Make the password dialogue banner display the netbsd PKGREVISION

number, if there was one (which, of course, makes me bump PKGREVISION
to 1 for all three xscreensaver pkgs (are we really supposed to bump
PKGREVISION for each pkg individually?)).  This eliminates the
confusion where pkg_info says version "4.14nb1" is installed, yet the
dialogue says it's onlu version "4.14".

Also, fix the conflicts for the screensaver pkg so that it properly
conflicts with xscreensaver-gnome<4.14 (not <1.14).
This commit is contained in:
atatat 2003-12-18 13:49:17 +00:00
parent bfc83ae39f
commit e10da302d3
6 changed files with 35 additions and 6 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/12/13 19:23:43 jmmv Exp $
# $NetBSD: Makefile,v 1.2 2003/12/18 13:49:17 atatat Exp $
#
PKGNAME= ${DISTNAME:S/-/-demo-/}
COMMENT= Screen saver and locker for the X window system (demo program)
PKGREVISION= 1
CONFLICTS+= xscreensaver<4.14 xscreensaver-gnome-[0-9]*

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.23 2003/12/13 19:22:13 jmmv Exp $
# $NetBSD: Makefile,v 1.24 2003/12/18 13:49:17 atatat Exp $
#
PKGNAME= ${DISTNAME:S/-/-gnome-/}
COMMENT= Screen saver and locker for the X window system (GNOME applet)
PKGREVISION= 1
CONFLICTS+= xscreensaver<4.14 xscreensaver-demo-[0-9]*

View file

@ -1,9 +1,10 @@
# $NetBSD: Makefile,v 1.62 2003/12/13 19:22:12 jmmv Exp $
# $NetBSD: Makefile,v 1.63 2003/12/18 13:49:17 atatat Exp $
#
COMMENT= Screen saver and locker for the X window system
PKGREVISION= 1
CONFLICTS+= xscreensaver-gnome<1.14
CONFLICTS+= xscreensaver-gnome<4.14
.include "../../x11/xscreensaver/Makefile.common"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.60 2003/12/16 07:08:10 tron Exp $
# $NetBSD: Makefile.common,v 1.61 2003/12/18 13:49:17 atatat Exp $
#
DISTNAME= xscreensaver-4.14
@ -27,6 +27,9 @@ CONFIGURE_ENV+= X_PRE_LIBS=-lXt
CONFIGURE_ENV+= ac_cv_x_app_defaults="${PREFIX}/lib/X11/app-defaults"
CONFIGURE_ENV+= PERL="${PERL5}" ac_cv_perl_version="${PERL_VERSION}"
CONFIGURE_ENV+= INTLTOOL_PERL="${PERL5}"
.if defined(PKGREVISION)
CONFIGURE_ENV+= X_CFLAGS="-DPKGREVISION=${PKGREVISION}"
.endif
CONFIGURE_ARGS+= ac_cv_path_INTLTOOL_PERL="${PERL5}"
MAKE_ENV+= KDEDIR=${PREFIX}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.32 2003/12/13 19:22:13 jmmv Exp $
$NetBSD: distinfo,v 1.33 2003/12/18 13:49:17 atatat Exp $
SHA1 (xscreensaver-4.14.tar.gz) = 4996718deaceeb578953f400e518b745c1dd32c4
Size (xscreensaver-4.14.tar.gz) = 3988251 bytes
@ -7,4 +7,5 @@ SHA1 (patch-ab) = 3dc02761edb19658e17935bd245208fa7387316d
SHA1 (patch-ac) = 9b82326439791ecc8e05e85a4d691109b4e50e68
SHA1 (patch-ad) = 244908c3e4c278c878bf89e07bd68efb62b3fc4d
SHA1 (patch-ae) = 16d0c8b50b2601458aaec09d1c7425fb23308225
SHA1 (patch-af) = 2340efe0cf677a20c336570b24374d675f5cd6eb
SHA1 (patch-ag) = e4f2332a349a94162f057601a69498a171ad4114

View file

@ -0,0 +1,22 @@
$NetBSD: patch-af,v 1.13 2003/12/18 13:49:17 atatat Exp $
Make the password dialogue banner display the netbsd PKGREVISION
number, if there was one.
--- driver/xscreensaver.c.orig 2003-10-07 04:59:40.000000000 -0400
+++ driver/xscreensaver.c
@@ -478,9 +478,13 @@ set_version_string (saver_info *si, int
*s = '_';
}
- si->version = (char *) malloc (5);
+ si->version = (char *) malloc (32);
memcpy (si->version, screensaver_id + 17, 4);
si->version [4] = 0;
+
+#if PKGREVISION > 0
+ (void)snprintf(si->version, 10, "%.4snb%d", screensaver_id + 17, PKGREVISION);
+#endif
}