Allow the one-true-shell to work on DragonFly. Patches are included
upstream already.
This commit is contained in:
parent
f4c004c852
commit
e11995dcd3
13 changed files with 174 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.26 2005/08/07 20:18:07 hiramatsu Exp $
|
||||
# $NetBSD: Makefile.common,v 1.27 2005/10/11 12:43:00 joerg Exp $
|
||||
|
||||
DISTNAME= zsh-${ZSH_VERSION}
|
||||
CATEGORIES= shells
|
||||
|
@ -57,7 +57,7 @@ LDFLAGS+= ${COMPILER_RPATH_FLAG}${PREFIX}/lib/zsh
|
|||
|
||||
. if ${OPSYS} == "Linux" || ${OPSYS} == "IRIX" || ${OPSYS} == "OpenBSD"
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.terminfo
|
||||
. elif ${OPSYS} == "Interix"
|
||||
. elif ${OPSYS} == "Interix" || ${OPSYS} == "DragonFly"
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.terminfo ${PKGDIR}/PLIST.shlibs
|
||||
. else
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.shlibs
|
||||
|
@ -79,6 +79,9 @@ PKG_SHELL= bin/zsh
|
|||
|
||||
INSTALL_TARGET= install install.info
|
||||
|
||||
pre-install:
|
||||
@cd ${WRKSRC}/Completion; find . -name \*.orig -exec rm \{\} \;
|
||||
|
||||
post-install:
|
||||
@${INSTALL_DATA_DIR} ${PREFIX}/share/doc/zsh
|
||||
@cd ${WRKSRC}/Etc; ${INSTALL_DATA} BUGS FAQ \
|
||||
|
|
|
@ -1,9 +1,19 @@
|
|||
$NetBSD: distinfo,v 1.22 2005/04/07 14:16:41 adam Exp $
|
||||
$NetBSD: distinfo,v 1.23 2005/10/11 12:43:00 joerg Exp $
|
||||
|
||||
SHA1 (zsh-4.2.5.tar.bz2) = 4dc142eb37c4dadae29ed7fb51756ed89ba64263
|
||||
RMD160 (zsh-4.2.5.tar.bz2) = 10e2319b30d5791d39c0a4488e297d451adbdbe5
|
||||
Size (zsh-4.2.5.tar.bz2) = 2074535 bytes
|
||||
SHA1 (patch-aa) = 5e5fde0f21a64c2e0579958868b05737ef0c6afb
|
||||
SHA1 (patch-ab) = 815de90c379035dbc02b251cee148f6df47f9a65
|
||||
SHA1 (patch-ac) = fdcdd3996008a6ce61352251e652d6223fc0b400
|
||||
SHA1 (patch-ac) = 821c6f60ddfddb72e14d5a33b1b448b2c5c0a036
|
||||
SHA1 (patch-ad) = a10254d6ab2833c412c07ccf2c9850146330b812
|
||||
SHA1 (patch-ae) = 7d4514d0bad6553d3c0cf115874bf50ed0da3d48
|
||||
SHA1 (patch-af) = 82112d5a986a411ef786a77aef8318b0382b55a8
|
||||
SHA1 (patch-ag) = 226bd32c4773f774fc32917995d22e6862c9a29a
|
||||
SHA1 (patch-ah) = 7c3c8f0248514d9d5b49aa7614b9d904818ee2ef
|
||||
SHA1 (patch-ai) = 8860dff9d404d37c533b4a504deacd2fd53ae75f
|
||||
SHA1 (patch-aj) = 63ab6c60ced9797f85fd4f6d66378d075df80d3f
|
||||
SHA1 (patch-ak) = 94357cd693db8883573d151ada587d97182dbc22
|
||||
SHA1 (patch-al) = 5d64cc17df312921be919c4398194c6c14dce769
|
||||
SHA1 (patch-am) = 0c3c403e35b1ae274874f17eac6807d7b7289ca2
|
||||
SHA1 (patch-an) = 68349a486e06264a6e07858d1471c56a351929e5
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.18 2005/04/07 14:16:41 adam Exp $
|
||||
$NetBSD: patch-ac,v 1.19 2005/10/11 12:43:00 joerg Exp $
|
||||
|
||||
--- configure.orig 2005-04-04 09:49:26.000000000 +0000
|
||||
+++ configure
|
||||
@@ -15724,6 +15724,10 @@ echo "${ECHO_T}$zsh_cv_sys_elf" >&6
|
||||
--- configure.orig 2005-04-04 11:49:26.000000000 +0200
|
||||
+++ configure 2005-05-10 00:02:26.000000000 +0200
|
||||
@@ -15724,6 +15724,10 @@
|
||||
DLLD="${DLLD=$CC}"
|
||||
DLLDARG=""
|
||||
;;
|
||||
|
@ -13,7 +13,7 @@ $NetBSD: patch-ac,v 1.18 2005/04/07 14:16:41 adam Exp $
|
|||
* )
|
||||
DLLD="${DLLD=ld}"
|
||||
DLLDARG=""
|
||||
@@ -15734,6 +15738,7 @@ echo "${ECHO_T}$zsh_cv_sys_elf" >&6
|
||||
@@ -15734,6 +15738,7 @@
|
||||
case "$host_os" in
|
||||
hpux*) DLLDFLAGS="${DLLDFLAGS=-shared}" ;;
|
||||
darwin*) DLCFLAGS="${DLCFLAGS=-fno-common}" ;;
|
||||
|
@ -21,12 +21,12 @@ $NetBSD: patch-ac,v 1.18 2005/04/07 14:16:41 adam Exp $
|
|||
*) DLCFLAGS="${DLCFLAGS=-fPIC}" ;;
|
||||
esac
|
||||
else
|
||||
@@ -15747,7 +15752,7 @@ echo "${ECHO_T}$zsh_cv_sys_elf" >&6
|
||||
@@ -15747,7 +15752,7 @@
|
||||
esac
|
||||
fi
|
||||
case "$host_os" in
|
||||
- freebsd*|linux*|irix*|osf*|gnu*) DLLDFLAGS="${DLLDFLAGS=-shared}" ;;
|
||||
+ freebsd*|linux*|irix*|osf*|gnu*|interix*) DLLDFLAGS="${DLLDFLAGS=-shared}" ;;
|
||||
+ freebsd*|linux*|irix*|osf*|gnu*|interix*|dragonfly*) DLLDFLAGS="${DLLDFLAGS=-shared}" ;;
|
||||
sunos*) DLLDFLAGS="${DLLDFLAGS=-assert nodefinitions}" ;;
|
||||
sysv4*|esix*) DLLDFLAGS="${DLLDFLAGS=-G $ldflags}" ;;
|
||||
netbsd*) DLLDFLAGS="${DLLDFLAGS=${DLLDARG}-x -shared --whole-archive}" ;;
|
||||
|
|
11
shells/zsh/patches/patch-ad
Normal file
11
shells/zsh/patches/patch-ad
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/BSD/Command/_chflags.orig 2005-05-09 23:55:24.000000000 +0200
|
||||
+++ Completion/BSD/Command/_chflags 2005-05-09 23:55:03.000000000 +0200
|
||||
@@ -25,7 +25,7 @@
|
||||
unset own
|
||||
fi
|
||||
|
||||
-if [[ $OSTYPE = freebsd* ]]; then
|
||||
+if [[ $OSTYPE = freebsd* || $OSTYPE = dragonfly* ]]; then
|
||||
flags=( $flags[@]
|
||||
'(nouunlnk)uunlnk[set the user undeletable flag]'
|
||||
'(uunlnk)nouunlnk[unset the user undeletable flag]'
|
11
shells/zsh/patches/patch-af
Normal file
11
shells/zsh/patches/patch-af
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/Unix/Command/_apm.orig 2005-05-09 23:57:43.000000000 +0200
|
||||
+++ Completion/Unix/Command/_apm 2005-05-09 23:58:44.000000000 +0200
|
||||
@@ -11,7 +11,7 @@
|
||||
'(-n --noignore)'{-n,--noignore}'[tell the system not to ignore system-generated APM message]' \
|
||||
'(-i --ignore)'{-i,--ignore}'[tell the system to ignore system-generated APM message]' && return
|
||||
|
||||
-elif [[ $OSTYPE == freebsd* ]]; then
|
||||
+elif [[ $OSTYPE == freebsd* || $OSTYPE = dragonfly* ]]; then
|
||||
|
||||
_arguments \
|
||||
'-a[display AC line status]' \
|
11
shells/zsh/patches/patch-ag
Normal file
11
shells/zsh/patches/patch-ag
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/Unix/Command/_cvs.orig 2005-05-09 23:57:52.000000000 +0200
|
||||
+++ Completion/Unix/Command/_cvs 2005-05-09 23:59:19.000000000 +0200
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
# "+Qqrwtnlvb:T:e:d:Hfz:s:xa"
|
||||
case $OSTYPE in
|
||||
- freebsd*|openbsd*)
|
||||
+ freebsd*|openbsd*|dragonfly*)
|
||||
extra='-R[read only access]'
|
||||
;;
|
||||
esac
|
11
shells/zsh/patches/patch-ah
Normal file
11
shells/zsh/patches/patch-ah
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/Unix/Command/_ifconfig.orig 2005-05-09 23:57:59.000000000 +0200
|
||||
+++ Completion/Unix/Command/_ifconfig 2005-05-09 23:58:49.000000000 +0200
|
||||
@@ -19,7 +19,7 @@
|
||||
{,-}trailers {,-}link{0,1,2}
|
||||
)
|
||||
;;
|
||||
- freebsd*)
|
||||
+ freebsd* | dragonfly*)
|
||||
args=( -s $updown
|
||||
'(-a -l -u -d -m -L 1 *)-C[list interface cloners]'
|
||||
'(-l -C)-m[list supported media]'
|
38
shells/zsh/patches/patch-ai
Normal file
38
shells/zsh/patches/patch-ai
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- Completion/Unix/Command/_mount.orig 2005-05-09 23:58:03.000000000 +0200
|
||||
+++ Completion/Unix/Command/_mount 2005-05-09 23:59:50.000000000 +0200
|
||||
@@ -471,7 +471,7 @@
|
||||
'swidth[specify stripe width]:size'
|
||||
)
|
||||
;;
|
||||
- freebsd*)
|
||||
+ freebsd*|dragonfly*)
|
||||
_fs_any=(
|
||||
'(sync)async[do all I/O asynchronously]'
|
||||
'current[use current options on already mounted file system]'
|
||||
@@ -626,7 +626,7 @@
|
||||
deffs=hsfs
|
||||
typeops=-F
|
||||
;;
|
||||
- freebsd*)
|
||||
+ freebsd*|dragonfly*)
|
||||
args=( -s
|
||||
'(:)-a[mount all filesystems in fstab]'
|
||||
'-d[cause everything to be done except for the actual system call]'
|
||||
@@ -700,7 +700,7 @@
|
||||
'*:dev or dir:->udevordir'
|
||||
)
|
||||
;;
|
||||
- freebsd*)
|
||||
+ freebsd*|dragonfly*)
|
||||
args=(
|
||||
'(*)-a[unmount all mounted file systems]'
|
||||
'-A[unmount all mounted file systems except the root]'
|
||||
@@ -762,7 +762,7 @@
|
||||
fi
|
||||
|
||||
case "$OSTYPE" in
|
||||
- freebsd*)
|
||||
+ freebsd*|dragonfly*)
|
||||
while read mline; do
|
||||
case $mline[(w)1] in
|
||||
\#* )
|
11
shells/zsh/patches/patch-aj
Normal file
11
shells/zsh/patches/patch-aj
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/Unix/Command/_mt.orig 2005-05-09 23:58:35.000000000 +0200
|
||||
+++ Completion/Unix/Command/_mt 2005-05-09 23:57:23.000000000 +0200
|
||||
@@ -44,7 +44,7 @@
|
||||
'densities:explain some common density codes'
|
||||
'datcompression:enquire or set compression status'
|
||||
)
|
||||
-elif [[ $OSTYPE = freebsd* ]]; then
|
||||
+elif [[ $OSTYPE = freebsd* || $OSTYPE = dragonfly* ]]; then
|
||||
cmds=( ${cmds:#(asf|eof):*}
|
||||
'smk:write specified number of setmarks at current position'
|
||||
'fss:forward space by specified number of setmarks'
|
11
shells/zsh/patches/patch-ak
Normal file
11
shells/zsh/patches/patch-ak
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/Unix/Command/_sysctl.orig 2005-05-09 23:58:13.000000000 +0200
|
||||
+++ Completion/Unix/Command/_sysctl 2005-05-09 23:58:54.000000000 +0200
|
||||
@@ -13,7 +13,7 @@
|
||||
'(-o)-x[show opaques as well (entire values)]' \
|
||||
'(-a)*:sysctl variable:_multi_parts -i . sysctlvars'
|
||||
;;
|
||||
- freebsd[0-4].*|darwin*)
|
||||
+ freebsd[0-4].*|darwin*|dragonfly*)
|
||||
: ${(A)_cache_sysctlvars:=${${$(sysctl -A 2>/dev/null):#[^a-z]*}%%:*}}
|
||||
_arguments -s -A "-*" \
|
||||
'(-w -X *)-a[list all]' \
|
14
shells/zsh/patches/patch-al
Normal file
14
shells/zsh/patches/patch-al
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- Completion/Unix/Type/_file_systems.orig 2005-05-09 23:58:17.000000000 +0200
|
||||
+++ Completion/Unix/Type/_file_systems 2005-05-10 00:00:42.000000000 +0200
|
||||
@@ -16,9 +16,9 @@
|
||||
;;
|
||||
osf*) fss=( advfs ufs nfs mfs cdfs ) ;;
|
||||
solaris*) fss=( ufs nfs hsfs s5fs pcfs cachefs tmpfs ) ;;
|
||||
- freebsd*)
|
||||
+ freebsd*|dragonfly*)
|
||||
fss=( cd9660 devfs ext2fs fdesc kernfs linprocfs mfs msdos nfs
|
||||
- ntfs null nwfs portal procfs std ufs umap union )
|
||||
+ ntfs null nwfs portal procfs std udf ufs umap union )
|
||||
;;
|
||||
*)
|
||||
# default for all other systems
|
11
shells/zsh/patches/patch-am
Normal file
11
shells/zsh/patches/patch-am
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Completion/Unix/Type/_net_interfaces.orig 2005-05-09 23:58:21.000000000 +0200
|
||||
+++ Completion/Unix/Type/_net_interfaces 2005-05-10 00:00:05.000000000 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
disp=(-ld list)
|
||||
fi
|
||||
;;
|
||||
- darwin*|freebsd*) intf=( $(ifconfig -l) ) ;;
|
||||
+ darwin*|freebsd*|dragonfly*) intf=( $(ifconfig -l) ) ;;
|
||||
irix*) intf=( ${${${(f)"$(/usr/etc/netstat -i)"}%% *}[2,-1]} ) ;;
|
||||
linux*) intf=( /proc/sys/net/ipv4/conf/*~*(all|default)(N:t) ) ;;
|
||||
*) intf=( $(ifconfig -a|sed -n 's/^\([^ :]*\).*/\1/p') ) ;;
|
21
shells/zsh/patches/patch-an
Normal file
21
shells/zsh/patches/patch-an
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- Src/Modules/zpty.c.orig 2004-06-03 00:15:01.000000000 +0200
|
||||
+++ Src/Modules/zpty.c 2005-05-10 00:01:41.000000000 +0200
|
||||
@@ -246,15 +246,13 @@
|
||||
#ifdef __linux
|
||||
static char char1[] = "abcdefghijklmnopqrstuvwxyz";
|
||||
static char char2[] = "0123456789abcdef";
|
||||
-#else /* __linux */
|
||||
-# ifdef __FreeBSD__
|
||||
+#elif defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
static char char1[] = "pqrsPQRS";
|
||||
static char char2[] = "0123456789abcdefghijklmnopqrstuv";
|
||||
-# else /* __FreeBSD__ */
|
||||
+#else /* __FreeBSD__ || __DragonFly__ */
|
||||
static char char1[] = "pqrstuvwxyzPQRST";
|
||||
static char char2[] = "0123456789abcdef";
|
||||
-# endif /* __FreeBSD__ */
|
||||
-#endif /* __linux */
|
||||
+#endif
|
||||
|
||||
static char name[11];
|
||||
static int mfd, sfd;
|
Loading…
Reference in a new issue