update to 0.2.4

change: adjust to newer ffmpeg API
This commit is contained in:
drochner 2012-10-25 10:27:11 +00:00
parent 300826f85f
commit e11d2186dd
7 changed files with 6 additions and 92 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.5 2012/10/23 17:18:33 asau Exp $
# $NetBSD: Makefile,v 1.6 2012/10/25 10:27:11 drochner Exp $
#
DISTNAME= libdlna-0.2.3
PKGREVISION= 2
DISTNAME= libdlna-0.2.4
CATEGORIES= net
MASTER_SITES= http://libdlna.geexbox.org/releases/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,11 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/05/23 08:03:18 obache Exp $
$NetBSD: distinfo,v 1.2 2012/10/25 10:27:11 drochner Exp $
SHA1 (libdlna-0.2.3.tar.bz2) = 87159167610abde806a7addb8e425dbdc446856e
RMD160 (libdlna-0.2.3.tar.bz2) = b6ef7cca1c661b95d3f8892ad99179fae9ddfbf4
Size (libdlna-0.2.3.tar.bz2) = 37142 bytes
SHA1 (patch-aa) = 2ecdb279c68f5411c0c53de4f544ba84042a5af9
SHA1 (patch-ab) = cd12b7c6a0055402047ccd7e7f6c7cdc1b997417
SHA1 (patch-ac) = e5258dea39c7fd33cc123896830a6e1b15c25e3d
SHA1 (patch-ad) = 5a30c1491d4b5aa8a90187ca2f1096e9523e9e7c
SHA1 (patch-ae) = 97323e8fd202880b5b1fcad6ae544fbdd25e0abe
SHA1 (libdlna-0.2.4.tar.bz2) = 5e86f4443eeb9e7194c808301efeb78611a9e8b3
RMD160 (libdlna-0.2.4.tar.bz2) = 6083bdcb7b5bc048f5b81373ef452145ba913861
Size (libdlna-0.2.4.tar.bz2) = 37579 bytes
SHA1 (patch-af) = b34c260bf86062d268a8f113df17e285ed6ecdb7

View file

@ -1,18 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/05/23 08:03:18 obache Exp $
Adjust header file locations for ffmpeg changes.
--- configure.orig 2007-11-26 20:47:43.000000000 +0000
+++ configure
@@ -610,9 +610,9 @@ if [ -n "$ffmpegdir" ]; then
fi
echolog "Checking for libavformat ..."
-check_lib ffmpeg/avformat.h av_register_all -lavformat || die "Error, can't find libavformat !"
+check_lib libavformat/avformat.h av_register_all -lavformat || die "Error, can't find libavformat !"
echolog "Checking for libavcodec ..."
-check_lib ffmpeg/avcodec.h avcodec_register_all -lavcodec || die "Error, can't find libavcodec !"
+check_lib libavcodec/avcodec.h avcodec_register_all -lavcodec || die "Error, can't find libavcodec !"
#################################################
# version

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2010/05/23 08:03:18 obache Exp $
Adjust header file locations for ffmpeg changes.
--- src/profiles.h.orig 2007-11-26 20:47:43.000000000 +0000
+++ src/profiles.h
@@ -22,8 +22,8 @@
#ifndef _PROFILES_H_
#define _PROFILES_H_
-#include <ffmpeg/avcodec.h>
-#include <ffmpeg/avformat.h>
+#include <libavcodec/avcodec.h>
+#include <libavformat/avformat.h>
#include "dlna_internals.h"
#include "containers.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2010/05/23 08:03:18 obache Exp $
Adjust header file locations for ffmpeg changes.
--- src/containers.c.orig 2007-11-26 20:47:43.000000000 +0000
+++ src/containers.c
@@ -4,7 +4,7 @@
#include <sys/stat.h>
#include <fcntl.h>
-#include <ffmpeg/avformat.h>
+#include <libavformat/avformat.h>
#include "containers.h"
#include "profiles.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2010/05/23 08:03:18 obache Exp $
Adjust header file locations for ffmpeg changes.
--- src/av_mpeg4_part10.c.orig 2007-11-26 20:47:43.000000000 +0000
+++ src/av_mpeg4_part10.c
@@ -26,7 +26,7 @@
#include <sys/stat.h>
#include <fcntl.h>
-#include <ffmpeg/avcodec.h>
+#include <libavcodec/avcodec.h>
#include "dlna_internals.h"
#include "profiles.h"

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 2010/05/23 08:03:18 obache Exp $
Adjust header file locations for ffmpeg changes.
--- src/av_mpeg4_part2.c.orig 2007-11-26 20:47:43.000000000 +0000
+++ src/av_mpeg4_part2.c
@@ -26,7 +26,7 @@
#include <sys/stat.h>
#include <fcntl.h>
-#include <ffmpeg/avcodec.h>
+#include <libavcodec/avcodec.h>
#include "dlna_internals.h"
#include "profiles.h"