The author assumes defined(__STDC__) && defined(__sun__) results in no

<stdarg.h> available... this is not the case with even vaguely recent
gcc on Solaris.
Build fixed, Man page installation stays broken on Solaris as it is a
different (and more general) problem.
This commit is contained in:
is 2010-01-07 15:22:49 +00:00
parent 63b6a09f7d
commit e12effce71
5 changed files with 45 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.14 2008/07/14 12:56:04 joerg Exp $
# $NetBSD: Makefile,v 1.15 2010/01/07 15:22:49 is Exp $
#
DISTNAME= xpilot-4.5.4
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= games x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xpilotgame/}

View file

@ -1,7 +1,10 @@
$NetBSD: distinfo,v 1.8 2006/01/23 16:46:20 joerg Exp $
$NetBSD: distinfo,v 1.9 2010/01/07 15:22:49 is Exp $
SHA1 (xpilot-4.5.4.tar.gz) = d295977be8c27c3b9aecf8e69061a451bf8d7e4b
RMD160 (xpilot-4.5.4.tar.gz) = db8e62fbfa7a7ba19abeb41da651ae4b0298bbc2
Size (xpilot-4.5.4.tar.gz) = 1384615 bytes
SHA1 (patch-aa) = 8cd85761965ded5186d19a7553b10c75dcc34b4f
SHA1 (patch-ab) = 26e80e4ef932bc2f5ebcff19b2d41f83641be83c
SHA1 (patch-ac) = 949ea447de5bd653a849ec16fc044c803615f6c6
SHA1 (patch-ad) = 88ffc97307afe633a626027d6699bb08b3c0827e
SHA1 (patch-ae) = a459b61013bddc3b214811568cf660131221b7da

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2010/01/07 15:22:49 is Exp $
--- src/common/error.h.orig 2001-05-30 11:34:15.000000000 -0700
+++ src/common/error.h
@@ -34,7 +34,7 @@
#ifndef ERROR_H
#define ERROR_H
-# if (defined(__STDC__) && !defined(__sun__) || defined(__cplusplus) || defined(_WINDOWS))
+# if (defined(__STDC__) || defined(__cplusplus) || defined(_WINDOWS))
# include <stdarg.h>
extern void warn(const char *fmt, ...);
extern void error(const char *fmt, ...);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2010/01/07 15:22:49 is Exp $
--- src/common/error.c.orig 2001-05-27 10:15:04.000000000 -0700
+++ src/common/error.c
@@ -36,7 +36,7 @@
#undef HAVE_STDARG
#undef HAVE_VARARG
#ifndef _WINDOWS
-# if (defined(__STDC__) && !defined(__sun__) || defined(__cplusplus))
+# if (defined(__STDC__) || defined(__cplusplus))
# define HAVE_STDARG 1
# else
# define HAVE_VARARG 1

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2010/01/07 15:22:49 is Exp $
--- src/common/net.h.orig 2001-06-02 14:02:14.000000000 -0700
+++ src/common/net.h
@@ -84,7 +84,7 @@ int Sockbuf_read(sockbuf_t *sbuf);
int Sockbuf_copy(sockbuf_t *dest, sockbuf_t *src, int len);
#if !defined(STDVA)
-# if defined(__STDC__) && !defined(__sun__) || defined(__cplusplus)
+# if defined(__STDC__) || defined(__cplusplus)
# define STDVA 1 /* has ANSI stdarg stuff */
# else
# define STDVA 0 /* nope, still the K&R way */