xu4: fix build with libxml2 2.2

This commit is contained in:
wiz 2024-02-01 09:33:08 +00:00
parent e7b7b93377
commit e205d7a585
3 changed files with 27 additions and 1 deletions

View File

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2021/10/26 10:44:36 nia Exp $
$NetBSD: distinfo,v 1.9 2024/02/01 09:33:08 wiz Exp $
BLAKE2s (xu4-1.0beta3.tar.gz) = 0b7b4e07e3edeb98ac03b0b597ca61ff72dff461c6f04a84e22e7ce3db1f47a2
SHA512 (xu4-1.0beta3.tar.gz) = b62f7d737f31f5cc25dc8c7bb8821f6360dbfec05fe4ba671ae9561cd9bc9fba1f28d35ac3eab9e7c40afbfded25229083a7383c5d6f102f2265b2bca763cd76
@ -6,6 +6,7 @@ Size (xu4-1.0beta3.tar.gz) = 418477 bytes
SHA1 (patch-src_Makefile) = ac80c253affd3b150a377cd0072db9557c26407b
SHA1 (patch-src_armor.cpp) = 1cc4ad07efaa70c5764b910d055939e22b4287d5
SHA1 (patch-src_codex.cpp) = 706aa3a6854b72ae6ada927cc1bd1c71f7c4959e
SHA1 (patch-src_config.h) = b2f5c1fcb6685f39ee8544e989d624d36ea26c54
SHA1 (patch-src_conversation.cpp) = 15ea5eed4abe11e7afb58359b6cd732b1e84b458
SHA1 (patch-src_creature.cpp) = 9479f075c95b481bae073011c72672b383a5f7e4
SHA1 (patch-src_debug.h) = 7c5e021bbc0edd355146440b57eea30ca87d77a7
@ -30,3 +31,4 @@ SHA1 (patch-src_stats.cpp) = da37132d4c710e5dda29b222d27aed84fcd250d1
SHA1 (patch-src_textview.cpp) = 18da8c99836c4a277c1f674b03f7c77da58f020e
SHA1 (patch-src_u4file.cpp) = 70d8d1650d0888d56c2d9f720b1d4b715b8502dd
SHA1 (patch-src_weapon.cpp) = d87690c8ed0b63be171437b2331955284859be97
SHA1 (patch-src_xml.h) = 44ee956ba789de51ff9772ac80a054c1392c539b

View File

@ -0,0 +1,12 @@
$NetBSD: patch-src_config.h,v 1.1 2024/02/01 09:33:08 wiz Exp $
--- src/config.h.orig 2024-02-01 09:31:34.669422918 +0000
+++ src/config.h
@@ -8,6 +8,7 @@
#include "vc6.h" // Fixes things if you're using VC6, does nothing if otherwise
#include <string>
#include <vector>
+#include <libxml/tree.h>
#include <libxml/xmlmemory.h>
class ConfigElement;

View File

@ -0,0 +1,12 @@
$NetBSD: patch-src_xml.h,v 1.1 2024/02/01 09:33:08 wiz Exp $
--- src/xml.h.orig 2024-02-01 09:30:08.504957542 +0000
+++ src/xml.h
@@ -6,6 +6,7 @@
#define XML_H
#include <string>
+#include <libxml/parser.h>
#include <libxml/xmlmemory.h>
xmlDocPtr xmlParse(const char *filename);