Fix pthread detection.

This commit is contained in:
joerg 2006-04-28 18:23:28 +00:00
parent af247ba259
commit e2206eea32
3 changed files with 34 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.14 2006/04/22 15:05:39 jschauma Exp $
# $NetBSD: Makefile,v 1.15 2006/04/28 18:23:28 joerg Exp $
DISTNAME= cinepaint-0.20-2
PKGNAME= cinepaint-0.20.2
@ -26,5 +26,6 @@ BUILDLINK_API_DEPENDS.lcms+= lcms>=1.13 # needs _cmsLCMScolorSpace
.include "../../graphics/tiff/buildlink3.mk"
.include "../../x11/fltk/buildlink3.mk"
.include "../../x11/gtk/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.6 2006/01/31 21:06:56 adam Exp $
$NetBSD: distinfo,v 1.7 2006/04/28 18:23:28 joerg Exp $
SHA1 (cinepaint-0.20-2.tar.gz) = 67ef64c1708553fc50f28c622d016e6388df079b
RMD160 (cinepaint-0.20-2.tar.gz) = 637396d43db8e6bd00d6b28fc754315be8db2d9c
Size (cinepaint-0.20-2.tar.gz) = 7550210 bytes
SHA1 (patch-aa) = 2259896756f3371589b4a83655e4c118d0247302
SHA1 (patch-ab) = 1e03ffb0deab12b229f2604083bd3515a80747ac
SHA1 (patch-ac) = c6a506ffedd7d08832256243fd67981f7ee9679f

View file

@ -0,0 +1,30 @@
$NetBSD: patch-ac,v 1.3 2006/04/28 18:23:28 joerg Exp $
--- configure.orig 2006-04-28 17:23:15.000000000 +0000
+++ configure
@@ -22212,13 +22212,13 @@ _ACEOF
fi
if test -z "$THREAD_LIBS"; then
- echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
-echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
+ echo "$as_me:$LINENO: checking for pthread_create in ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}" >&5
+echo $ECHO_N "checking for pthread_create in ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}... $ECHO_C" >&6
if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpthread $LIBS"
+LIBS="${PTHREAD_LDFLAGS} ${PTHREAD_LIBS} $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -22277,7 +22277,7 @@ fi
echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
echo "${ECHO_T}$ac_cv_lib_pthread_pthread_create" >&6
if test $ac_cv_lib_pthread_pthread_create = yes; then
- THREAD_LIBS='-lpthread'
+ THREAD_LIBS='${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}'
else
echo "$as_me:$LINENO: result: none" >&5
echo "${ECHO_T}none" >&6