Let mplayer autocomplete .webm files.

Bump PKGREVISION.
This commit is contained in:
wiz 2011-12-14 11:09:33 +00:00
parent b8cc478001
commit e24301fe02
3 changed files with 19 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.23 2011/07/30 11:53:52 ryoon Exp $
# $NetBSD: Makefile,v 1.24 2011/12/14 11:09:33 wiz Exp $
.include "../../shells/zsh/Makefile.common"
ZSH_VERSION= 4.3.12
PKGREVISION= 1
ZSH_MAINTAINER= ryoon@NetBSD.org
USE_TOOLS+= env

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.21 2011/11/11 18:45:46 joerg Exp $
$NetBSD: distinfo,v 1.22 2011/12/14 11:09:33 wiz Exp $
SHA1 (zsh-4.3.12.tar.bz2) = 8fd7a6d841770c8b12cf3ae8229dd857ecdbad93
RMD160 (zsh-4.3.12.tar.bz2) = 83f2a0f3e590722262e5725df97d924b1fd4ee84
Size (zsh-4.3.12.tar.bz2) = 2917959 bytes
SHA1 (patch-Completion_X_Command___mplayer) = 95a421f80a845dab6430a52f8155ecb02b8d5c14
SHA1 (patch-ab) = 577a98385f258cbc47ff49d0b4bc6cc9134e864a
SHA1 (patch-ac) = 23c086e61120f9c533e4a3a53e44c5b6b48b1352
SHA1 (patch-af) = cedd6fb7369b0fc9debbaab29aaf40c25c587123

View file

@ -0,0 +1,15 @@
$NetBSD: patch-Completion_X_Command___mplayer,v 1.1 2011/12/14 11:09:34 wiz Exp $
Add webm to mplayer autocompletion.
--- Completion/X/Command/_mplayer.orig 2010-06-06 13:44:12.000000000 +0000
+++ Completion/X/Command/_mplayer
@@ -115,7 +115,7 @@ case "$state" in
_tags files urls
while _tags; do
_requested files expl 'video file' _files -g \
- "*.(#i)(asf|asx|avi|flac|flv|m1v|m2p|m2v|mjpg|mka|mkv|mov|mp3|mp4|mpe|mpeg|mpg|ogg|ogm|qt|rm|vob|wav|wma|wmv)(-.)" && ret=0
+ "*.(#i)(asf|asx|avi|flac|flv|m1v|m2p|m2v|mjpg|mka|mkv|mov|mp3|mp4|mpe|mpeg|mpg|ogg|ogm|qt|rm|vob|wav|webm|wma|wmv)(-.)" && ret=0
if _requested urls; then
while _next_label urls expl URL; do
_urls "$expl[@]" && ret=0