Update to 1.0pre1 (renamed to 1.0rc1 for pkgsrc):

mplayer (1.0)
  pre1:  "Development" on the beach
    NOTE: the mplayer 'main' branch was forked at the time of 0.90-rc4, so
    0.90-rc5 (and later 0.90 releases) changes are independent!
    (it also means that there are main-only and 0_90-only changes)

    DOCS:
    * DOCS/Language/ dirs renamed to DOCS/id, English files moved to DOCS/en
    * HTML --> XML format conversion (English, Russian and French for now)
    * new Spanish DOCS translation
    * man page restructured, options ordered
    * Finally merged libavc-option.txt into the man page.
    * slave mode commands moved from the man page to DOCS/tech/
    * traditional Chinese help file added
    * massive help file updates, most languages are up to date now
    * new and improved Windows port section with Cygwin and MinGW subsections
    * almost all options documented
    * fixes and small updates all over the place

    Big/Structural changes:
    * linux/ dir renamed to osdep/
    * postproc/postproc* files moved to libavcodec
    * old libmpeg2 replaced with patched version of the 0.3.1 release
    * docs priority & installation (--language=ab,cd,ef,all and so on)
    * yuv2rgb conversion removed from most vo drivers (like fbdev, gif89 etc)
    * -vop option obsoleted by reverse-order -vf, big config layer changes
    * stream layer "cleanup", -dvd -> dvd:// etc
    * autosub fuzziness, it tries to load all subs with similar filenames
    * removed the whole old config reader, leaving only the newer one
      (no backward compatibilty!)

    Ports:
    * HP-UX fixes
    * Ported to Darwin / Mac OS X (with extra accurate Darwin timers)
    * Ported to Win32/MinGW (including network, timers, getch etc)
    * win32 codecs DLL support on Win32/Cygwin (and MinGW too!)
    * Lots of PPC (including Altivec) optimizations
    * Some ARM fixes
    * Alpha fixes (especially non-gcc3 support)
    * Initial Hitachi SuperH support (SH3/SH4)

    Codecs/demuxers support:
    * realaudio win32 DLLs support
    * various realaudio/realvideo fixes, including WxH bugs, Sipr etc
    * various realmedia a-v sync fixes
    * realaudio v4 demuxer
    * realaudio 14_4 and 28_8 codecs support (both binary DLLs and native code)
    * realmedia rtsp:// support (independent from the live.com rtsp stuff!)
    * Matroska demuxer
    * demuxer: enabling mpeg4-es autodetection, h264-es support
    * .wav extradata parsing (for truespeech, atrac3 etc)
    * MPEG-TS (Transport Stream) and TIVO demuxers
    * DVB (Digital Video Broadcasting) input driver
    * hwac3: DTS passthru support
    * new filters: down3dright, detc, telecine, tfields, ilpack, ivtc, dsize,
      tinterlace, pullup (mmx optimized!), framestep, tile
    * vf layer: slices support (crop, expand, swscale only)
    * vf scale aspect fixes
    * swscaler: cleanup & API change, yv12 -> yuy2 in alpha asm, -fPIC
      compileable
    * swscaler: brightness/cont/sat. and different YUV matrices support
    * NUV encoding
    * SGI image files decoding (-mf)
    * Theora video (using libtheora/libogg) support
    * DivX.com 5.0.5 libs support
    * support for latest XviD en/decoder features
    * decoder for Hauppauge PVR 250/350 MB-YUV format (fourcc HM12)
    * support for Vanguard's win32 h264 etc codecs
    * Video for Linux 1: various bugfixes, video eq support
    * Video for Linux 2 support
    * TV support: kick-ass image format handling
    * mp3lib: moved the assembly sources into gcc inline assembly (c)
    * mp3lib: sync with mpg123 0.59s-pre
    * mp3lib: final layer-1 support
    * mp3lib: skip trashed first mp3 frame, fixes lot of buggy/misdetected
      files
    * imported a working FAAD version
    * 8BPS (Planar RGB) support
    * working DVD (libmpdvdkit) support for Cygwin/MinGW

    FFmpeg/libavcodec:
    * libavcodec: static,const,compiler warning cleanup, UINTX -> uintx_t
    * old HuffYUV v1 support
    * PAL 4:1:1 SMPTE 314M DV streams support, NTSC DV last MB column fix
    * fixing padding bug autodetection for some rare files
    * DspContext.(i)dct_* bitexact cleanup
    * user settable quantizer bias
    * MPEG1 slice encoding support
    * MSMPEG4 2-pass support
    * H264 video decoding
    * Indeo 3 video decoding
    * VP3 video decoder (buggy somtimes)
    * Sorenson 3 (SVQ3) video decoder (it's actually a h264 variant)
    * 3IV1 (3ivx v1) decoding
    * ASV1 (ASUS Video v1) and ASV2 (ASUS Video v2) en/decoding
    * Improved SVQ1 decoding (using FFmpeg VLC functions)
    * truncated unary binarization, unary k-th order exp golomb binarization :)
    * FFV1: lossless YUV codec, compresses a lot better than huffyuv, but
      slower
    * lossless MJPEG en/decoding, pegasus "pseudo yuv" (=RCT) decoding
    * ATI VCR1 and VCR2 decoding
    * full featured SH4 optimizations
    * ARM optimized simple_idct
    * MPEG2 encoding
    * PSX MDEC decoder
    * user settable quantization matrices

    Drivers:
    * x11_common: fix detection of metacity
    * x11_common: 10l fix in original layer detection code
    * x11_common: extended fstype config options
    * x11_common: smooth window moving
    * tdfx_vid driver (3dfx cards overlay with AGP support)
    * vo_xover: general x11 overlay driver, currently only tdfx_vid uses it
    * mga_vid: various fixes, 16MB G400 detection, support for multiple cards
    * new svgalib vo driver
    * vo_directfb2: triple buffering support, configuration sys changed, fixes
    * OpenGL driver cleanups/fixes (both vo_gl and vo_gl2)
    * vo_fbdev cleanup/partial rewrite, now with real direct rendering
    * vo_xvmc: new driver featuring XvMC (HW MC/IDCT) acceleration
    * new TGA output driver
    * new vo_fbdev2 (written from scratch)

    Others:
    * gcc can now detect badly called mp_msg()s
    * a lot of config/cmdline parsing fixes (some of them were at least 100000l
      bugs)
    * configure: enable VIDIX for PPC
    * configure: full featured PPC optimizations and rewritten architecture
      handling
    * spudec.c: Fix "invalid fragment" handling, Improved subtitle queueing
    * network streaming layer: IPv6 support
    * FTP support
    * playtree parsing speedup :)
    * various URL parsing fixes
    * crashing on broken config files finally fixed!
    * GUI: PPC (reverse byteorder) fixes
    * GUI: revert to 'default' skin if configured skin failed
    * TOOLS/plotpsnr.pl: PSNR plotting tool using gnuplot
    * DOCS/tech/mpcf.txt: MPCF/NUT draft/specification
    * TVout/matroxtv: various improvements
    * spelling/grammar fixes in numerous files
This commit is contained in:
jmmv 2003-09-02 17:46:31 +00:00
parent 7e78d9f9d1
commit e2475bde3b
10 changed files with 125 additions and 150 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2003/08/31 00:25:19 xtraeme Exp $
# $NetBSD: Makefile,v 1.25 2003/09/02 17:46:36 jmmv Exp $
#
PKGNAME= gmplayer-${MPLAYER_PKG_VERSION}
@ -51,7 +51,7 @@ do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/mplayer/Skin
.for SKIN in ${SKINS}
@${ECHO_MSG} "Installing skin ${SKIN}..."
@${GTAR} xCzf ${PREFIX}/share/mplayer/Skin/ ${DISTDIR}/${DIST_SUBDIR}/${SKIN}
@${GTAR} xCmzf ${PREFIX}/share/mplayer/Skin/ ${DISTDIR}/${DIST_SUBDIR}/${SKIN}
.endfor
@${CHMOD} -R a+r ${PREFIX}/share/mplayer/Skin
@${CHMOD} a+rx ${PREFIX}/share/mplayer/Skin/*

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2003/07/24 12:56:52 tron Exp $
@comment $NetBSD: PLIST,v 1.9 2003/09/02 17:46:37 jmmv Exp $
bin/gmplayer
man/man1/gmplayer.1
share/mplayer/Skin/AlienMind/README
@ -538,8 +538,8 @@ share/mplayer/Skin/xine-lcd/volume.png
@dirrm share/mplayer/Skin/WindowsMediaPlayer6
@dirrm share/mplayer/Skin/MidnightLove
@dirrm share/mplayer/Skin/Cyrus
@dirrm share/mplayer/Skin/CornerMP
@dirrm share/mplayer/Skin/CornerMP-aqua
@dirrm share/mplayer/Skin/CornerMP
@dirrm share/mplayer/Skin/BlueHeart
@dirrm share/mplayer/Skin/AlienMind
@dirrm share/mplayer/Skin

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.35 2003/08/31 00:25:19 xtraeme Exp $
$NetBSD: distinfo,v 1.36 2003/09/02 17:46:37 jmmv Exp $
SHA1 (mplayer/MPlayer-0.91.tar.bz2) = c468c1c7044283def3064ef94dd691367973ea01
Size (mplayer/MPlayer-0.91.tar.bz2) = 3467061 bytes
SHA1 (mplayer/MPlayer-1.0pre1.tar.bz2) = 34482db6102a0d4b2a3692617926a92e44116f81
Size (mplayer/MPlayer-1.0pre1.tar.bz2) = 4190784 bytes
SHA1 (mplayer/default-1.7.tar.bz2) = 6912c3e58b4c76fad97fdb72945b27815069f7e3
Size (mplayer/default-1.7.tar.bz2) = 173439 bytes
SHA1 (mplayer/AlienMind-1.0.tar.bz2) = 7c890bbb2e5b34b800ba2f7273b1f6a4e6c4281c

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.21 2003/08/31 00:25:20 xtraeme Exp $
$NetBSD: distinfo,v 1.22 2003/09/02 17:46:38 jmmv Exp $
SHA1 (mplayer/MPlayer-0.91.tar.bz2) = c468c1c7044283def3064ef94dd691367973ea01
Size (mplayer/MPlayer-0.91.tar.bz2) = 3467061 bytes
SHA1 (mplayer/MPlayer-1.0pre1.tar.bz2) = 34482db6102a0d4b2a3692617926a92e44116f81
Size (mplayer/MPlayer-1.0pre1.tar.bz2) = 4190784 bytes
SHA1 (patch-aa) = 6938dbdccb9b760dadad304f3bf61245e8b1baa6
SHA1 (patch-ab) = f2fd9006914a7d1bac364be74ca5d7cb9aab6806
SHA1 (patch-ad) = e77e938e7f4b9a2849f816bbc662db277d7898d3

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2003/08/31 00:25:20 xtraeme Exp $
# $NetBSD: Makefile,v 1.12 2003/09/02 17:46:31 jmmv Exp $
.include "Makefile.common"
@ -24,19 +24,21 @@ DISTFILES+= ${MP_FONTS}
.include "../../mk/bsd.prefs.mk"
do-install:
${INSTALL_MAN} ${WRKSRC}/DOCS/mplayer.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/DOCS/en/mplayer.1 ${PREFIX}/man/man1
${INSTALL_DATA_DIR} ${PREFIX}/share/mplayer
${INSTALL_DATA_DIR} ${PREFIX}/share/mplayer/DOCS
${INSTALL_DATA_DIR} ${PREFIX}/share/mplayer/fonts
${INSTALL_DATA} ${WRKSRC}/etc/codecs.conf ${PREFIX}/share/mplayer
${INSTALL_DATA} ${WRKSRC}/etc/input.conf ${PREFIX}/share/mplayer
${CP} -R ${WRKSRC}/DOCS ${PREFIX}/share/mplayer
(cd ${WRKSRC}/DOCS && \
${PAX} -rwpppm * ${PREFIX}/share/mplayer/DOCS); \
${FIND} ${PREFIX}/share/mplayer/DOCS -type d -exec ${CHMOD} \
${PKGDIRMODE} \{\} \;
${FIND} ${PREFIX}/share/mplayer/DOCS -type f -exec ${CHMOD} \
${SHAREMODE} \{\} \;
for D in ${FONT_DIRS}; do \
(cd ${WRKDIR}/$$D && \
${PAX} -rw * ${PREFIX}/share/mplayer/fonts); \
${PAX} -rwpppm * ${PREFIX}/share/mplayer/fonts); \
done
${LN} -s ${PREFIX}/share/mplayer/fonts/font-arial-18-iso-8859-1 \
${PREFIX}/share/mplayer/font

View file

@ -1,13 +1,14 @@
# $NetBSD: Makefile.common,v 1.38 2003/08/31 00:25:20 xtraeme Exp $
# $NetBSD: Makefile.common,v 1.39 2003/09/02 17:46:32 jmmv Exp $
#
MPLAYER_DIST_VERSION= 0.91
MPLAYER_DIST_VERSION= 1.0pre1
#PKGREVISION= 0
# This variable is used in all packages which depend on this package
MPLAYER_PKG_VERSION= 0.91
MPLAYER_PKG_VERSION= 1.0rc1
DISTNAME= MPlayer-${MPLAYER_DIST_VERSION}
WRKSRC= ${WRKDIR}/${DISTNAME:S/MPlayer/mplayer/}
CATEGORIES?= graphics
MASTER_SITES= http://www.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \

View file

@ -1,92 +1,79 @@
@comment $NetBSD: PLIST,v 1.12 2003/07/20 20:15:02 dillo Exp $
@comment $NetBSD: PLIST,v 1.13 2003/09/02 17:46:32 jmmv Exp $
man/man1/mplayer.1
share/mplayer/DOCS/Chinese/bugreports.html
share/mplayer/DOCS/Chinese/cd-dvd.html
share/mplayer/DOCS/Chinese/codecs.html
share/mplayer/DOCS/Chinese/default.css
share/mplayer/DOCS/Chinese/documentation.html
share/mplayer/DOCS/Chinese/encoding.html
share/mplayer/DOCS/Chinese/faq.html
share/mplayer/DOCS/Chinese/formats.html
share/mplayer/DOCS/Chinese/mplayer.1
share/mplayer/DOCS/Chinese/skin.html
share/mplayer/DOCS/Chinese/sound.html
share/mplayer/DOCS/Chinese/users_against_developers.html
share/mplayer/DOCS/Chinese/video.html
share/mplayer/DOCS/French/bugreports.html
share/mplayer/DOCS/French/cd-dvd.html
share/mplayer/DOCS/French/codecs.html
share/mplayer/DOCS/French/default.css
share/mplayer/DOCS/French/documentation.html
share/mplayer/DOCS/French/encoding.html
share/mplayer/DOCS/French/exemple.conf
share/mplayer/DOCS/French/faq.html
share/mplayer/DOCS/French/formats.html
share/mplayer/DOCS/French/mplayer.1
share/mplayer/DOCS/French/skin.html
share/mplayer/DOCS/French/sound.html
share/mplayer/DOCS/French/users_against_developers.html
share/mplayer/DOCS/French/video.html
share/mplayer/DOCS/German/bugreports.html
share/mplayer/DOCS/German/cd-dvd.html
share/mplayer/DOCS/German/codecs.html
share/mplayer/DOCS/German/default.css
share/mplayer/DOCS/German/documentation.html
share/mplayer/DOCS/German/encoding.html
share/mplayer/DOCS/German/faq.html
share/mplayer/DOCS/German/formats.html
share/mplayer/DOCS/German/mplayer.1
share/mplayer/DOCS/German/sound.html
share/mplayer/DOCS/German/users_against_developers.html
share/mplayer/DOCS/German/video.html
share/mplayer/DOCS/Hungarian/bugreports.html
share/mplayer/DOCS/Hungarian/cd-dvd.html
share/mplayer/DOCS/Hungarian/codecs.html
share/mplayer/DOCS/Hungarian/documentation.html
share/mplayer/DOCS/Hungarian/encoding.html
share/mplayer/DOCS/Hungarian/example.conf
share/mplayer/DOCS/Hungarian/faq.html
share/mplayer/DOCS/Hungarian/formats.html
share/mplayer/DOCS/Hungarian/mplayer.1
share/mplayer/DOCS/Hungarian/skin.html
share/mplayer/DOCS/Hungarian/sound.html
share/mplayer/DOCS/Hungarian/video.html
share/mplayer/DOCS/Italian/bugreports.html
share/mplayer/DOCS/Italian/cd-dvd.html
share/mplayer/DOCS/Italian/codecs.html
share/mplayer/DOCS/Italian/default.css
share/mplayer/DOCS/Italian/documentation.html
share/mplayer/DOCS/Italian/encoding.html
share/mplayer/DOCS/Italian/faq.html
share/mplayer/DOCS/Italian/formats.html
share/mplayer/DOCS/Italian/skin.html
share/mplayer/DOCS/Italian/sound.html
share/mplayer/DOCS/Italian/users_against_developers.html
share/mplayer/DOCS/Italian/video.html
share/mplayer/DOCS/Polish/bugreports.html
share/mplayer/DOCS/Polish/cd-dvd.html
share/mplayer/DOCS/Polish/codecs.html
share/mplayer/DOCS/Polish/documentation.html
share/mplayer/DOCS/Polish/encoding.html
share/mplayer/DOCS/Polish/faq.html
share/mplayer/DOCS/Polish/formats.html
share/mplayer/DOCS/Polish/mplayer.1
share/mplayer/DOCS/Polish/skin.html
share/mplayer/DOCS/Polish/sound.html
share/mplayer/DOCS/Polish/users_against_developers.html
share/mplayer/DOCS/Polish/video.html
share/mplayer/DOCS/bugreports.html
share/mplayer/DOCS/cd-dvd.html
share/mplayer/DOCS/codecs-in.html
share/mplayer/DOCS/codecs.html
share/mplayer/DOCS/de/bugreports.html
share/mplayer/DOCS/de/cd-dvd.html
share/mplayer/DOCS/de/codecs.html
share/mplayer/DOCS/de/documentation.html
share/mplayer/DOCS/de/encoding.html
share/mplayer/DOCS/de/faq.html
share/mplayer/DOCS/de/formats.html
share/mplayer/DOCS/de/mplayer.1
share/mplayer/DOCS/de/sound.html
share/mplayer/DOCS/de/users_against_developers.html
share/mplayer/DOCS/de/video.html
share/mplayer/DOCS/default.css
share/mplayer/DOCS/documentation.html
share/mplayer/DOCS/encoding.html
share/mplayer/DOCS/faq.html
share/mplayer/DOCS/formats.html
share/mplayer/DOCS/mplayer.1
share/mplayer/DOCS/skin.html
share/mplayer/DOCS/sound.html
share/mplayer/DOCS/en/bugreports.html
share/mplayer/DOCS/en/cd-dvd.html
share/mplayer/DOCS/en/codecs-in.html
share/mplayer/DOCS/en/codecs.html
share/mplayer/DOCS/en/documentation.html
share/mplayer/DOCS/en/encoding.html
share/mplayer/DOCS/en/faq.html
share/mplayer/DOCS/en/formats.html
share/mplayer/DOCS/en/mplayer.1
share/mplayer/DOCS/en/skin.html
share/mplayer/DOCS/en/sound.html
share/mplayer/DOCS/en/users_against_developers.html
share/mplayer/DOCS/en/video.html
share/mplayer/DOCS/es/mplayer.1
share/mplayer/DOCS/fr/bugreports.html
share/mplayer/DOCS/fr/cd-dvd.html
share/mplayer/DOCS/fr/codecs.html
share/mplayer/DOCS/fr/documentation.html
share/mplayer/DOCS/fr/encoding.html
share/mplayer/DOCS/fr/exemple.conf
share/mplayer/DOCS/fr/faq.html
share/mplayer/DOCS/fr/formats.html
share/mplayer/DOCS/fr/mplayer.1
share/mplayer/DOCS/fr/skin.html
share/mplayer/DOCS/fr/sound.html
share/mplayer/DOCS/fr/users_against_developers.html
share/mplayer/DOCS/fr/video.html
share/mplayer/DOCS/hu/bugreports.html
share/mplayer/DOCS/hu/cd-dvd.html
share/mplayer/DOCS/hu/codecs.html
share/mplayer/DOCS/hu/documentation.html
share/mplayer/DOCS/hu/encoding.html
share/mplayer/DOCS/hu/example.conf
share/mplayer/DOCS/hu/faq.html
share/mplayer/DOCS/hu/formats.html
share/mplayer/DOCS/hu/mplayer.1
share/mplayer/DOCS/hu/skin.html
share/mplayer/DOCS/hu/sound.html
share/mplayer/DOCS/hu/video.html
share/mplayer/DOCS/it/bugreports.html
share/mplayer/DOCS/it/cd-dvd.html
share/mplayer/DOCS/it/codecs.html
share/mplayer/DOCS/it/documentation.html
share/mplayer/DOCS/it/encoding.html
share/mplayer/DOCS/it/faq.html
share/mplayer/DOCS/it/formats.html
share/mplayer/DOCS/it/skin.html
share/mplayer/DOCS/it/sound.html
share/mplayer/DOCS/it/users_against_developers.html
share/mplayer/DOCS/it/video.html
share/mplayer/DOCS/pl/bugreports.html
share/mplayer/DOCS/pl/cd-dvd.html
share/mplayer/DOCS/pl/codecs.html
share/mplayer/DOCS/pl/documentation.html
share/mplayer/DOCS/pl/encoding.html
share/mplayer/DOCS/pl/faq.html
share/mplayer/DOCS/pl/formats.html
share/mplayer/DOCS/pl/mplayer.1
share/mplayer/DOCS/pl/skin.html
share/mplayer/DOCS/pl/sound.html
share/mplayer/DOCS/pl/users_against_developers.html
share/mplayer/DOCS/pl/video.html
share/mplayer/DOCS/tech/MAINTAINERS
share/mplayer/DOCS/tech/TODO
share/mplayer/DOCS/tech/codec-devel.txt
@ -104,6 +91,7 @@ share/mplayer/DOCS/tech/libmpcodecs.txt
share/mplayer/DOCS/tech/libvo.txt
share/mplayer/DOCS/tech/libvo2.txt
share/mplayer/DOCS/tech/manpage.txt
share/mplayer/DOCS/tech/mpcf.txt
share/mplayer/DOCS/tech/mpsub.sub
share/mplayer/DOCS/tech/osd.txt
share/mplayer/DOCS/tech/patches.txt
@ -114,13 +102,25 @@ share/mplayer/DOCS/tech/realcodecs/TODO
share/mplayer/DOCS/tech/realcodecs/audio-codecs.txt
share/mplayer/DOCS/tech/realcodecs/streaming.txt
share/mplayer/DOCS/tech/realcodecs/video-codecs.txt
share/mplayer/DOCS/tech/release-howto.txt
share/mplayer/DOCS/tech/slave.txt
share/mplayer/DOCS/tech/subcp.txt
share/mplayer/DOCS/tech/swscaler_filters.txt
share/mplayer/DOCS/tech/swscaler_methods.txt
share/mplayer/DOCS/tech/vidix.txt
share/mplayer/DOCS/tech/wishlist
share/mplayer/DOCS/users_against_developers.html
share/mplayer/DOCS/video.html
share/mplayer/DOCS/zh/bugreports.html
share/mplayer/DOCS/zh/cd-dvd.html
share/mplayer/DOCS/zh/codecs.html
share/mplayer/DOCS/zh/documentation.html
share/mplayer/DOCS/zh/encoding.html
share/mplayer/DOCS/zh/faq.html
share/mplayer/DOCS/zh/formats.html
share/mplayer/DOCS/zh/mplayer.1
share/mplayer/DOCS/zh/skin.html
share/mplayer/DOCS/zh/sound.html
share/mplayer/DOCS/zh/users_against_developers.html
share/mplayer/DOCS/zh/video.html
share/mplayer/codecs.conf
share/mplayer/font
share/mplayer/fonts/README-arial-cp1250
@ -200,13 +200,17 @@ share/mplayer/input.conf
@dirrm share/mplayer/fonts/font-arial-14-iso-8859-1
@dirrm share/mplayer/fonts/font-arial-14-cp1250
@dirrm share/mplayer/fonts
@dirrm share/mplayer/DOCS/zh
@dirrm share/mplayer/DOCS/tech/realcodecs
@dirrm share/mplayer/DOCS/tech
@dirrm share/mplayer/DOCS/Polish
@dirrm share/mplayer/DOCS/Italian
@dirrm share/mplayer/DOCS/Hungarian
@dirrm share/mplayer/DOCS/German
@dirrm share/mplayer/DOCS/French
@dirrm share/mplayer/DOCS/Chinese
@exec ${MKDIR} %D/share/mplayer/DOCS/ru
@dirrm share/mplayer/DOCS/ru
@dirrm share/mplayer/DOCS/pl
@dirrm share/mplayer/DOCS/it
@dirrm share/mplayer/DOCS/hu
@dirrm share/mplayer/DOCS/fr
@dirrm share/mplayer/DOCS/es
@dirrm share/mplayer/DOCS/en
@dirrm share/mplayer/DOCS/de
@dirrm share/mplayer/DOCS
@dirrm share/mplayer

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.26 2003/08/31 00:25:20 xtraeme Exp $
$NetBSD: distinfo,v 1.27 2003/09/02 17:46:32 jmmv Exp $
SHA1 (mplayer/MPlayer-0.91.tar.bz2) = c468c1c7044283def3064ef94dd691367973ea01
Size (mplayer/MPlayer-0.91.tar.bz2) = 3467061 bytes
SHA1 (mplayer/MPlayer-1.0pre1.tar.bz2) = 34482db6102a0d4b2a3692617926a92e44116f81
Size (mplayer/MPlayer-1.0pre1.tar.bz2) = 4190784 bytes
SHA1 (mplayer/font-arial-iso-8859-1.tar.bz2) = 152c40bf20de34aa8802d7f80d34d673b0b67212
Size (mplayer/font-arial-iso-8859-1.tar.bz2) = 234242 bytes
SHA1 (mplayer/font-arial-iso-8859-2.tar.bz2) = 7b99bbe0e9ba89a57eccbea8f93c453c4f268181
@ -9,6 +9,5 @@ Size (mplayer/font-arial-iso-8859-2.tar.bz2) = 222208 bytes
SHA1 (mplayer/font-arial-cp1250.tar.bz2) = ccf11dce5d0fb72fd3af97f788b7471cd0cd0b68
Size (mplayer/font-arial-cp1250.tar.bz2) = 249705 bytes
SHA1 (patch-aa) = 6938dbdccb9b760dadad304f3bf61245e8b1baa6
SHA1 (patch-ab) = f2fd9006914a7d1bac364be74ca5d7cb9aab6806
SHA1 (patch-ad) = e77e938e7f4b9a2849f816bbc662db277d7898d3
SHA1 (patch-ae) = 12d16a7dda6be9d950d09d23d41d0de03ca70425

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ab,v 1.7 2003/02/22 16:26:18 fredb Exp $
--- libavcodec/alpha/simple_idct_alpha.c.orig Tue Nov 26 19:20:20 2002
+++ libavcodec/alpha/simple_idct_alpha.c Sat Feb 22 05:57:45 2003
@@ -49,7 +49,7 @@
static inline int idct_row(DCTELEM *row)
{
int_fast32_t a0, a1, a2, a3, b0, b1, b2, b3, t;
- uint64_t l, r;
+ uint64_t l, r, t2;
l = ldq(row);
r = ldq(row + 4);
@@ -60,12 +60,12 @@
if (((l & ~0xffffUL) | r) == 0) {
a0 >>= ROW_SHIFT;
- a0 = (uint16_t) a0;
- a0 |= a0 << 16;
- a0 |= a0 << 32;
+ t2 = (uint16_t) a0;
+ t2 |= t2 << 16;
+ t2 |= t2 << 32;
- stq(a0, row);
- stq(a0, row + 4);
+ stq(t2, row);
+ stq(t2, row + 4);
return 1;
}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.35 2003/08/31 00:25:20 xtraeme Exp $
$NetBSD: distinfo,v 1.36 2003/09/02 17:46:36 jmmv Exp $
SHA1 (mplayer/MPlayer-0.91.tar.bz2) = c468c1c7044283def3064ef94dd691367973ea01
Size (mplayer/MPlayer-0.91.tar.bz2) = 3467061 bytes
SHA1 (mplayer/MPlayer-1.0pre1.tar.bz2) = 34482db6102a0d4b2a3692617926a92e44116f81
Size (mplayer/MPlayer-1.0pre1.tar.bz2) = 4190784 bytes
SHA1 (patch-aa) = 6938dbdccb9b760dadad304f3bf61245e8b1baa6
SHA1 (patch-ab) = f2fd9006914a7d1bac364be74ca5d7cb9aab6806
SHA1 (patch-ad) = e77e938e7f4b9a2849f816bbc662db277d7898d3