SDL2: make sdl2-config DTRT if the X11 libraries are not in ${PREFIX}/lib
Because SDL2 uses dlopen for these libraries, it's hard to tell what is failing. Example test case in http://daemonforums.org/showthread.php?t=10360 reported by oliv3 on IRC, thanks!
This commit is contained in:
parent
da7f27b391
commit
e28d7adb8b
3 changed files with 22 additions and 7 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.33 2018/12/23 14:27:15 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.34 2018/12/30 14:47:04 maya Exp $
|
||||
|
||||
DISTNAME= SDL2-2.0.9
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.libsdl.org/release/
|
||||
|
||||
|
@ -16,6 +16,9 @@ USE_TOOLS+= gmake pkg-config autoconf automake autoreconf
|
|||
GNU_CONFIGURE= yes
|
||||
PKGCONFIG_OVERRIDE+= sdl2.pc.in
|
||||
|
||||
CONFIGURE_ENV+= SDL_RLD_FLAGS="${COMPILER_RPATH_FLAG}${PREFIX}/lib \
|
||||
${COMPILER_RPATH_FLAG}${X11BASE}/lib"
|
||||
|
||||
CHECK_PORTABILITY_SKIP+=build-scripts/androidbuildlibs.sh
|
||||
CHECK_PORTABILITY_SKIP+=build-scripts/iosbuild.sh
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.31 2018/12/05 10:46:15 bsiegert Exp $
|
||||
$NetBSD: distinfo,v 1.32 2018/12/30 14:47:04 maya Exp $
|
||||
|
||||
SHA1 (SDL2-2.0.9.tar.gz) = 4354c6baad9a48486182656a7506abfb63e9bff5
|
||||
RMD160 (SDL2-2.0.9.tar.gz) = db2efabf55af41cddf015db0b5213b11ef22b9d0
|
||||
SHA512 (SDL2-2.0.9.tar.gz) = a78a4708b2bb5b35a7c7b7501eb3bd60a9aa3bb95a3d84e57763df4a377185e7312a94b66321eef7ca0d17255e4b402fc950e83ef0dbbd08f14ff1194107dc10
|
||||
Size (SDL2-2.0.9.tar.gz) = 5246942 bytes
|
||||
SHA1 (patch-configure) = 5637a66f8890586026034f5324829e61c94ac5be
|
||||
SHA1 (patch-configure) = 1631314dab18886ea553ee53fac89e16718cacab
|
||||
SHA1 (patch-src_audio_netbsd_SDL__netbsdaudio.c) = 7a1f32ea7029f8dc99aecfaead7c68f2fd6cb230
|
||||
SHA1 (patch-src_joystick_bsd_SDL__sysjoystick.c) = 152b5df76a91c7e7acde126b1464fdd464cf1ba2
|
||||
SHA1 (patch-src_video_cocoa_SDL__cocoawindow.m) = 1d5ac9c17ceadf668925734b5cad311e26f2fc58
|
||||
|
|
|
@ -1,10 +1,22 @@
|
|||
$NetBSD: patch-configure,v 1.6 2017/01/26 03:46:20 nat Exp $
|
||||
$NetBSD: patch-configure,v 1.7 2018/12/30 14:47:04 maya Exp $
|
||||
|
||||
Adding --enable-new-dtags breaks sdl2-config on NetBSD.
|
||||
Allow overriding SDL_RLD_FLAGS so we can add /usr/X11R7/lib.
|
||||
|
||||
--- configure.orig 2016-10-20 03:56:27.000000000 +0000
|
||||
--- configure.orig 2018-10-31 15:07:22.000000000 +0000
|
||||
+++ configure
|
||||
@@ -23955,7 +23955,7 @@ _ACEOF
|
||||
@@ -24937,7 +24937,9 @@ SDLTEST_DEPENDS=`echo "$SDLTEST_DEPENDS"
|
||||
|
||||
if test "x$enable_rpath" = "xyes"; then
|
||||
if test $ARCH = bsdi -o $ARCH = freebsd -o $ARCH = linux -o $ARCH = netbsd; then
|
||||
- SDL_RLD_FLAGS="-Wl,-rpath,\${libdir}"
|
||||
+ if test -n $SDL_RLD_FLAGS; then
|
||||
+ SDL_RLD_FLAGS="-Wl,-rpath,\${libdir}"
|
||||
+ fi
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for linker option --enable-new-dtags" >&5
|
||||
$as_echo_n "checking for linker option --enable-new-dtags... " >&6; }
|
||||
@@ -24960,7 +24962,7 @@ _ACEOF
|
||||
if ac_fn_c_try_link "$LINENO"; then :
|
||||
|
||||
have_enable_new_dtags=yes
|
||||
|
|
Loading…
Reference in a new issue