OpenPTC-X11-1.0.0-2

Prometheus Truecolour for X11
This commit is contained in:
garbled 1999-07-22 09:14:55 +00:00
parent cf14397b57
commit e2c9c8b0e2
8 changed files with 147 additions and 0 deletions

21
graphics/openptc/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/07/22 09:14:55 garbled Exp $
DISTNAME= OpenPTC-x11-1.0.0-2
PKGNAME= OpenPTC-X11-1.0.02
CATEGORIES= graphics
MASTER_SITES= http://www.cs.ucl.ac.uk/students/c.nentwich/ptc/
MAINTAINER= root@garbled.net
HOMEPAGE= http://www.cs.ucl.ac.uk/students/c.nentwich/ptc/
DEPENDS+= Hermes-1.2.5:../../graphics/hermes
WRKSRC= ${WRKDIR}/OpenPTC-x11-1.0.0
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X11BASE= yes
CONFIGURE_ENV+= CXXFLAGS="-I${LOCALBASE}/include"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/07/22 09:14:55 garbled Exp $
MD5 (OpenPTC-x11-1.0.0-2.tar.gz) = 9d7a4dca14167994b4a744112ba07541

View file

@ -0,0 +1,4 @@
$NetBSD: patch-sum,v 1.1.1.1 1999/07/22 09:14:55 garbled Exp $
MD5 (patch-aa) = b2b4bf1727641d8961c84e4de81e30ff
MD5 (patch-ab) = fc61d1db983675e1e801752fb8ac1bb8

View file

@ -0,0 +1,44 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/07/22 09:14:55 garbled Exp $
--- configure.orig Wed Mar 31 16:43:45 1999
+++ configure Thu Jul 22 01:34:25 1999
@@ -528,9 +528,9 @@
-PTCVERSION="1.0.0"
+PTCVERSION="1.0"
PTCFLAGS=$CXXFLAGS
-PTCLIBS="-lX11 -lXext"
+PTCLIBS="-lX11 -lXext $LDFLAGS"
SAVELIBS=""
@@ -1950,7 +1950,7 @@
#include "confdefs.h"
#include <$ac_hdr>
EOF
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ac_try="$ac_cpp -I$LOCALBASE/include conftest.$ac_ext >/dev/null 2>conftest.out"
{ (eval echo configure:1955: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
@@ -2019,9 +2019,6 @@
echo
echo "Do you want to build a dynamic library too ? (y/n) "
-read PTC_DYN_JN
-
-if test $PTC_DYN_JN = "y"; then
echo "Building dynamic library".
PTC_DYN="dynamic"
@@ -2042,9 +2039,6 @@
# else
# echo "Skippping Java support."
# fi
-else
- echo "No dynamic library will be built."
-fi

View file

@ -0,0 +1,29 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/07/22 09:14:55 garbled Exp $
--- Makefile.in.orig Wed Mar 31 16:44:04 1999
+++ Makefile.in Thu Jul 22 01:57:53 1999
@@ -54,19 +54,19 @@
install -d $(prefix)/include/ptc/X11
install -d $(exec_prefix)/lib
install -d $(exec_prefix)/bin
- install -m 0644 source/ptc.h $(prefix)/include/ptc
+ install -c -m 0644 source/ptc.h $(prefix)/include/ptc
for incfile in $(CORE_HEADER_FILES); do \
- install -m 0644 source/Core/$$incfile $(prefix)/include/ptc/Core; \
+ install -c -m 0644 source/Core/$$incfile $(prefix)/include/ptc/Core; \
done
for incfile in $(X11_HEADER_FILES); do \
- install -m 0644 source/X11/$$incfile $(prefix)/include/ptc/X11; \
+ install -c -m 0644 source/X11/$$incfile $(prefix)/include/ptc/X11; \
done
- install -m 0644 $(PTC_LIBRARY_PATH)/$(PTC_LIBRARY_NAME) $(exec_prefix)/lib
+ install -c -m 0644 $(PTC_LIBRARY_PATH)/$(PTC_LIBRARY_NAME) $(exec_prefix)/lib
@cd $(exec_prefix)/lib ; ln -sf $(PTC_LIBRARY_NAME) libptc.a
- install -m 0755 ptc-config $(exec_prefix)/bin
+ install -c -m 0755 ptc-config $(exec_prefix)/bin
chmod 755 $(exec_prefix)/bin/ptc-config
if test -e library/$(PTC_LIBRARY_DYN); then \
- install -m 0755 library/$(PTC_LIBRARY_DYN) $(exec_prefix)/lib; \
+ install -c -m 0755 library/$(PTC_LIBRARY_DYN) $(exec_prefix)/lib; \
cd $(exec_prefix)/lib ; ln -sf $(PTC_LIBRARY_DYN) libptc.so ; \
fi

View file

@ -0,0 +1 @@
Prometheus Truecolour for X11

View file

@ -0,0 +1,13 @@
Prometheus Truecolour (OpenPTC) is a third-generation standard for cross
platform low-level graphics access. A lot of design experience has gone into
it to provide one of the cleanest APIs available for this kind of purpose.
OpenPTC will provide you with a frame-buffer to draw into. You can choose
that buffer to use a pixel format convenient for you, OpenPTC will convert
it to the video modes on the target platform, using highly optimised
x86 and MMX routines where available. This is achieved using the HERMES
((c)1998/99 Christian Nentwich et al) pixel conversion library.
OpenPTC 1.0 is available for X11, GGI (Linux), Win32, DOS and JAVA. Work for
other platforms is in progress. All implementations of PTC come with full
source code and may be used free of charge even in commercial projects.

View file

@ -0,0 +1,32 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/07/22 09:14:55 garbled Exp $
bin/ptc-config
include/ptc/Core/Area.h
include/ptc/Core/Base.h
include/ptc/Core/Clear.h
include/ptc/Core/Clipper.h
include/ptc/Core/Color.h
include/ptc/Core/Copy.h
include/ptc/Core/Error.h
include/ptc/Core/Format.h
include/ptc/Core/Index.h
include/ptc/Core/Palette.h
include/ptc/Core/Surface.h
include/ptc/Core/Types.h
include/ptc/Core/Key.h
include/ptc/Core/Timer.h
include/ptc/Core/Hermes.h
include/ptc/Core/Config.h
include/ptc/Core/Mode.h
include/ptc/X11/Console.h
include/ptc/X11/Display.h
include/ptc/X11/DGADisplay.h
include/ptc/X11/WindowDisplay.h
include/ptc/X11/Image.h
include/ptc/X11/ptconfig.h
include/ptc/ptc.h
lib/libptc.1.0.a
lib/libptc.so.1.0
lib/libptc.a
@dirrm include/ptc/Core
@dirrm include/ptc/X11
@dirrm include/ptc