Link libiconv.la against libcharset.la to fix the build on MirBSD.

Bump PKGREVISION.

Patch was first sent to tech-pkg, no one objected.
This commit is contained in:
bsiegert 2011-09-06 18:51:14 +00:00
parent b2e9f7747a
commit e2d56eceac
3 changed files with 17 additions and 6 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.58 2011/08/22 14:03:36 wiz Exp $
# $NetBSD: Makefile,v 1.59 2011/09/06 18:51:14 bsiegert Exp $
DISTNAME= libiconv-1.14
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_GNU:=libiconv/}
PKGREVISION= 1
MAINTAINER= rh@NetBSD.org
HOMEPAGE= http://www.gnu.org/software/libiconv/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.35 2011/08/22 14:03:36 wiz Exp $
$NetBSD: distinfo,v 1.36 2011/09/06 18:51:14 bsiegert Exp $
SHA1 (libiconv-1.13-cp932.patch.gz) = 3dd6ed92e0d9f58db71edf63e31ab6cbd4420f99
RMD160 (libiconv-1.13-cp932.patch.gz) = 71040b00489ad1a5f218a09b4d22e550b1d31fc8
@ -10,4 +10,4 @@ SHA1 (patch-aa) = 7fe47a14379dbeb487c677957e67fc7b043297ce
SHA1 (patch-ab) = f10e4d1de691043acca775eed5c47c6061b31626
SHA1 (patch-ad) = e94da1c4423677b74f463d4b132c7714efc65815
SHA1 (patch-ae) = ab346a515d5ab0efd679e7783edebd95a05db782
SHA1 (patch-af) = 513a8f995161853870a01afabccdb2a650b794a6
SHA1 (patch-af) = 8338647dbf181e908fc52dbc12e7bdff62f7bcb7

View file

@ -1,8 +1,17 @@
$NetBSD: patch-af,v 1.6 2010/11/10 21:00:50 adam Exp $
$NetBSD: patch-af,v 1.7 2011/09/06 18:51:14 bsiegert Exp $
--- lib/Makefile.in.orig 2009-06-21 11:17:33.000000000 +0000
--- lib/Makefile.in.orig Sun Aug 7 17:47:39 2011
+++ lib/Makefile.in
@@ -96,14 +96,14 @@ libiconv.res.lo : $(srcdir)/../windows/l
@@ -68,7 +68,7 @@ OBJECTS_RES_no =
all : libiconv.la
libiconv.la : $(OBJECTS)
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(CFLAGS) -o libiconv.la -rpath $(libdir) -version-info $(LIBICONV_VERSION_INFO) -no-undefined $(OBJECTS)
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(CFLAGS) -o libiconv.la -rpath $(libdir) -version-info $(LIBICONV_VERSION_INFO) -no-undefined $(OBJECTS) libcharset.la
iconv.lo : $(srcdir)/iconv.c $(srcdir)/converters.h \
$(srcdir)/encodings.def $(srcdir)/encodings_aix.def $(srcdir)/encodings_osf1.def $(srcdir)/encodings_dos.def $(srcdir)/encodings_local.def \
@@ -96,7 +96,7 @@ libiconv.res.lo : $(srcdir)/../windows/l
# $(libdir) and $(includedir) - don't use $(prefix) and $(exec_prefix) here.
install-lib : all force
if [ ! -d $(libdir) ] ; then $(mkinstalldirs) $(libdir) ; fi
@ -11,6 +20,7 @@ $NetBSD: patch-af,v 1.6 2010/11/10 21:00:50 adam Exp $
# On AIX, libiconv.a must include the object files of /lib/libiconv.a,
# otherwise the setlocale() call fails when invoked from executables linked
@@ -103,7 +103,7 @@ install-lib : all force
# with -rpath $(libdir), even if linked without -liconv.
install : all force
if [ ! -d $(DESTDIR)$(libdir) ] ; then $(mkinstalldirs) $(DESTDIR)$(libdir) ; fi