Don't pick up C++11's std::is_object trait.
This commit is contained in:
parent
5576e5e0d1
commit
e2ec7fd7f1
2 changed files with 24 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.10 2011/02/23 10:20:26 adam Exp $
|
||||
$NetBSD: distinfo,v 1.11 2013/04/30 22:20:22 joerg Exp $
|
||||
|
||||
SHA1 (enigma-1.01-r1914.tar.gz) = f0c4b3e8fbbcc246044fbdf0ff474a005e9905a1
|
||||
RMD160 (enigma-1.01-r1914.tar.gz) = 205e11ecc87b3a46911782366043ce80079b9918
|
||||
|
@ -9,4 +9,5 @@ SHA1 (patch-lib-src_enigma-core_IMG__SavePNG.c) = 7377498a9be1425cb7c683147b37ce
|
|||
SHA1 (patch-lib-src_enigma-core_ecl_alist.hh) = 15c0d90cecb60010f85074d28c907f4ba416a972
|
||||
SHA1 (patch-lib-src_enigma-core_ecl_dict.hh) = 64dfc60a4a805a4b1f3af8ca3726efd14d1d7cfd
|
||||
SHA1 (patch-lib-src_enigma-core_ecl_font.cc) = 132504419ed9b045f021dc3b2023116d57ab51e9
|
||||
SHA1 (patch-src_lua.cc) = fecb5ec31029b4850aee656df399650a0c124c6a
|
||||
SHA1 (patch-src_oxyd.cc) = e70a5b6049db22be42be438c08ccfed677907a20
|
||||
|
|
22
games/enigma/patches/patch-src_lua.cc
Normal file
22
games/enigma/patches/patch-src_lua.cc
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-src_lua.cc,v 1.1 2013/04/30 22:20:22 joerg Exp $
|
||||
|
||||
--- src/lua.cc.orig 2013-04-30 19:57:33.000000000 +0000
|
||||
+++ src/lua.cc
|
||||
@@ -171,7 +171,7 @@ to_object(lua_State *L, int idx)
|
||||
if (lua_isnil(L,idx))
|
||||
return 0;
|
||||
|
||||
- if (!is_object(L,idx)) {
|
||||
+ if (!::is_object(L,idx)) {
|
||||
throwLuaError(L, "Cannot convert type to an Object");
|
||||
return 0;
|
||||
}
|
||||
@@ -294,7 +294,7 @@ en_set_floor(lua_State *L)
|
||||
|
||||
if (lua_isnil(L, 3))
|
||||
fl = 0;
|
||||
- else if (is_object(L,3)) {
|
||||
+ else if (::is_object(L,3)) {
|
||||
fl = static_cast<Floor*>(*(static_cast<void**> (lua_touserdata(L,3))));
|
||||
if( ! fl)
|
||||
throwLuaError(L, "object is no valid floor");
|
Loading…
Reference in a new issue