Remove old, outdated synergy1.2 package

This commit is contained in:
tnn 2015-02-15 06:18:15 +00:00
parent d29f835f6b
commit e301ac4d3d
18 changed files with 0 additions and 268 deletions

View file

@ -1,8 +0,0 @@
With synergy, all the computers on your desktop form a single virtual
screen. You use the mouse and keyboard of only one of the computers
while you use all of the monitors on all of the computers. You tell
synergy how many screens you have and their positions relative to one
another. Synergy then detects when the mouse moves off the edge of a
screen and jumps it instantly to the neighboring screen. The keyboard
works normally on each screen; input goes to whichever screen has the
cursor.

View file

@ -1,24 +0,0 @@
# $NetBSD: Makefile,v 1.6 2012/10/23 17:19:11 asau Exp $
#
DISTNAME= synergy-1.2.7
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=synergy2/}
MAINTAINER= yui@yui.pe.kr
HOMEPAGE= http://synergy2.sourceforge.net/
COMMENT= Let an user share a mouse and keyboard among computers
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
BUILDLINK_DEPMETHOD.libXt?= build
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/libXtst/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2006/06/01 23:26:56 minskim Exp $
bin/synergyc
bin/synergys

View file

@ -1,19 +0,0 @@
$NetBSD: distinfo,v 1.6 2013/05/11 21:40:40 joerg Exp $
SHA1 (synergy-1.2.7.tar.gz) = 5964460892fd9e9cb55c5bfe4e781f2bc08d0b76
RMD160 (synergy-1.2.7.tar.gz) = 6bdbe5adbc13c2f49afcb99ccaa20b96a12c2bcf
Size (synergy-1.2.7.tar.gz) = 707319 bytes
SHA1 (patch-aa) = 5a48140c7622195a716eededae2d1ee0f6fa4e85
SHA1 (patch-ab) = 24f611bc942b6c0dac8e3d398150e5a8bb44ebd6
SHA1 (patch-cmd_synergyc_synergyc.cpp) = 5cdfdeafe28aca64b86892040fb35affb6857cbe
SHA1 (patch-lib-arch-CArchDaemonUnix.cpp) = 1d11d87f9a388ba68403ff74d4fcd5fa180a919e
SHA1 (patch-lib_arch_CMultibyte.cpp) = 66cc7cd1e327a1bfd519cb003835914221cbb369
SHA1 (patch-lib_base_CEvent.cpp) = d23f2fbf2e9cf6dea3740ad1f6f4aeb9029d9a32
SHA1 (patch-lib_base_CStringUtil.cpp) = 8f803bcab5a37bd4bf5a918fe3333338bd7d22c2
SHA1 (patch-lib_client_CClient.cpp) = afa4dc5089da155756a5ea4772be216256f71663
SHA1 (patch-lib_client_CServerProxy.cpp) = d6692bebbb6c71684cd320822859701b96fb7efc
SHA1 (patch-lib_net_CTCPSocket.cpp) = 609768fa601c76e6431c222ab66e7aabf59bab49
SHA1 (patch-lib_server_CServer.cpp) = eefe1004a9dd7216c0496f9e9b46cfa0fa2f13f3
SHA1 (patch-lib_synergy_CPacketStreamFilter.cpp) = 614734a5a276950ff688e4d3a9c3e7ae66fed743
SHA1 (patch-lib_synergy_IKeyState.cpp) = fb6a64639156f56bb353ed598835cb5badb3a1f2
SHA1 (patch-lib_synergy_IPrimaryScreen.cpp) = 3a04d64a8270ed2da265213bacdf32c72ad01fcc

View file

@ -1,39 +0,0 @@
$NetBSD: patch-aa,v 1.2 2011/11/22 20:07:20 joerg Exp $
--- lib/platform/CXWindowsScreen.cpp.orig 2005-12-15 05:46:20.000000000 +0000
+++ lib/platform/CXWindowsScreen.cpp
@@ -25,6 +25,7 @@
#include "CStringUtil.h"
#include "IEventQueue.h"
#include "TMethodEventJob.h"
+#include <cstdlib>
#include <cstring>
#if X_DISPLAY_MISSING
# error X11 is required to build synergy
@@ -923,7 +924,7 @@ CXWindowsScreen::openIM()
// find the appropriate style. synergy supports XIMPreeditNothing
// only at the moment.
XIMStyles* styles;
- if (XGetIMValues(im, XNQueryInputStyle, &styles, NULL) != NULL ||
+ if (XGetIMValues(im, XNQueryInputStyle, &styles, (void *)NULL) != NULL ||
styles == NULL) {
LOG((CLOG_WARN "cannot get IM styles"));
XCloseIM(im);
@@ -946,7 +947,7 @@ CXWindowsScreen::openIM()
}
// create an input context for the style and tell it about our window
- XIC ic = XCreateIC(im, XNInputStyle, style, XNClientWindow, m_window, NULL);
+ XIC ic = XCreateIC(im, XNInputStyle, style, XNClientWindow, m_window, (void *)NULL);
if (ic == NULL) {
LOG((CLOG_WARN "cannot create IC"));
XCloseIM(im);
@@ -955,7 +956,7 @@ CXWindowsScreen::openIM()
// find out the events we must select for and do so
unsigned long mask;
- if (XGetICValues(ic, XNFilterEvents, &mask, NULL) != NULL) {
+ if (XGetICValues(ic, XNFilterEvents, &mask, (void *)NULL) != NULL) {
LOG((CLOG_WARN "cannot get IC filter events"));
XDestroyIC(ic);
XCloseIM(im);

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ab,v 1.3 2012/08/08 13:42:42 marino Exp $
--- lib/arch/CArchNetworkBSD.cpp.orig 2005-07-28 01:50:02.000000000 +0000
+++ lib/arch/CArchNetworkBSD.cpp
@@ -28,6 +28,7 @@
#include <fcntl.h>
#include <errno.h>
#include <string.h>
+#include <stdlib.h>
#if HAVE_POLL
# include <poll.h>
@@ -50,6 +51,8 @@
#if HAVE_ALLOCA_H
# define freea(x_)
#else
+# undef alloca
+# undef freea
# define alloca(x_) malloc(x_)
# define freea(x_) free(x_)
#endif

View file

@ -1,12 +0,0 @@
$NetBSD: patch-cmd_synergyc_synergyc.cpp,v 1.1 2013/05/11 21:40:41 joerg Exp $
--- cmd/synergyc/synergyc.cpp.orig 2013-05-10 13:04:17.000000000 +0000
+++ cmd/synergyc/synergyc.cpp
@@ -32,6 +32,7 @@
#include "CArch.h"
#include "XArch.h"
#include <cstring>
+#include <cstdlib>
#define DAEMON_RUNNING(running_)
#if WINAPI_MSWINDOWS

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib-arch-CArchDaemonUnix.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/arch/CArchDaemonUnix.cpp.orig 2005-01-01 20:52:42.000000000 +0000
+++ lib/arch/CArchDaemonUnix.cpp
@@ -19,6 +19,7 @@
#include <sys/stat.h>
#include <fcntl.h>
#include <errno.h>
+#include <stdlib.h>
//
// CArchDaemonUnix

View file

@ -1,21 +0,0 @@
$NetBSD: patch-lib_arch_CMultibyte.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/arch/CMultibyte.cpp.orig 2011-11-22 19:34:33.000000000 +0000
+++ lib/arch/CMultibyte.cpp
@@ -18,15 +18,13 @@
#include "common.h"
#include "CArch.h"
#include <limits.h>
+#include <stdlib.h>
#include <string.h>
#if HAVE_LOCALE_H
# include <locale.h>
#endif
#if HAVE_WCHAR_H || defined(_MSC_VER)
# include <wchar.h>
-#elif __APPLE__
- // wtf? Darwin puts mbtowc() et al. in stdlib
-# include <stdlib.h>
#else
// platform apparently has no wchar_t support. provide dummy
// implementations. hopefully at least the C++ compiler has

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_base_CEvent.cpp,v 1.1 2013/05/11 21:40:41 joerg Exp $
--- lib/base/CEvent.cpp.orig 2013-05-10 13:03:09.000000000 +0000
+++ lib/base/CEvent.cpp
@@ -12,6 +12,7 @@
* GNU General Public License for more details.
*/
+#include <cstdlib>
#include "CEvent.h"
#include "CEventQueue.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_base_CStringUtil.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/base/CStringUtil.cpp.orig 2011-11-22 19:35:22.000000000 +0000
+++ lib/base/CStringUtil.cpp
@@ -20,6 +20,7 @@
#include <cstdio>
#include <cstdlib>
#include <algorithm>
+#include <cstring>
//
// CStringUtil

View file

@ -1,13 +0,0 @@
$NetBSD: patch-lib_client_CClient.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/client/CClient.cpp.orig 2011-11-22 19:38:57.000000000 +0000
+++ lib/client/CClient.cpp
@@ -26,6 +26,8 @@
#include "CLog.h"
#include "IEventQueue.h"
#include "TMethodEventJob.h"
+#include <stdlib.h>
+#include <string.h>
//
// CClient

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_client_CServerProxy.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/client/CServerProxy.cpp.orig 2011-11-22 19:39:17.000000000 +0000
+++ lib/client/CServerProxy.cpp
@@ -24,6 +24,7 @@
#include "TMethodEventJob.h"
#include "XBase.h"
#include <memory>
+#include <string.h>
//
// CServerProxy

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_net_CTCPSocket.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/net/CTCPSocket.cpp.orig 2011-11-22 19:36:24.000000000 +0000
+++ lib/net/CTCPSocket.cpp
@@ -23,6 +23,7 @@
#include "IEventJob.h"
#include "CArch.h"
#include "XArch.h"
+#include <stdlib.h>
#include <string.h>
//

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_server_CServer.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/server/CServer.cpp.orig 2011-11-22 19:39:54.000000000 +0000
+++ lib/server/CServer.cpp
@@ -28,6 +28,7 @@
#include "CLog.h"
#include "TMethodEventJob.h"
#include "CArch.h"
+#include <stdlib.h>
#include <string.h>
//

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_synergy_CPacketStreamFilter.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/synergy/CPacketStreamFilter.cpp.orig 2011-11-22 19:37:00.000000000 +0000
+++ lib/synergy/CPacketStreamFilter.cpp
@@ -16,6 +16,7 @@
#include "IEventQueue.h"
#include "CLock.h"
#include "TMethodEventJob.h"
+#include <string.h>
//
// CPacketStreamFilter

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_synergy_IKeyState.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/synergy/IKeyState.cpp.orig 2011-11-22 19:37:22.000000000 +0000
+++ lib/synergy/IKeyState.cpp
@@ -13,6 +13,7 @@
*/
#include "IKeyState.h"
+#include <stdlib.h>
//
// IKeyState

View file

@ -1,12 +0,0 @@
$NetBSD: patch-lib_synergy_IPrimaryScreen.cpp,v 1.1 2011/11/22 20:07:20 joerg Exp $
--- lib/synergy/IPrimaryScreen.cpp.orig 2011-11-22 19:37:41.000000000 +0000
+++ lib/synergy/IPrimaryScreen.cpp
@@ -13,6 +13,7 @@
*/
#include "IPrimaryScreen.h"
+#include <stdlib.h>
//
// IPrimaryScreen