add patch from upstream to fix a sign extension problem which

breaks blowfish password hashes for non-ASCII characters
bump PKGREV
This commit is contained in:
drochner 2011-06-20 09:17:50 +00:00
parent c2c4056ca8
commit e31a800ad3
3 changed files with 19 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.19 2010/12/13 10:33:24 wiz Exp $
# $NetBSD: Makefile,v 1.20 2011/06/20 09:17:50 drochner Exp $
#
DISTNAME= john-1.7.6
PKGREVISION= 1
CATEGORIES= security textproc
MASTER_SITES= http://www.openwall.com/john/g/

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.12 2010/12/13 10:32:35 wiz Exp $
$NetBSD: distinfo,v 1.13 2011/06/20 09:17:50 drochner Exp $
SHA1 (john-1.7.6.tar.gz) = da0b6298e6e045606d48880df045096e8bc87fcb
RMD160 (john-1.7.6.tar.gz) = 294fa9a381b45df6fda6e537bc920e74c1d966b0
Size (john-1.7.6.tar.gz) = 832790 bytes
SHA1 (patch-aa) = c7f027cec0ee565312fd4417ded8fe43005b01d1
SHA1 (patch-ab) = 4f8c9e1bba14f64b651c6d08337f004a3e278e44
SHA1 (patch-ac) = 8c123939d2b4939e172ae32cd90ba2950d907dd8

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ac,v 1.1 2011/06/20 09:17:50 drochner Exp $
http://www.openwall.com/lists/john-dev/2011/06/19/3
--- src/BF_std.c.orig 2010-05-25 06:30:33.000000000 +0000
+++ src/BF_std.c
@@ -587,7 +587,7 @@ void BF_std_set_key(char *key, int index
tmp = 0;
for (j = 0; j < 4; j++) {
tmp <<= 8;
- tmp |= *ptr;
+ tmp |= (unsigned char)*ptr;
if (!*ptr) ptr = key; else ptr++;
}