biology/xmakemol: import package from wip.

XMakemol is a mouse-based program, written using the LessTif widget set,
for viewing and manipulating atomic and other chemical systems. It reads
XYZ input and renders atoms, bonds and hydrogen bonds.
This commit is contained in:
vins 2022-12-30 18:17:48 +00:00
parent 419db8629e
commit e353a51fab
8 changed files with 134 additions and 0 deletions

15
biology/xmakemol/DESCR Normal file
View file

@ -0,0 +1,15 @@
XMakemol is a mouse-based program, written using the LessTif widget set,
for viewing and manipulating atomic and other chemical systems. It reads XYZ
input and renders atoms, bonds and hydrogen bonds.
Features include:
- Animating multiple frame files
- Interactive measurement of bond lengths, bond angles and torsion angles
- Control over atom/bond sizes
- Exporting to Xpm, Encapsulated PostScript and XYZ formats
- Toggling the visibility of groups of atoms
- Editing the positions of subsets of atoms
This version incorporates the latest patches from Debian, which provide
additional tuning of H-bond detection.

8
biology/xmakemol/MESSAGE Normal file
View file

@ -0,0 +1,8 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2022/12/30 18:17:48 vins Exp $
To use xmakemol, set the XM_ELEMENTS environmental variable as below:
export XM_ELEMENTS=${PREFIX}/share/xmakemol/elements
===========================================================================

61
biology/xmakemol/Makefile Normal file
View file

@ -0,0 +1,61 @@
# $NetBSD: Makefile,v 1.1 2022/12/30 18:17:48 vins Exp $
DISTNAME= xmakemol-5.16h
CATEGORIES= biology x11
MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/vins/dists/
EXTRACT_SUFX= .tar.xz
MAINTAINER= vins@NetBSD.org
HOMEPAGE= https://www.nongnu.org/xmakemol/
COMMENT= Program for visualizing atomic and molecular systems
LICENSE= gnu-gpl-v2
GNU_CONFIGURE= yes
USE_TOOLS+= gmake perl
USE_TOOLS+= autoconf automake autoreconf
REPLACE_PERL= xmake_anim.pl
ELEM_FILE= ${WRKSRC}/elements
SUBST_CLASSES+= paths
SUBST_STAGE.paths= pre-configure
SUBST_FILES.paths+= xmakemol.1
SUBST_VARS.paths= PREFIX
SUBST_MESSAGE.paths= Replacing PREFIX placeholder.
CONFIGURE_ARGS+= --with-mesa
CONFIGURE_ARGS+= --with-opengl=${BUILDLINK_PREFIX.MesaLib}
BUILDLINK_TRANSFORM+= l:MesaGL:GL
BUILDLINK_TRANSFORM+= l:MesaGLU:GLU
MAKE_FLAGS+= CC=${CC:Q}
MAKE_FLAGS+= CFLAGS='${CFLAGS} -DELEMENTS=\"${ELEM_FILE}\"'
MAKE_FLAGS+= CPPLAGS=${CPPLAGS:Q}
MAKE_FLAGS+= LDFLAGS=${LDFLAGS:Q}
INSTALLATION_DIRS= share/applications
WRKSRC= ${WRKDIR}/${DISTNAME:S,h,,}
post-extract:
${CP} ${FILESDIR}/xmakemol.desktop ${WRKSRC}
post-install:
${INSTALL_DATA} ${WRKSRC}/xmakemol.desktop \
${DESTDIR}${PREFIX}/share/applications/xmakemol.desktop
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../graphics/freeglut/buildlink3.mk"
.include "../../graphics/glw/buildlink3.mk"
.include "../../graphics/glu/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/libXmu/buildlink3.mk"
.include "../../x11/libXi/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
.include "../../mk/motif.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

6
biology/xmakemol/PLIST Normal file
View file

@ -0,0 +1,6 @@
@comment $NetBSD: PLIST,v 1.1 2022/12/30 18:17:48 vins Exp $
bin/xmake_anim.pl
bin/xmakemol
man/man1/xmakemol.1
share/applications/xmakemol.desktop
share/xmakemol/elements

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2022/12/30 18:17:48 vins Exp $
BLAKE2s (xmakemol-5.16h.tar.xz) = 104be5a568d52cceacf8aa0f4c7619d7aa2f0039b4b45ad1ece34aa2c4e895e2
SHA512 (xmakemol-5.16h.tar.xz) = 63ce47a96aaa61872bd27cb60befe175f72b0a3560ce48056d21fce91e0d268436c73b4ddc9bd9fa539cbabe4934167da92122847e226657178e82a7d0e01280
Size (xmakemol-5.16h.tar.xz) = 216832 bytes
SHA1 (patch-Makefile.in) = 57d571687495e824866a9040e43da3ad95ca1904
SHA1 (patch-xmakemol.1) = ef991119d9e5534d6032b7e94f3ea7d7c1cacbe3

View file

@ -0,0 +1,8 @@
[Desktop Entry]
Version=1.0
Name=XMakemol
GenericName=Molecule Viewer
Comment=View and manipulate atomic and other chemical systems
Type=Application
Exec=xmakemol
Categories=Chemistry;Education;Science;

View file

@ -0,0 +1,14 @@
$NetBSD: patch-Makefile.in,v 1.1 2022/12/30 18:17:48 vins Exp $
datarootdir support.
--- Makefile.in.orig 2022-12-22 06:47:47.695595945 +0000
+++ Makefile.in
@@ -41,6 +41,7 @@ bindir = @bindir@
sbindir = @sbindir@
libexecdir = @libexecdir@
datadir = @datadir@
+datarootdir = @datarootdir@
sysconfdir = @sysconfdir@
sharedstatedir = @sharedstatedir@
localstatedir = @localstatedir@

View file

@ -0,0 +1,15 @@
$NetBSD: patch-xmakemol.1,v 1.1 2022/12/30 18:17:48 vins Exp $
Fix hardcoded path.
--- xmakemol.1.orig 2005-03-07 10:49:49.000000000 +0000
+++ xmakemol.1
@@ -47,7 +47,7 @@ Print version information.
.SH FILES
.LP
-\fI/usr/share/xmakemol/elements\fP
+\fI@PREFIX@/share/xmakemol/elements\fP
List of element properties.
.SH ENVIRONMENT VARIABLES