Update to tig-0.10.1. I cannot find a changelog. If you're interested,
see the git history by checking out the repository at the address provided at the homepage.
This commit is contained in:
parent
d8b9f188a7
commit
e35668fd5e
5 changed files with 6 additions and 68 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2007/11/16 07:41:11 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2008/04/06 05:13:45 bjs Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tig-0.9.1
|
||||
DISTNAME= tig-0.10.1
|
||||
CATEGORIES= devel scm
|
||||
MASTER_SITES= http://jonas.nitro.dk/tig/releases/
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2007/11/16 07:41:11 bjs Exp $
|
||||
$NetBSD: distinfo,v 1.2 2008/04/06 05:13:45 bjs Exp $
|
||||
|
||||
SHA1 (tig-0.9.1.tar.gz) = 15ba19a8114ad589f8b370f86bf6878b1e6d378d
|
||||
RMD160 (tig-0.9.1.tar.gz) = f6bb7b52b83d4428e0fe9f85039d65fe5f056393
|
||||
Size (tig-0.9.1.tar.gz) = 100039 bytes
|
||||
SHA1 (tig-0.10.1.tar.gz) = 7793d3a7f603b3cbcc3746f9ef4b724d54693eb9
|
||||
RMD160 (tig-0.10.1.tar.gz) = c9052bb4e1a9d4fb6551b492cfdce540afb402a4
|
||||
Size (tig-0.10.1.tar.gz) = 104006 bytes
|
||||
SHA1 (patch-aa) = 0c0ee454f8d2e7dfad6ed5fa83eeb00adc16da77
|
||||
SHA1 (patch-ab) = c27ccfe5169cb911ede50159e459169fa760c2f8
|
||||
SHA1 (patch-ac) = ae186a0611244326392b01022222872b3b569f7d
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2007/11/16 07:41:11 bjs Exp $
|
||||
|
||||
--- manual.txt.orig 2007-09-29 17:16:27.000000000 -0400
|
||||
+++ manual.txt
|
||||
@@ -343,6 +343,8 @@ u Update status of file. In the status v
|
||||
M Resolve unmerged file by launching git-mergetool(1). Note, to work \
|
||||
correctly this might require some initial configuration of your \
|
||||
preferred merge tool. See the manpage of git-mergetool(1).
|
||||
+',' Move tree view to the parent tree.
|
||||
+e Open file in editor.
|
||||
-----------------------------------------------------------------------------
|
||||
|
||||
[[refspec]]
|
|
@ -1,37 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2007/11/16 07:41:11 bjs Exp $
|
||||
|
||||
--- tig.c.orig 2007-11-16 01:48:58.000000000 -0500
|
||||
+++ tig.c
|
||||
@@ -353,6 +353,7 @@ sq_quote(char buf[SIZEOF_STR], size_t bu
|
||||
REQ_(TOGGLE_REV_GRAPH, "Toggle revision graph visualization"), \
|
||||
REQ_(STATUS_UPDATE, "Update file status"), \
|
||||
REQ_(STATUS_MERGE, "Merge file using external tool"), \
|
||||
+ REQ_(TREE_PARENT, "Switch to parent directory in tree view"), \
|
||||
REQ_(EDIT, "Open in editor"), \
|
||||
REQ_(CHERRY_PICK, "Cherry-pick commit to current branch")
|
||||
|
||||
@@ -790,6 +791,7 @@ static struct keybinding default_keybind
|
||||
{ ':', REQ_PROMPT },
|
||||
{ 'u', REQ_STATUS_UPDATE },
|
||||
{ 'M', REQ_STATUS_MERGE },
|
||||
+ { ',', REQ_TREE_PARENT },
|
||||
{ 'e', REQ_EDIT },
|
||||
{ 'C', REQ_CHERRY_PICK },
|
||||
|
||||
@@ -2861,6 +2863,16 @@ tree_request(struct view *view, enum req
|
||||
{
|
||||
enum open_flags flags;
|
||||
|
||||
+ if (request == REQ_TREE_PARENT) {
|
||||
+ if (*opt_path) {
|
||||
+ /* fake 'cd ..' */
|
||||
+ request = REQ_ENTER;
|
||||
+ line = &view->line[1];
|
||||
+ } else {
|
||||
+ /* quit view if at top of tree */
|
||||
+ return REQ_VIEW_CLOSE;
|
||||
+ }
|
||||
+ }
|
||||
if (request != REQ_ENTER)
|
||||
return request;
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2007/11/16 07:41:11 bjs Exp $
|
||||
|
||||
--- tigrc.5.txt.orig 2007-11-16 01:48:58.000000000 -0500
|
||||
+++ tigrc.5.txt
|
||||
@@ -234,6 +234,7 @@ toggle-lineno Toggle line numbers
|
||||
toggle-rev-graph Toggle revision graph visualization
|
||||
status-update Update file status
|
||||
status-merge Resolve unmerged file
|
||||
+tree-parent Switch to parent directory in tree view
|
||||
edit Open in editor
|
||||
cherry-pick Cherry-pick commit to current branch
|
||||
------------------------------------------------------------------------------
|
Loading…
Reference in a new issue