tcpreplay: update to 4.3.4

This release is for bug fixes only.

    ASAN reports memory leaks while running tests
    local libopts compiler warnings
    DLT name for DLT_C_JNPR_ETHER in documentation
    clean up new_cidr_map() string manipulation on error exit
    fix gcc 8.3.0 build warnings
    invalid --pps value protection
    packets slowly drift further and further behind when they should be sent
    64 bit rollover can cause pps replay issues after several hours
    typo fixes
    DLT_NULL/DLT_LOOP support for cross-platform PF_INET6
    armv5 Freescale compile
    heap buffer overflow in tcpreplay fast_edit_packet
    heap buffer overflow in tcpreplay get_next_packet
    CVE-2020-24266 heap buffer overflow in tcpprep get_l2len
    CVE-2020-24265 heap buffer overflow in tcpprep
    fix UNUSED macro declaration
    handle malformed and unsupported packets as soft errors
    compile failure on aarch64-linux-android
    tcprewrite --fixlen not working on DLT conversion
    fix configure --without-libdnet
    ensure automake version is at least 1.15
    with multiplier option only first file can be sent and hang
    do not create tap0 if device already exists
This commit is contained in:
nia 2021-06-12 06:22:09 +00:00
parent 16f1a7de67
commit e36a228875
3 changed files with 19 additions and 19 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.26 2020/06/21 15:30:39 nia Exp $
# $NetBSD: Makefile,v 1.27 2021/06/12 06:22:09 nia Exp $
DISTNAME= tcpreplay-4.3.3
DISTNAME= tcpreplay-4.3.4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GITHUB:=appneta/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.14 2020/06/21 15:30:39 nia Exp $
$NetBSD: distinfo,v 1.15 2021/06/12 06:22:09 nia Exp $
SHA1 (tcpreplay-4.3.3.tar.xz) = 23ffd5e382d55bb0ed27c7becb196c7565fcaf6b
RMD160 (tcpreplay-4.3.3.tar.xz) = b159ff5fe5d6e4e126932c155bf9680047d19972
SHA512 (tcpreplay-4.3.3.tar.xz) = 110d7768a176d2126766829466a209cdd983afcf0c988f7e128baa5057b3ac1dc918fcaeb168a2e6654429100a146afcbdafcda8c3d67adf6b17892a48689a02
Size (tcpreplay-4.3.3.tar.xz) = 748220 bytes
SHA1 (patch-configure) = acafd832ae7d94520daf9600a18f3419bd440e1e
SHA1 (tcpreplay-4.3.4.tar.xz) = c3b965369c4a17e0b0fd6b10658abf41938263cd
RMD160 (tcpreplay-4.3.4.tar.xz) = 548441954bb4135a8a177d1b475373f8cd13f56f
SHA512 (tcpreplay-4.3.4.tar.xz) = 6d19cf492114c68a9fafcf7790c08f31607d2c0112e02fa41eed8747255bbbef85f281f74348e1d51f1d476b88f07d64715224618ec15268688baefaf7cc7124
Size (tcpreplay-4.3.4.tar.xz) = 739280 bytes
SHA1 (patch-configure) = b0fd4b920672bf399d4ec8213cbb3f084a2edf94

View file

@ -1,15 +1,15 @@
$NetBSD: patch-configure,v 1.1 2020/06/21 15:30:39 nia Exp $
$NetBSD: patch-configure,v 1.2 2021/06/12 06:22:09 nia Exp $
Shell portability.
--- configure.orig 2020-06-14 22:29:09.000000000 +0000
--- configure.orig 2021-05-02 00:25:04.000000000 +0000
+++ configure
@@ -18537,7 +18537,7 @@ $as_echo_n "checking for autogen version
test ${AUTOGEN_MAJOR} -lt 5 ; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
- if test "x$enable_local_libopts" == "xno"; then
+ if test "x$enable_local_libopts" = "xno"; then
as_fn_error $? "${AUTOGEN} is too old (${AUTOGEN_VERSION}) for building from source code. Upgrade to 5.18.4 or higher" "$LINENO" 5
fi
AUTOGEN_VERSION="${AUTOGEN_VERSION} - downlevel"
@@ -23400,7 +23400,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for 'make test' profile" >&5
$as_echo_n "checking for 'make test' profile... " >&6; }
-if test "$host" == "$build" ; then
+if test "$host" = "$build" ; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "yes" >&6; }
else