etlegacy[-server]: update to 2.80.0

2.80.0 (released 09/04/2022)

  Engine

    General

     * Fixed infinite loop in filesystem initalization when pak0.pk3 was
       missing
     * Changed default URI from ET:// (upper case) to et:// (lower case) and
       made case insensitive for compatibility / flexibility

  Client

    General

     * Removed cl_activateLean cvar (moved behaviour to mod
       (cg_activateLean))

    SDL2 Audio backend

     * Fixed double played sound in one frame increasing sound (i.e mg42)

  Mod

    General

     * Fixed players not set unready after swapping teams
     * Fixed wait map-script command not matching the correct time on higher
       sv_fps (comparing to sv_fps 20), which affected and broke certain
       gameplay elements
     * Updated game command list and related help in console
     * Fixed accuracy calculation for splashdamage weapons
     * Fixed dropping objective was allowed during pause
     * Added cg_activateLean, allowing all clients activate lean usage
     * Added g_shoveNoZ to allow disabling Z shove completely
     * Added binds for shifting enemy spawn timer and requesting artillery
     * Changed the way for displaying help command by swapping arguments
       order (Before: <command_name> ?) (After: ? <command_name>)

    Stability & Performance

     * Fixed hitsounds reduced network performance and sometimes get
       duplicated, especially with high pings
     * Added commands flood protection (g_floodProtection / g_floodLimit /
       g_floodWait cvars)
     * Changed unprotect flood for team cmd so class cmd doesn't get dropped
     * Fixed prediction error by changing cg_errorDecay flag with CVAR_CHEAT

    Audio

     * Fixed missing hitsound when player has exactly FORCE_LIMBO_HEALTH
       health (-113 HP)

    Graphics

     * Fixed players breath puffs effect missing completely
     * Fixed pause weapon animation in 1st person during pause
     * Fixed viewmodel FOV calculation wasn't lowering enough 1st person
       weapon draw on FOV > 90
     * Remove g_altSuicideAnim and default to the normal death anim on player
       suiciding
     * Fixed a crash with cg_drawgun 2 and cg_weapanims 0 combination
     * Added voice chat icons for :
          * Affirmative / Negative
          * Hold your fire
          * Say player class

    UI

     * Fixed disconnect icon rendering through walls
     * Added hud componement scale and color configurability from hud file
     * Fixed fireteam highlight overlay spacing on top edge
     * Fixed * characters in map description were not replaced by line feed
     * Added cg_popupTime and cg_numPopups cvar to control popups more
       thoroughly
     * Added sharetimer/sharetimer_buddy commands and cg_sharetimerText cvar
       share the spawntimer you have set for when you think the enemy spawns
     * Removed grid drawing on compass
     * Added cg_fireteamBgAlpha cvar to control fireteam background alpha
       value
     * Added cvar name tooltip in option menus
     * Added missile camera for practice
     * Enhanced squared compass
          * Fixed icon scaling to match regular compass
          * Fixed slightly incorrect out of bounds check for icons
          * Icons are now drawn when they're inside the map and respect map
            zoom
          * Added indicators for N, S, E, W

    Weapons

     * Increased landmine splash radius by 25 (225 -> 250) to match etpro
     * Fixed picking up rifle with full riflenade ammo was restoring 4
       riflenade instead of 5
     * Fixed throwable missiles (i.e: grenade, satchel, dynamite, landmine)
       infinite bouncing
     * Removed hardcoded sensitivity on mounted mg's and use common
       sensitivity
     * Added cg_scopedSensitivityScaler to scale sensitivity when scoped
This commit is contained in:
nia 2022-04-17 09:24:14 +00:00
parent 4b27301520
commit e3798c16c6
5 changed files with 17 additions and 18 deletions

View file

@ -1,6 +1,5 @@
# $NetBSD: Makefile,v 1.27 2022/03/28 10:44:07 tnn Exp $
# $NetBSD: Makefile,v 1.28 2022/04/17 09:24:14 nia Exp $
PKGREVISION= 1
.include "Makefile.common"
PKGNAME= etlegacy-${ETL_VERSION}

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile.common,v 1.6 2022/01/24 14:32:44 nia Exp $
# $NetBSD: Makefile.common,v 1.7 2022/04/17 09:24:14 nia Exp $
# used by games/etlegacy/Makefile
# used by games/etlegacy-server/Makefile
ETL_VERSION= 2.79.0
ETL_VERSION= 2.80.0
CATEGORIES= games
DIST_SUBDIR= etlegacy-${PKGVERSION_NOREV}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2022/01/24 14:32:44 nia Exp $
@comment $NetBSD: PLIST,v 1.9 2022/04/17 09:24:14 nia Exp $
${PLIST.client}bin/etl
bin/etlded
man/man6/etl.6
@ -14,7 +14,7 @@ share/etlegacy/etmain/mapvotecycle.cfg
share/etlegacy/etmain/mapvoteplayerscount.cfg
share/etlegacy/etmain/objectivecycle.cfg
share/etlegacy/legacy/description.txt
share/etlegacy/legacy/legacy_2.79-dirty.pk3
share/etlegacy/legacy/legacy_2.80-dirty.pk3
share/icons/hicolor/scalable/apps/etl.svg
share/licenses/etlegacy/COPYING.txt
share/metainfo/com.etlegacy.ETLegacy.metainfo.xml

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.8 2022/01/24 14:32:44 nia Exp $
$NetBSD: distinfo,v 1.9 2022/04/17 09:24:14 nia Exp $
BLAKE2s (etlegacy-2.79.0/etlegacy-libs.tar.gz) = 497211ec9b468e16d4192ed82ec07ab6927ae7079a55482ffe7e9a6160c992eb
SHA512 (etlegacy-2.79.0/etlegacy-libs.tar.gz) = cdefd393d5606025a98ad8b66bab76312395ba205d4f5144c3ee3674df4dc89f029238ab4ad441a3f38175e96a3f15f603af1cf65d65f658b6918222c5ddc5f3
Size (etlegacy-2.79.0/etlegacy-libs.tar.gz) = 23000305 bytes
BLAKE2s (etlegacy-2.79.0/etlegacy.tar.gz) = 331fb806491ff7c64f92a56e2619ad12c2a7bed3973aa63d66c6f9f20b551a80
SHA512 (etlegacy-2.79.0/etlegacy.tar.gz) = 04891156910ccc8e67bb946d0229dde9f05fd1307404d5e9134e3e912a41540c77600872c4ef0234cb4add98b60ff7b20f2cb412a0226941521e3541d5be1a12
Size (etlegacy-2.79.0/etlegacy.tar.gz) = 15306188 bytes
SHA1 (patch-cmake_ETLInstall.cmake) = f90ad0c02ad04a4539096e2a1301f210a5364f71
BLAKE2s (etlegacy-2.80.0/etlegacy-libs.tar.gz) = 497211ec9b468e16d4192ed82ec07ab6927ae7079a55482ffe7e9a6160c992eb
SHA512 (etlegacy-2.80.0/etlegacy-libs.tar.gz) = cdefd393d5606025a98ad8b66bab76312395ba205d4f5144c3ee3674df4dc89f029238ab4ad441a3f38175e96a3f15f603af1cf65d65f658b6918222c5ddc5f3
Size (etlegacy-2.80.0/etlegacy-libs.tar.gz) = 23000305 bytes
BLAKE2s (etlegacy-2.80.0/etlegacy.tar.gz) = 66ef52c6e45f7133e948e3e2e41dfd0872fcefd5353fecac4f3f3baa885ed26e
SHA512 (etlegacy-2.80.0/etlegacy.tar.gz) = 96261f3653271dac56a333c283db674b97593013dfa0132094eeeda360c98766a0bae5c020430b11f2971a883f6170c841b877a5ea84391a6d9e3a412e8ce491
Size (etlegacy-2.80.0/etlegacy.tar.gz) = 15326908 bytes
SHA1 (patch-cmake_ETLInstall.cmake) = a5b2a80b6cef0f28e5d1042fb84ea617d62fec74
SHA1 (patch-cmake_FindLua.cmake) = b25e7deef2f03f40dfbe577e94717b1bfc0aca59

View file

@ -1,10 +1,10 @@
$NetBSD: patch-cmake_ETLInstall.cmake,v 1.2 2021/12/09 16:10:59 nia Exp $
$NetBSD: patch-cmake_ETLInstall.cmake,v 1.3 2022/04/17 09:24:14 nia Exp $
Install man pages to PKGMANDIR.
--- cmake/ETLInstall.cmake.orig 2021-11-01 20:57:18.000000000 +0000
--- cmake/ETLInstall.cmake.orig 2022-04-09 17:17:04.000000000 +0000
+++ cmake/ETLInstall.cmake
@@ -42,7 +42,7 @@ if(UNIX AND NOT APPLE)
@@ -46,7 +46,7 @@ if(UNIX AND NOT APPLE)
DESTINATION "${INSTALL_DEFAULT_SHAREDIR}/metainfo"
)
install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/docs/linux/man/man6/"
@ -12,4 +12,4 @@ Install man pages to PKGMANDIR.
+ DESTINATION "${CMAKE_INSTALL_MANDIR}/man6"
)
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/docs/INSTALL.txt"
DESTINATION "${INSTALL_DEFAULT_SHAREDIR}/doc/etlegacy"
DESTINATION "${DOCDIR}"