Update ruby23-base and related packages to 2.3.4.

Ruby 2.3.4 Released				2017/3/30

Ruby 2.3.4 has been released.

This release contains about 80 bug fixes after the previous release. See the
commit logs for details.

And this release contains a bug fix of Symbol#hash to be non-deterministic.
This is a regression on the 2.3 series before 2.3.4.  See Bug #13376 for more
details.
This commit is contained in:
taca 2017-04-09 15:57:00 +00:00
parent 7379881e5f
commit e3e17d6f20
8 changed files with 12 additions and 108 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: rubyversion.mk,v 1.171 2017/04/09 15:54:28 taca Exp $
# $NetBSD: rubyversion.mk,v 1.172 2017/04/09 15:57:00 taca Exp $
#
# This file determines which Ruby version is used as a dependency for
@ -230,13 +230,13 @@ RUBY_VERSION_REQD?= ${PKGNAME_REQD:C/ruby([0-9][0-9]+)-.*/\1/}
RUBY18_VERSION= 1.8.7
RUBY21_VERSION= 2.1.10
RUBY22_VERSION= 2.2.7
RUBY23_VERSION= 2.3.3
RUBY23_VERSION= 2.3.4
# patch level
RUBY18_PATCHLEVEL= pl374
#RUBY21_PATCHLEVEL= p492
#RUBY22_PATCHLEVEL= p470
#RUBY23_PATCHLEVEL= p112
#RUBY23_PATCHLEVEL= p301
# current API compatible version; used for version of shared library
RUBY18_API_VERSION= 1.8.7

View file

@ -1,12 +1,10 @@
$NetBSD: distinfo,v 1.5 2016/12/05 15:11:57 taca Exp $
$NetBSD: distinfo,v 1.6 2017/04/09 15:57:01 taca Exp $
SHA1 (ruby-2.3.3.tar.bz2) = a8db9ce7f9110320f33b8325200e3ecfbd2b534b
RMD160 (ruby-2.3.3.tar.bz2) = 487cae3a24d7ad2cef80430efef42f8be2370a12
SHA512 (ruby-2.3.3.tar.bz2) = 88f7782effd35bfe0b4c33140b5eb147d09b63fbb35b9c42d2200c010f387e2b70984ead1eca86569e8ec31f08b35289d440c0ca76b662dadb760f848e863d91
Size (ruby-2.3.3.tar.bz2) = 14433673 bytes
SHA1 (ruby-2.3.4.tar.bz2) = f5b18e7149ec7620444c91962e695708829d0216
RMD160 (ruby-2.3.4.tar.bz2) = a44c9f342a401e75c33a2442b9460b2b1ef7f0f5
SHA512 (ruby-2.3.4.tar.bz2) = ad1f16142615498232d0de85149585be1d2c5de2bc40ec160d272a09e098ef6f317d8b25026001735261fd1c5bc0d1f8513a8474e89f0d86eed5b2fe7338d64e
Size (ruby-2.3.4.tar.bz2) = 14434361 bytes
SHA1 (patch-configure) = e1af70b87cfbb7c61a2bf65109b6e18efb825f0f
SHA1 (patch-eval.c) = 16e6eadca15c95ac3e2291a2003cb0fc606eafeb
SHA1 (patch-eval__error.c) = 8ed04dec5c3c0bf4d9ca8516888b331676f7c957
SHA1 (patch-ext_dbm_extconf.rb) = c998f8735db54b1ae2bc8b6caa359ce88bc7a45b
SHA1 (patch-ext_openssl_ossl__ssl.c) = 24e794aae278da6204e29212d9e2add0b0119ea4
SHA1 (patch-lib_mkmf.rb) = d01302bac014ec1d72bbf19df64bc2c93c07ec5e
@ -25,7 +23,4 @@ SHA1 (patch-man_irb.1) = bf3cd43511ddc51a41dced16f2be1c9f8018d226
SHA1 (patch-man_ri.1) = d8917e7a08bbc3eb41349570cc658d40c1b3463f
SHA1 (patch-man_ruby.1) = c6d1de29fe470024b926226615d97d485dececd9
SHA1 (patch-test_rubygems_test__gem.rb) = 47cc7af18fc5f30d6d695e70851cfaf3205a9266
SHA1 (patch-thread.c) = f837a1ca5c66034331fbbde32017d14e1161c978
SHA1 (patch-tool_rbinstall.rb) = 159b657293029cb5bc096d7c23ae85fe05c88ba2
SHA1 (patch-vm__eval.c) = 79124a03a2a97a5e07f4106b2a8393089d474ed3
SHA1 (patch-vm__trace.c) = 26a2ae6e76fc31d9ea5c8858de3a075f146b6338

View file

@ -1,7 +1,7 @@
# $NetBSD: hacks.mk,v 1.1 2015/12/30 14:59:42 taca Exp $
# $NetBSD: hacks.mk,v 1.2 2017/04/09 15:57:01 taca Exp $
.if !defined(RUBY21_BASE_HACKS_MK)
RUBY21_BASE_HACKS_MK= defined
.if !defined(RUBY23_BASE_HACKS_MK)
RUBY23_BASE_HACKS_MK= defined
.include "../../mk/compiler.mk"
@ -34,4 +34,4 @@ PKG_HACKS+= optimisation
BUILDLINK_TRANSFORM+= opt:-Os:-O1 rm:-freorder-blocks
.endif
.endif # RUBY21_BASE_HACKS_MK
.endif # RUBY23_BASE_HACKS_MK

View file

@ -1,22 +0,0 @@
$NetBSD: patch-eval.c,v 1.1 2015/12/30 14:59:42 taca Exp $
--- eval.c.orig 2015-11-20 00:17:25.000000000 +0000
+++ eval.c
@@ -788,7 +788,7 @@ rb_rescue2(VALUE (* b_proc) (ANYARGS), V
{
int state;
rb_thread_t *th = GET_THREAD();
- rb_control_frame_t *cfp = th->cfp;
+ rb_control_frame_t *volatile cfp = th->cfp;
volatile VALUE result = Qfalse;
volatile VALUE e_info = th->errinfo;
va_list args;
@@ -854,7 +854,7 @@ rb_protect(VALUE (* proc) (VALUE), VALUE
volatile VALUE result = Qnil;
volatile int status;
rb_thread_t *th = GET_THREAD();
- rb_control_frame_t *cfp = th->cfp;
+ rb_control_frame_t * volatile cfp = th->cfp;
struct rb_vm_protect_tag protect_tag;
rb_jmpbuf_t org_jmpbuf;

View file

@ -1,17 +0,0 @@
$NetBSD: patch-eval__error.c,v 1.1 2015/12/30 14:59:42 taca Exp $
--- eval_error.c.orig 2015-10-31 01:22:51.000000000 +0000
+++ eval_error.c
@@ -80,9 +80,9 @@ static void
error_print(void)
{
volatile VALUE errat = Qundef;
- rb_thread_t *th = GET_THREAD();
- VALUE errinfo = th->errinfo;
- int raised_flag = th->raised_flag;
+ rb_thread_t * volatile th = GET_THREAD();
+ volatile VALUE errinfo = th->errinfo;
+ volatile int raised_flag = th->raised_flag;
volatile VALUE eclass = Qundef, e = Qundef;
const char *volatile einfo;
volatile long elen;

View file

@ -1,15 +0,0 @@
$NetBSD: patch-thread.c,v 1.1 2015/12/30 14:59:42 taca Exp $
--- thread.c.orig 2015-12-09 00:38:32.000000000 +0000
+++ thread.c
@@ -466,8 +466,8 @@ rb_threadptr_unlock_all_locking_mutexes(
void
rb_thread_terminate_all(void)
{
- rb_thread_t *th = GET_THREAD(); /* main thread */
- rb_vm_t *vm = th->vm;
+ rb_thread_t *volatile th = GET_THREAD(); /* main thread */
+ rb_vm_t *volatile vm = th->vm;
volatile int sleeping = 0;
if (vm->main_thread != th) {

View file

@ -1,24 +0,0 @@
$NetBSD: patch-vm__eval.c,v 1.1 2015/12/30 14:59:42 taca Exp $
--- vm_eval.c.orig 2015-12-12 09:51:30.000000000 +0000
+++ vm_eval.c
@@ -1267,7 +1267,7 @@ eval_string_with_cref(VALUE self, VALUE
int state;
VALUE result = Qundef;
VALUE envval;
- rb_thread_t *th = GET_THREAD();
+ rb_thread_t *volatile th = GET_THREAD();
rb_env_t *env = NULL;
rb_block_t block, *base_block;
volatile int parse_in_eval;
@@ -2001,8 +2001,8 @@ rb_catch_protect(VALUE t, rb_block_call_
{
int state;
volatile VALUE val = Qnil; /* OK */
- rb_thread_t *th = GET_THREAD();
- rb_control_frame_t *saved_cfp = th->cfp;
+ rb_thread_t * volatile th = GET_THREAD();
+ rb_control_frame_t * volatile saved_cfp = th->cfp;
volatile VALUE tag = t;
TH_PUSH_TAG(th);

View file

@ -1,13 +0,0 @@
$NetBSD: patch-vm__trace.c,v 1.1 2015/12/30 14:59:42 taca Exp $
--- vm_trace.c.orig 2015-12-14 02:52:14.000000000 +0000
+++ vm_trace.c
@@ -389,7 +389,7 @@ rb_suppress_tracing(VALUE (*func)(VALUE)
volatile int raised;
volatile int outer_state;
VALUE result = Qnil;
- rb_thread_t *th = GET_THREAD();
+ rb_thread_t * volatile th = GET_THREAD();
int state;
const int tracing = th->trace_arg ? 1 : 0;
rb_trace_arg_t dummy_trace_arg;