Redo Python 3.x support.

This commit is contained in:
joerg 2017-09-30 20:58:00 +00:00
parent 3f91500185
commit e401533275
4 changed files with 46 additions and 6 deletions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2017/09/30 12:40:08 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2017/09/30 20:58:00 joerg Exp $
bin/get-github-token
bin/gist
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
@ -20,11 +20,11 @@ ${PYSITELIB}/txgithub/scripts/__init__.py
${PYSITELIB}/txgithub/scripts/__init__.pyc
${PYSITELIB}/txgithub/scripts/__init__.pyo
${PYSITELIB}/txgithub/scripts/create_token.py
${PLIST.py2x}${PYSITELIB}/txgithub/scripts/create_token.pyc
${PLIST.py2x}${PYSITELIB}/txgithub/scripts/create_token.pyo
${PYSITELIB}/txgithub/scripts/create_token.pyc
${PYSITELIB}/txgithub/scripts/create_token.pyo
${PYSITELIB}/txgithub/scripts/gist.py
${PLIST.py2x}${PYSITELIB}/txgithub/scripts/gist.pyc
${PLIST.py2x}${PYSITELIB}/txgithub/scripts/gist.pyo
${PYSITELIB}/txgithub/scripts/gist.pyc
${PYSITELIB}/txgithub/scripts/gist.pyo
${PYSITELIB}/txgithub/token.py
${PYSITELIB}/txgithub/token.pyc
${PYSITELIB}/txgithub/token.pyo

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.1 2017/09/29 14:31:29 joerg Exp $
$NetBSD: distinfo,v 1.2 2017/09/30 20:58:00 joerg Exp $
SHA1 (txgithub-15.0.0.tar.gz) = d3c8fbc3e07246f3bbe9520f74285b6383acf113
RMD160 (txgithub-15.0.0.tar.gz) = fa64e8cb817248d841a726a4ca11f3029db09cd2
SHA512 (txgithub-15.0.0.tar.gz) = 1935ad2466655174d92704233eb255993c4244142efb7899f5da0dda35ca58213a0d77f03fd2e34bcfa2cb601afe3d9bf02b22f0bef906ad54c7fc8ada9d46b6
Size (txgithub-15.0.0.tar.gz) = 5534 bytes
SHA1 (patch-txgithub_scripts_create__token.py) = 3fda957e8ef4ab862976ffbf4c32d700dabe8b63
SHA1 (patch-txgithub_scripts_gist.py) = 5b942c0dc0be12ce685201ca26704b57c61f3f66

View file

@ -0,0 +1,13 @@
$NetBSD: patch-txgithub_scripts_create__token.py,v 1.1 2017/09/30 20:58:00 joerg Exp $
--- txgithub/scripts/create_token.py.orig 2017-09-30 20:46:53.750550950 +0000
+++ txgithub/scripts/create_token.py
@@ -34,7 +34,7 @@ def run(reactor, *argv):
config = Options()
try:
config.parseOptions(argv[1:]) # When given no argument, parses sys.argv[1:]
- except usage.UsageError, errortext:
+ except usage.UsageError as errortext:
print('%s: %s' % (argv[0], errortext))
print('%s: Try --help for usage details.' % (argv[0]))
sys.exit(1)

View file

@ -0,0 +1,25 @@
$NetBSD: patch-txgithub_scripts_gist.py,v 1.1 2017/09/30 20:58:00 joerg Exp $
--- txgithub/scripts/gist.py.orig 2017-09-30 20:47:17.806190554 +0000
+++ txgithub/scripts/gist.py
@@ -30,16 +30,16 @@ def postGist(reactor, token, files):
gistFiles['gistfile1'] = {"content": sys.stdin.read()}
response = yield api.gists.create(files=gistFiles)
- print response['html_url']
+ print(response['html_url'])
def run(reactor, *argv):
config = Options()
try:
config.parseOptions(argv[1:]) # When given no argument, parses sys.argv[1:]
- except usage.UsageError, errortext:
- print '%s: %s' % (argv[0], errortext)
- print '%s: Try --help for usage details.' % (argv[0])
+ except usage.UsageError as errortext:
+ print('%s: %s' % (argv[0], errortext))
+ print('%s: Try --help for usage details.' % (argv[0]))
sys.exit(1)
return postGist(reactor, **config)