Fixes for the stricter checking with the new toolchain, provided
by Robert Elz in pkg/14911 (slightly modified by me).
This commit is contained in:
parent
4974d66607
commit
e40218078a
3 changed files with 70 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 02:08:30 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/12/14 09:23:06 martin Exp $
|
||||
|
||||
SHA1 (Maelstrom-1.4.3-L2.0.6-src.tar.gz) = 66c81365104bfab9985919f0cba5a6d955727d79
|
||||
Size (Maelstrom-1.4.3-L2.0.6-src.tar.gz) = 1463130 bytes
|
||||
|
@ -15,3 +15,5 @@ SHA1 (patch-ad) = d5405b696f839c4965fb8e299108aff1b689399a
|
|||
SHA1 (patch-ae) = 6f390cca5abbc0b277d22df8efc4ce589e8b0ecb
|
||||
SHA1 (patch-af) = 46b5ab4cfe3e20401fc5feaa9319c093b025ca1d
|
||||
SHA1 (patch-ag) = aa7102be99466e81b95258a2a2ff888d7136fda3
|
||||
SHA1 (patch-ah) = 03a8dcdc19cbcfb6d13a9de80ef529560bb3ad1a
|
||||
SHA1 (patch-ai) = 25e781f5092530b35256e17003d998443d479372
|
||||
|
|
54
games/maelstrom/patches/patch-ah
Normal file
54
games/maelstrom/patches/patch-ah
Normal file
|
@ -0,0 +1,54 @@
|
|||
$NetBSD: patch-ah,v 1.1 2001/12/14 09:23:06 martin Exp $
|
||||
|
||||
--- netlogic/netplay.cpp.orig Thu Dec 12 23:14:46 1996
|
||||
+++ netlogic/netplay.cpp Tue Dec 11 09:53:18 2001
|
||||
@@ -25,6 +25,10 @@
|
||||
#include <arpa/inet.h>
|
||||
#endif /* Win95 */
|
||||
|
||||
+#ifndef socklen_t
|
||||
+#define socklen_t unsigned int
|
||||
+#endif
|
||||
+
|
||||
int gNumPlayers;
|
||||
int gOurPlayer;
|
||||
int gDeathMatch;
|
||||
@@ -352,7 +356,8 @@
|
||||
int SyncNetwork(void)
|
||||
{
|
||||
int nleft;
|
||||
- int i, clen, len;
|
||||
+ int i, len;
|
||||
+ socklen_t clen;
|
||||
struct sockaddr_in from;
|
||||
unsigned long frame, seed, newseed;
|
||||
struct timeval timeout;
|
||||
@@ -567,7 +572,7 @@
|
||||
struct timeval timeout;
|
||||
fd_set fdset;
|
||||
char netbuf[BUFSIZ];
|
||||
- int clen;
|
||||
+ socklen_t clen;
|
||||
struct sockaddr_in from;
|
||||
|
||||
timeout.tv_sec = 0;
|
||||
@@ -807,7 +812,8 @@
|
||||
char message[BUFSIZ];
|
||||
int nleft, n;
|
||||
int acked[MAX_PLAYERS];
|
||||
- int i, clen, len;
|
||||
+ int i, len;
|
||||
+ socklen_t clen;
|
||||
struct sockaddr_in from;
|
||||
struct timeval timeout;
|
||||
fd_set fdset;
|
||||
@@ -939,7 +945,8 @@
|
||||
int Await_NewGame(int *Wave, int *Lives, int *Turbo)
|
||||
{
|
||||
unsigned char netbuf[BUFSIZ];
|
||||
- int i, clen, len, gameon;
|
||||
+ int i, len, gameon;
|
||||
+ socklen_t clen;
|
||||
struct sockaddr_in from;
|
||||
fd_set fdset;
|
||||
struct timeval timeout;
|
13
games/maelstrom/patches/patch-ai
Normal file
13
games/maelstrom/patches/patch-ai
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ai,v 1.1 2001/12/14 09:23:06 martin Exp $
|
||||
|
||||
--- fastrand.cpp.orig Mon May 26 04:27:54 1997
|
||||
+++ fastrand.cpp Tue Dec 11 09:56:52 2001
|
||||
@@ -14,7 +14,7 @@
|
||||
printf("SeedRandom(%lu)\n", Seed);
|
||||
#endif
|
||||
if ( ! Seed ) {
|
||||
- gettimeofday(&tv, (void *)0);
|
||||
+ gettimeofday(&tv, NULL);
|
||||
randomSeed = ((tv.tv_usec<<16)|((tv.tv_sec^tv.tv_usec)&0xFFFF));
|
||||
return;
|
||||
}
|
Loading…
Reference in a new issue