Mark C. Henderson's port of Matt Fichtenbaums TECO for Ultrix.

This commit is contained in:
is 2005-12-28 22:29:17 +00:00
parent 3608385513
commit e45f4a7fbd
8 changed files with 120 additions and 1 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.113 2005/12/06 22:43:03 wiz Exp $
# $NetBSD: Makefile,v 1.114 2005/12/28 22:33:36 is Exp $
#
COMMENT= Editors
@ -49,6 +49,7 @@ SUBDIR+= lyx-qt
SUBDIR+= lyx-xforms
SUBDIR+= manedit
SUBDIR+= matlab-mode
SUBDIR+= mflteco
SUBDIR+= mg2a
SUBDIR+= mined
SUBDIR+= mlview

1
editors/mflteco/DESCR Normal file
View file

@ -0,0 +1 @@
Mark C. Henderson's port of Matt Fichtenbaums TECO for Ultrix.

34
editors/mflteco/Makefile Normal file
View file

@ -0,0 +1,34 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
#
PKGNAME= mflteco-19920331
DISTNAME= mflteco
CATEGORIES= editors
MASTER_SITES= http://www.catb.org/~esr/retro/
MAINTAINER= is@netbsd.org
HOMEPAGE= http://www.catb.org/~esr/retro/
COMMENT= MFL clone of Tape Editor and COrrector
BUILD_TARGET= te
DOCS= ${LOCALBASE}/share/doc/mflteco
XMPL= ${LOCALBASE}/share/examples/mflteco
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/te ${LOCALBASE}/bin
${INSTALL_DATA_DIR} ${DOCS}
${INSTALL_DATA_DIR} ${XMPL}
${INSTALL_DATA} ${WRKSRC}/00README ${DOCS}
${INSTALL_DATA} ${WRKSRC}/teco.doc ${DOCS}
${INSTALL_DATA} ${WRKSRC}/teco.doc.1 ${DOCS}
${INSTALL_DATA} ${WRKSRC}/.tecorc ${XMPL}
${INSTALL_DATA} ${WRKSRC}/pi.tec ${XMPL}
${INSTALL_DATA} ${WRKSRC}/sample_tecorc.old ${XMPL}
${INSTALL_DATA} ${WRKSRC}/tecorc.mch ${XMPL}
pre-patch:
cp ${WRKSRC}/Makefile.sun4 ${WRKSRC}/Makefile
.include "../../mk/bsd.pkg.mk"

11
editors/mflteco/PLIST Normal file
View file

@ -0,0 +1,11 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
bin/te
share/doc/mflteco/00README
share/doc/mflteco/teco.doc
share/doc/mflteco/teco.doc.1
share/examples/mflteco/.tecorc
share/examples/mflteco/pi.tec
share/examples/mflteco/sample_tecorc.old
share/examples/mflteco/tecorc.mch
@dirrm share/examples/mflteco
@dirrm share/doc/mflteco

8
editors/mflteco/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
SHA1 (mflteco.tar.gz) = d32206d961fa7068afa5a36cf9e688a018622c11
RMD160 (mflteco.tar.gz) = 993ea515f87c17bafc763e3d7dcd55130cf7e83e
Size (mflteco.tar.gz) = 80566 bytes
SHA1 (patch-aa) = 3ee2c99f1a14c8f155faf866d29d070face206ab
SHA1 (patch-ab) = bdeaa25511e11a8e39516eb2aa4c2dbea9f1cf9e
SHA1 (patch-ac) = 052cf6f4ec6d03948543248f7bb9a872b00fb9f8

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
--- Makefile.orig 2005-12-28 22:07:58.000000000 +0100
+++ Makefile
@@ -5,7 +5,7 @@
# te_sunw makes teco to run in a Sun window
# te_tool makes teco to run either in its own window (TECOtool) or in a Sun window
# tt makes TECOtool
-CDF=-O -DMCH
+CDF=-O -DMCH -DWAITRET_INT -DPOSIX_TECO
te: te_data.o te_utils.o te_subs.o te_main.o te_rdcmd.o te_exec0.o te_exec1.o te_exec2.o \
te_srch.o te_chario.o te_window.o te_fxstub.o

View file

@ -0,0 +1,31 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
--- te_exec2.c.orig 1993-08-06 00:29:34.000000000 +0200
+++ te_exec2.c
@@ -42,7 +42,7 @@ VOID update_header();
do_e()
{
- char c; /* temps */
+ int c; /* temps */
int old_var;
FILE *t_eisw;
struct stat statbuff; /* buffer to fetch file stat (mode) of open file for EB */
@@ -609,7 +609,7 @@ int do_glob(gbuff, sbuff)
{
char glob_cmd[CELLSIZE+5]; /* "glob filespec" command string */
int t;
- char c;
+ int c;
int glob_pipe[2]; /* pipe to forked shell for expanding filenames */
struct qp glob_ptr; /* pointer for loading result buffer */
FILE *xx_out; /* stream for reading chars from pipe */
@@ -825,7 +825,7 @@ int read_stream(file, ff_found, rbuff, n
struct qp *rbuff;
int *ff_found, *nchars, endsw, crlf_sw, ff_sw;
{
- char chr;
+ int chr;
int crflag;
register struct buffcell *p;
register int c;

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ac,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
--- te_rdcmd.c.orig 1993-08-06 00:29:35.000000000 +0200
+++ te_rdcmd.c
@@ -9,13 +9,14 @@
#include "te_defs.h"
+static unsigned short do_func_keys();
+
int ccount; /* count of chars read in */
int read_cmdstr()
{
unsigned short c; /* temporary character */
int i; /* temporary */
- unsigned short do_func_keys();
goto prompt;