Add patch to build problem with newer readline.

This commit is contained in:
taca 2014-03-18 03:35:04 +00:00
parent aebfc1d012
commit e482ec1789
4 changed files with 34 additions and 2 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.98 2014/03/17 14:01:57 taca Exp $
$NetBSD: distinfo,v 1.99 2014/03/18 03:35:04 taca Exp $
SHA1 (samba-3.6.23.tar.gz) = 5ba2f8323ab17fa6c04bf87c11d20f10a4fcfe17
RMD160 (samba-3.6.23.tar.gz) = 43dc3b5dcc2ee515bed03ad77b9726841faea946
@ -30,3 +30,4 @@ SHA1 (patch-bc) = 857e2400c8852f3c878f8d82857e80f214be2aea
SHA1 (patch-bd) = b78324305bbf67fa4a7dd627e0af1618d2bf7b47
SHA1 (patch-be) = 2b298e596f2f57a595b83619ba68f6ad95febaaa
SHA1 (patch-bf) = 19932332d11ce447293b061cd47506fef3d01853
SHA1 (patch-eg) = af5ebab1c8e183020bb9a5914d0a218ad91d1a0b

View file

@ -0,0 +1,15 @@
$NetBSD: patch-eg,v 1.1 2014/03/18 03:35:04 taca Exp $
Use modern type definition of readline library.
--- ../libcli/smbreadline/smbreadline.c.orig 2014-03-11 19:17:34.000000000 +0900
+++ ../libcli/smbreadline/smbreadline.c 2014-03-18 10:56:31.000000000 +0900
@@ -141,7 +141,7 @@
#if HAVE_DECL_RL_EVENT_HOOK
if (callback)
- rl_event_hook = (Function *)callback;
+ rl_event_hook = (rl_hook_func_t *)callback;
#endif
ret = readline(prompt);
if (ret && *ret)

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.17 2014/03/03 08:46:45 obache Exp $
$NetBSD: distinfo,v 1.18 2014/03/18 03:35:23 taca Exp $
SHA1 (samba-3.5.22.tar.gz) = 6c807dc64c0cd02bd560c4cfc5fe485964777e49
RMD160 (samba-3.5.22.tar.gz) = ed8d8f9c5c1123334773fa9d47dca1e32ce54b6b
@ -32,3 +32,4 @@ SHA1 (patch-bc) = 857e2400c8852f3c878f8d82857e80f214be2aea
SHA1 (patch-bd) = b78324305bbf67fa4a7dd627e0af1618d2bf7b47
SHA1 (patch-be) = 2b298e596f2f57a595b83619ba68f6ad95febaaa
SHA1 (patch-bf) = 9511567bfe9b579ae0a1c85483e7fe3ad4866973
SHA1 (patch-lib_readline.c) = 69620ecb26f0752f8281e972aa89a4d620aaec87

View file

@ -0,0 +1,15 @@
$NetBSD: patch-lib_readline.c,v 1.1 2014/03/18 03:35:23 taca Exp $
Use modern type definition of readline library.
--- lib/readline.c.orig 2013-07-24 18:53:49.000000000 +0000
+++ lib/readline.c
@@ -148,7 +148,7 @@ char *smb_readline(const char *prompt, v
#if HAVE_DECL_RL_EVENT_HOOK
if (callback)
- rl_event_hook = (Function *)callback;
+ rl_event_hook = (rl_hook_func_t *)callback;
#endif
ret = readline(prompt);
if (ret && *ret)