Try to fix build problem on recent NetBSD release.

This commit is contained in:
obache 2007-12-05 13:38:27 +00:00
parent 3762ad56f0
commit e4832249f3
4 changed files with 111 additions and 11 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2005/12/20 14:32:01 joerg Exp $
$NetBSD: distinfo,v 1.7 2007/12/05 13:38:27 obache Exp $
SHA1 (mgl2-alpha-020.tar.gz) = aa6be2be28749ba9952afbb359ca0525cad3717f
RMD160 (mgl2-alpha-020.tar.gz) = 4c1b6772d9b9adc96279b016fb574defb78f1fe7
@ -13,15 +13,16 @@ SHA1 (patch-ag) = 4bfe05671d580b2a991e6a6990587d5669a24f5f
SHA1 (patch-ah) = 1706347380fe3d00295c4f5dc590c22c3f9edf75
SHA1 (patch-ai) = e24879156f9810fd748f53f9d1e69fcec5ecbe34
SHA1 (patch-aj) = 8d2537a705a864ce5e570bc82a69014144a6c703
SHA1 (patch-ak) = 3c8c077f2a3ad67e68814f8ddba6f8d876538c24
SHA1 (patch-ak) = bc5399de2c816c2f0b6edf12e22ecb187bf4fbdb
SHA1 (patch-al) = 85a4ce2a9779bd4fd3f2a37192a5250824fc9271
SHA1 (patch-am) = a0b8c7b4c37f5bad8ff5fa3d23d72e918595b72f
SHA1 (patch-an) = 958eea3832f726950357f0b6856d2d6347943dfa
SHA1 (patch-ao) = a8baeadfb048e397409d027ac5c53b49e4cbd6b9
SHA1 (patch-ap) = f77dbbd3ae25e17e34d2a81155fdefa8765429a2
SHA1 (patch-aq) = 67b42759d6036d9dbc43789c4bdf9d8c7ed5364a
SHA1 (patch-aq) = ecdf40c1bc906da2bd738e9145719d0a2fc146ff
SHA1 (patch-ar) = 680c2f40e37f8f71d305c8f46460a1fbdc0f0242
SHA1 (patch-as) = fceb87ac6fb9644bd7a640dcc81cf29ca0f824e5
SHA1 (patch-at) = 263b09454b9900d383e3447bc5b3da2e37b495cf
SHA1 (patch-au) = 8450ac4c190d08430583b36c5b8b767601a5aab3
SHA1 (patch-av) = a8ad4b5e4043bfdf8a77ba1f8017fca697f02cab
SHA1 (patch-aw) = 83d0696c69dff81ff4e7af0f50458fa8d7c72515

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ak,v 1.2 2003/10/14 16:22:21 salo Exp $
$NetBSD: patch-ak,v 1.3 2007/12/05 13:38:27 obache Exp $
--- mgterm/mdate.c.orig 2001-03-09 12:05:20.000000000 +0100
+++ mgterm/mdate.c 2003-10-14 17:47:28.000000000 +0200
@@ -66,23 +66,23 @@
--- mgterm/mdate.c.orig 2001-03-09 11:05:20.000000000 +0000
+++ mgterm/mdate.c
@@ -66,23 +66,23 @@ static int from_main=0;
void mdate();
static char *icon_mdate="\
@ -43,7 +43,7 @@ $NetBSD: patch-ak,v 1.2 2003/10/14 16:22:21 salo Exp $
";
main() {
int c;
@@ -670,9 +670,10 @@
@@ -670,9 +670,10 @@ void mem_draw() {
#include <sys/swap.h>
#include <sys/param.h>
#include <sys/sysctl.h>
@ -56,3 +56,27 @@ $NetBSD: patch-ak,v 1.2 2003/10/14 16:22:21 salo Exp $
#endif
#include <errno.h>
@@ -683,7 +684,11 @@ struct swapent swaps[NSWAPS];
int
memmode()
{
+#if __NetBSD_Version__ > 106000000
+ struct uvmexp_sysctl uvmexp;
+#else
struct uvmexp uvmexp;
+#endif
int mib[2];
int size = sizeof(uvmexp);
int pagesize = getpagesize();
@@ -694,7 +699,11 @@ memmode()
if (!memmode_ok)
return 0;
mib[0] = CTL_VM;
+#if __NetBSD_Version__ > 106000000
+ mib[1] = VM_UVMEXP2;
+#else
mib[1] = VM_UVMEXP;
+#endif
if (sysctl(mib, 2, &uvmexp, &size, NULL, 0) < 0) {
printf("Can't get uvmexp: %s\n", strerror(errno));
memset(&uvmexp, 0, sizeof(uvmexp));

View file

@ -1,8 +1,16 @@
$NetBSD: patch-aq,v 1.1 2005/12/20 14:32:01 joerg Exp $
$NetBSD: patch-aq,v 1.2 2007/12/05 13:38:27 obache Exp $
--- lib/draw_engine.c.orig 2005-12-20 14:27:42.000000000 +0000
--- lib/draw_engine.c.orig 2000-09-09 03:40:42.000000000 +0000
+++ lib/draw_engine.c
@@ -413,6 +413,7 @@ void bitblt_generic(struct screen *dst,
@@ -30,6 +30,7 @@
#include "mgl2.h"
#include "draw_engine.h"
#include <stdlib.h>
+#include <stdio.h>
#ifndef NULL
@@ -413,6 +414,7 @@ void bitblt_generic(struct screen *dst,
}
}
ret:

View file

@ -0,0 +1,67 @@
$NetBSD: patch-aw,v 1.1 2007/12/05 13:38:27 obache Exp $
--- lib/ferom.c.orig 2000-12-09 17:49:34.000000000 +0000
+++ lib/ferom.c
@@ -30,6 +30,9 @@
#include <sys/types.h>
#include <sys/mman.h>
+#include <string.h>
+#include <stdio.h>
+#include <stdlib.h>
#include "mgl2.h"
@@ -83,6 +86,7 @@ static struct romfont {
};
#define ferom_font ((struct romfont *)(s->_pen_font.opt))
+#define ferom_font_p (s->_pen_font.opt)
#define ferom_attr (s->_pen_font.attr)
#define ferom_width (s->_pen_font.width)
#define ferom_height (s->_pen_font.height)
@@ -96,36 +100,36 @@ static void ferom_set_font(struct screen
ferom_off = 0;
switch (size) {
case 12:
- ferom_font = &romfont[0];
+ ferom_font_p = &romfont[0];
ferom_width = ferom_height = 12;
break;
case 16:
- ferom_font = &romfont[1];
+ ferom_font_p = &romfont[1];
if (ferom_font->height == 0) {
- ferom_font = &romfont[0];
+ ferom_font_p = &romfont[0];
ferom_off = 2;
}
ferom_width = ferom_height = 16;
break;
case 24:
- ferom_font = &romfont[2];
+ ferom_font_p = &romfont[2];
if (ferom_font->height == 0) {
- ferom_font = &romfont[0];
+ ferom_font_p = &romfont[0];
ferom_off = 6;
}
ferom_width = ferom_height = 24;
break;
default:
if (size == romfont[4].height) {
- ferom_font = &romfont[4];
+ ferom_font_p = &romfont[4];
ferom_width = ferom_font->width;
ferom_height = ferom_font->height;
} else if ( size == romfont[5].height) {
- ferom_font = &romfont[5];
+ ferom_font_p = &romfont[5];
ferom_width = ferom_font->width;
ferom_height = ferom_font->height;
} else {
- ferom_font = &romfont[0];
+ ferom_font_p = &romfont[0];
ferom_width = ferom_font->width;
ferom_height = ferom_font->height;
}