Imported LuaJIT from pkgsrc-wip.
LuaJIT is a Just-In-Time Compiler for the Lua programming language. Lua is a powerful, light-weight programming language designed for extending applications. Lua is also frequently used as a general-purpose, stand-alone language. More information about Lua can be found at: http://www.lua.org/ LuaJIT is based on the Lua 5.1.x virtual machine and bytecode interpreter from lua.org. It compiles bytecode to native x86 (i386+) machine code to speed up the execution of Lua programs. Packaged by pho@cielonegro.org.
This commit is contained in:
parent
f7be48cdf3
commit
e4b29568d6
5 changed files with 89 additions and 0 deletions
9
lang/LuaJIT/DESCR
Normal file
9
lang/LuaJIT/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
LuaJIT is a Just-In-Time Compiler for the Lua programming language.
|
||||
|
||||
Lua is a powerful, light-weight programming language designed for extending
|
||||
applications. Lua is also frequently used as a general-purpose, stand-alone
|
||||
language. More information about Lua can be found at: http://www.lua.org/
|
||||
|
||||
LuaJIT is based on the Lua 5.1.x virtual machine and bytecode interpreter from
|
||||
lua.org. It compiles bytecode to native x86 (i386+) machine code to speed up the
|
||||
execution of Lua programs.
|
31
lang/LuaJIT/Makefile
Normal file
31
lang/LuaJIT/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/07/26 19:34:33 rillig Exp $
|
||||
#
|
||||
|
||||
DISTNAME= LuaJIT-1.1.5
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://luajit.org/download/
|
||||
|
||||
MAINTAINER= pho@cielonegro.org
|
||||
HOMEPAGE= http://luajit.org/
|
||||
COMMENT= Just-In-Time Compiler for the Lua programming language
|
||||
|
||||
LICENSE= mit
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
MAKE_FLAGS+= INSTALL_TOP=${PREFIX}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
OPSYSVARS+= BUILD_TARGET
|
||||
BUILD_TARGET.Linux= linux
|
||||
BUILD_TARGET.FreeBSD= bsd
|
||||
BUILD_TARGET.NetBSD= bsd
|
||||
BUILD_TARGET.OpenBSD= bsd
|
||||
BUILD_TARGET.Darwin= macosx
|
||||
BUILD_TARGET.SunOS= solaris
|
||||
BUILD_TARGET.*= posix
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
9
lang/LuaJIT/PLIST
Normal file
9
lang/LuaJIT/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/07/26 19:34:33 rillig Exp $
|
||||
bin/luajit
|
||||
share/lua/5.1/jit/dis_x86.lua
|
||||
share/lua/5.1/jit/dump.lua
|
||||
share/lua/5.1/jit/dumphints.lua
|
||||
share/lua/5.1/jit/opt.lua
|
||||
share/lua/5.1/jit/opt_inline.lua
|
||||
share/lua/5.1/jit/trace.lua
|
||||
@pkgdir lib/lua/5.1
|
6
lang/LuaJIT/distinfo
Normal file
6
lang/LuaJIT/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/07/26 19:34:33 rillig Exp $
|
||||
|
||||
SHA1 (LuaJIT-1.1.5.tar.gz) = 5141f2ba18d042421e51774d9f60a41d8d1d5cf2
|
||||
RMD160 (LuaJIT-1.1.5.tar.gz) = 2c0f89ede02716f4de06347ea5040f7d75086135
|
||||
Size (LuaJIT-1.1.5.tar.gz) = 362411 bytes
|
||||
SHA1 (patch-aa) = 59b8a259d60a89e9603230bad3a7f9a86a21dff1
|
34
lang/LuaJIT/patches/patch-aa
Normal file
34
lang/LuaJIT/patches/patch-aa
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/07/26 19:34:33 rillig Exp $
|
||||
|
||||
--- Makefile.orig 2008-10-25 09:00:00.000000000 +0900
|
||||
+++ Makefile
|
||||
@@ -61,15 +61,22 @@ test: dummy
|
||||
src/luajit -O -e 'io.write("Hello world, from ", jit.version, "!\n")'
|
||||
|
||||
install: dummy
|
||||
- cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD) $(INSTALL_LMOD)/jit
|
||||
- cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
|
||||
- ###cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
|
||||
- ###cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
|
||||
- ###cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
|
||||
- cd jit && $(INSTALL_DATA) *.lua $(INSTALL_LMOD)/jit
|
||||
+ cd src && $(MKDIR) \
|
||||
+ $(DESTDIR)$(INSTALL_BIN) \
|
||||
+ $(DESTDIR)$(INSTALL_INC) \
|
||||
+ $(DESTDIR)$(INSTALL_LIB) \
|
||||
+ $(DESTDIR)$(INSTALL_MAN) \
|
||||
+ $(DESTDIR)$(INSTALL_LMOD) \
|
||||
+ $(DESTDIR)$(INSTALL_CMOD) \
|
||||
+ $(DESTDIR)$(INSTALL_LMOD)/jit
|
||||
+ cd src && $(INSTALL_EXEC) $(TO_BIN) $(DESTDIR)$(INSTALL_BIN)
|
||||
+ ###cd src && $(INSTALL_DATA) $(TO_INC) $(DESTDIR)$(INSTALL_INC)
|
||||
+ ###cd src && $(INSTALL_DATA) $(TO_LIB) $(DESTDIR)$(INSTALL_LIB)
|
||||
+ ###cd doc && $(INSTALL_DATA) $(TO_MAN) $(DESTDIR)$(INSTALL_MAN)
|
||||
+ cd jit && $(INSTALL_DATA) *.lua $(DESTDIR)$(INSTALL_LMOD)/jit
|
||||
|
||||
ranlib:
|
||||
- cd src && cd $(INSTALL_LIB) && $(RANLIB) $(TO_LIB)
|
||||
+ cd src && cd $(DESTDIR)$(INSTALL_LIB) && $(RANLIB) $(TO_LIB)
|
||||
|
||||
none:
|
||||
@echo "Please do"
|
Loading…
Reference in a new issue