Update to 0.8.3:
New in 0.8.3: * The two hotfixes for libgii 0.8.2 * manpage fixes * several minor fixes New in 0.8.2: 2002-12-??; * Misc bugfixes (see ChangeLog). * Huge Documentation update. * Threadsafety fixes * LibGG: New supported platform: Darwin * Major build system update - autoconf 2.5x works now - build fixes for many platforms * input-kii - new input target. Works for many KGI users, but still not for everyone. - still very experimental, thus disabled by default * input-x/input-xwin - handle GraphicExpose events * input-ipaq - new touchscreen input for Compaq iPaq from Tobias * input-zaurus - new touchscreen input for Sharp Zaurus from Tobias New in 0.8.1: 2001-08-26; * Nothing much in the code except the usual minor fixes. * The build process is improved. New in 0.8: 2001-07-10; * Misc bugfixes (see ChangeLog). * Huge Documentation update. * New API: giiSplitInputs() * input-linux-evdev - Bugfixes from Stephan * input-directx - Update * input-vgl - small build fix for FreeBSD New in 0.7: 2000-12-18; * Portability fixes for non-Linux platforms. * Preliminary Win32 support. * All headers should be C++ compatible now. * Misc bugfixes (see ChangeLog). * Documentation updates. * Renamed GGI_ELOCKBUSY to GGI_EBUSY. * New LibGG functions ggCurTime() and ggConfigExpandAlias(). * LibGG now uses it's own mutexes when compiled with gcc - no more pthreads and dynamic linker bugs. * Support compiler type checking on gii_input_t. * New command events GII_CMDCODE_PREFER_ABSPTR and GII_CMDCODE_PREFER_RELPTR. * input-linux-evdev - New target to support the new evdev input API present in Linux 2.4 and 2.2.18. Should handle mice, joysticks and keyboards. * input-linux-mouse - Improved autodetection of mousetype. * input-mouse - 3 button support for MS protocol. - 4 button support for IMPS/2 protocol. * input-x/input-xwin - Prevent events from lagging in the socket queue in apps that don't call XFLush/XSync frequently. * input-vgl - New inputlib for FreeBSD's VGL library. * input-directx - New inputlib for DirectInput on Win32. * filter-keytrans - Added new filter to arbitrarily remap key events.
This commit is contained in:
parent
fa68f327ab
commit
e4b9ad3f90
11 changed files with 130 additions and 70 deletions
|
@ -1,10 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.5 2003/01/28 22:03:24 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2003/04/02 12:03:41 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libgii-0.6
|
||||
PKGREVISION= 1
|
||||
DISTNAME= libgii-0.8.3.src
|
||||
PKGNAME= ${DISTNAME:S/.src//}
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.ggi-project.org/pub/ggi/ggi/current/
|
||||
MASTER_SITES= ftp://ftp.ggi-project.org/pub/ggi/ggi/v2.0/ \
|
||||
http://www.ggi-project.org/ftp/ggi/v2.0/ \
|
||||
${MASTER_SITE_SOURCEFORGE:=ggi/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= hubertf@netbsd.org
|
||||
HOMEPAGE= http://www.ggi-project.org/
|
||||
|
@ -25,5 +29,8 @@ CONFIGURE_ARGS+= --sysconfdir="${PKG_SYSCONFDIR}"
|
|||
PKG_SYSCONFSUBDIR= ggi
|
||||
EGDIR= ${PREFIX}/share/examples/ggi
|
||||
CONF_FILES= ${EGDIR}/libgii.conf ${PKG_SYSCONFDIR}/libgii.conf
|
||||
MAKE_DIRS+= ${PKG_SYSCONFDIR}/filter
|
||||
CONF_FILES+= ${EGDIR}/filter/keytrans ${PKG_SYSCONFDIR}/filter/keytrans
|
||||
CONF_FILES+= ${EGDIR}/filter/mouse ${PKG_SYSCONFDIR}/filter/mouse
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2003/01/02 23:15:44 jmmv Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2003/04/02 12:03:42 wiz Exp $
|
||||
bin/mhub
|
||||
bin/xsendbut
|
||||
include/ggi/errors.h
|
||||
|
@ -10,15 +10,20 @@ include/ggi/input/lin_kbd.h
|
|||
include/ggi/input/xwin.h
|
||||
include/ggi/internal/gii-dl.h
|
||||
include/ggi/internal/gii.h
|
||||
include/ggi/internal/gii_debug.h
|
||||
include/ggi/keyboard.h
|
||||
include/ggi/system.h
|
||||
lib/ggi/filter/keytrans.a
|
||||
lib/ggi/filter/keytrans.la
|
||||
lib/ggi/filter/keytrans.so
|
||||
lib/ggi/filter/mouse.a
|
||||
lib/ggi/filter/mouse.la
|
||||
lib/ggi/filter/mouse.so
|
||||
lib/ggi/filter/save.a
|
||||
lib/ggi/filter/save.la
|
||||
lib/ggi/filter/save.so
|
||||
lib/ggi/filter/tcp.a
|
||||
lib/ggi/filter/tcp.la
|
||||
lib/ggi/filter/tcp.so
|
||||
lib/ggi/input/file.a
|
||||
lib/ggi/input/file.la
|
||||
lib/ggi/input/file.so
|
||||
|
@ -37,6 +42,9 @@ lib/ggi/input/spaceorb.so
|
|||
lib/ggi/input/stdin.a
|
||||
lib/ggi/input/stdin.la
|
||||
lib/ggi/input/stdin.so
|
||||
lib/ggi/input/tcp.a
|
||||
lib/ggi/input/tcp.la
|
||||
lib/ggi/input/tcp.so
|
||||
lib/ggi/input/x.a
|
||||
lib/ggi/input/x.la
|
||||
lib/ggi/input/x.so
|
||||
|
@ -47,27 +55,66 @@ lib/libgg.a
|
|||
lib/libgg.la
|
||||
lib/libgg.so
|
||||
lib/libgg.so.0
|
||||
lib/libgg.so.0.6
|
||||
lib/libgg.so.0.8
|
||||
lib/libgii.a
|
||||
lib/libgii.la
|
||||
lib/libgii.so
|
||||
lib/libgii.so.0
|
||||
lib/libgii.so.0.6
|
||||
lib/libgii.so.0.8
|
||||
man/man1/mhub.1
|
||||
man/man3/giiAddEventMask.3
|
||||
man/man3/giiClose.3
|
||||
man/man3/giiEventPoll.3
|
||||
man/man3/giiEventRead.3
|
||||
man/man3/giiEventSelect.3
|
||||
man/man3/giiEventSend.3
|
||||
man/man3/giiEventsQueued.3
|
||||
man/man3/giiExit.3
|
||||
man/man3/giiGetEventMask.3
|
||||
man/man3/giiInit.3
|
||||
man/man3/giiJoinInputs.3
|
||||
man/man3/giiMTInit.3
|
||||
man/man3/giiOpen.3
|
||||
man/man3/giiPanic.3
|
||||
man/man3/giiQueryDeviceInfo.3
|
||||
man/man3/giiQueryDeviceInfoByNumber.3
|
||||
man/man3/giiQueryValInfo.3
|
||||
man/man3/giiRemoveEventMask.3
|
||||
man/man3/giiSetEventMask.3
|
||||
man/man3/giiSplitInputs.3
|
||||
man/man3/gii_any_event.3
|
||||
man/man3/gii_cmd_event.3
|
||||
man/man3/gii_cmd_nodata_event.3
|
||||
man/man3/gii_cmddata_getdevinfo.3
|
||||
man/man3/gii_cmddata_getvalinfo.3
|
||||
man/man3/gii_event.3
|
||||
man/man3/gii_event_mask.3
|
||||
man/man3/gii_event_type.3
|
||||
man/man3/gii_expose_event.3
|
||||
man/man3/gii_key_event.3
|
||||
man/man3/gii_pbutton_event.3
|
||||
man/man3/gii_phystype.3
|
||||
man/man3/gii_pmove_event.3
|
||||
man/man3/gii_val_event.3
|
||||
man/man3/gii_valrange.3
|
||||
man/man7/filter-key.7
|
||||
man/man7/filter-keytrans.7
|
||||
man/man7/filter-mouse.7
|
||||
man/man7/filter-save.7
|
||||
man/man7/filter-tcp.7
|
||||
man/man7/input-directx.7
|
||||
man/man7/input-file.7
|
||||
man/man7/input-linux-evdev.7
|
||||
man/man7/input-linux-kbd.7
|
||||
man/man7/input-linux-mouse.7
|
||||
man/man7/input-lk201.7
|
||||
man/man7/input-mouse.7
|
||||
man/man7/input-tcp.7
|
||||
man/man7/libgii.7
|
||||
share/examples/ggi/filter/keytrans
|
||||
share/examples/ggi/filter/mouse
|
||||
share/examples/ggi/libgii.conf
|
||||
@dirrm share/examples/ggi/filter
|
||||
@dirrm share/examples/ggi
|
||||
@dirrm lib/ggi/input
|
||||
@dirrm lib/ggi/filter
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: buildlink2.mk,v 1.2 2002/11/25 20:34:36 jlam Exp $
|
||||
# $NetBSD: buildlink2.mk,v 1.3 2003/04/02 12:03:42 wiz Exp $
|
||||
|
||||
.if !defined(LIBGII_BUILDLINK2_MK)
|
||||
LIBGII_BUILDLINK2_MK= # defined
|
||||
|
||||
BUILDLINK_PACKAGES+= libgii
|
||||
BUILDLINK_DEPENDS.libgii?= libgii>=0.6
|
||||
BUILDLINK_DEPENDS.libgii?= libgii>=0.8.3
|
||||
BUILDLINK_PKGSRCDIR.libgii?= ../../graphics/libgii
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.libgii=libgii
|
||||
|
@ -18,7 +18,6 @@ BUILDLINK_FILES.libgii+= include/ggi/input/lin_kbd.h
|
|||
BUILDLINK_FILES.libgii+= include/ggi/input/xwin.h
|
||||
BUILDLINK_FILES.libgii+= include/ggi/internal/gii-dl.h
|
||||
BUILDLINK_FILES.libgii+= include/ggi/internal/gii.h
|
||||
BUILDLINK_FILES.libgii+= include/ggi/internal/gii_debug.h
|
||||
BUILDLINK_FILES.libgii+= include/ggi/keyboard.h
|
||||
BUILDLINK_FILES.libgii+= include/ggi/system.h
|
||||
BUILDLINK_FILES.libgii+= lib/libgg.*
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.5 2003/01/02 23:15:44 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.6 2003/04/02 12:03:42 wiz Exp $
|
||||
|
||||
SHA1 (libgii-0.6.tar.gz) = d83d7b045343b1f745e6557208532c959e9e825f
|
||||
Size (libgii-0.6.tar.gz) = 258201 bytes
|
||||
SHA1 (patch-aa) = addcc0f20a0676464806f152e9466d344ef052ef
|
||||
SHA1 (patch-ab) = a3052dbb66ffcd6815709cbcaf6eda3d2b138c77
|
||||
SHA1 (patch-ac) = 3c1787495d633f04e7a430de074f36ce19cfb390
|
||||
SHA1 (patch-ad) = 0a3ca686488d26b7a55f2e86a3f10ec2d52e1643
|
||||
SHA1 (patch-ae) = 56fd144dd17a270838935ac333f27e4948aae28e
|
||||
SHA1 (libgii-0.8.3.src.tar.bz2) = d66517e602ecb7766eed707284699a75f4f42f93
|
||||
Size (libgii-0.8.3.src.tar.bz2) = 373117 bytes
|
||||
SHA1 (patch-ab) = 8a152d9b3cedeb9164c6c05059a82068b854dbef
|
||||
SHA1 (patch-ac) = f68870863504ab268071c842a1ef346235c2242c
|
||||
SHA1 (patch-ad) = d34c4862c383d42a12a991fbf9437f0a42d42026
|
||||
SHA1 (patch-ae) = 0efd1b558d098a6645e409092db0238b71507e75
|
||||
SHA1 (patch-af) = 364d793e1f78f87102d497d83c29b334575421e3
|
||||
SHA1 (patch-ag) = cdf19f624e0b87f7e33c9430cc622e8fca10fb47
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2002/11/25 20:16:27 jlam Exp $
|
||||
|
||||
--- doc/man/Makefile.in.orig Sun May 16 13:51:42 1999
|
||||
+++ doc/man/Makefile.in
|
||||
@@ -129,7 +129,7 @@ install-man3:
|
||||
for i in $$list; do \
|
||||
if test -f $(srcdir)/$$i; then file=$(srcdir)/$$i; \
|
||||
else file=$$i; fi; \
|
||||
- ext=`echo $$i | sed -e 's/^.*\\.//'`; \
|
||||
+ ext=`echo $$i | sed -e 's/^.*\\.//;s/gii$$//'`; \
|
||||
inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
|
||||
inst=`echo $$inst | sed '$(transform)'`.$$ext; \
|
||||
echo " $(INSTALL_DATA) $$file $(DESTDIR)$(man3dir)/$$inst"; \
|
||||
@@ -144,7 +144,7 @@ uninstall-man3:
|
||||
esac; \
|
||||
done; \
|
||||
for i in $$list; do \
|
||||
- ext=`echo $$i | sed -e 's/^.*\\.//'`; \
|
||||
+ ext=`echo $$i | sed -e 's/^.*\\.//;s/gii$$//'`; \
|
||||
inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
|
||||
inst=`echo $$inst | sed '$(transform)'`.$$ext; \
|
||||
echo " rm -f $(DESTDIR)$(man3dir)/$$inst"; \
|
|
@ -1,19 +1,20 @@
|
|||
$NetBSD: patch-ab,v 1.2 2002/11/25 20:16:27 jlam Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2003/04/02 12:03:44 wiz Exp $
|
||||
|
||||
--- input/xwin/Makefile.am.orig Wed Mar 31 16:03:12 1999
|
||||
--- input/xwin/Makefile.am.orig Sat Jul 7 21:55:49 2001
|
||||
+++ input/xwin/Makefile.am
|
||||
@@ -10,12 +10,10 @@ xwin_la_LDFLAGS = ${extra_libraries} -mo
|
||||
@@ -11,12 +11,11 @@ xwin_la_LDFLAGS = ${extra_libraries} -mo
|
||||
|
||||
inputlibdir = ${libdir}/ggi/input
|
||||
inputlibdir = ${libdir}/${ggi_subdir}/input
|
||||
|
||||
-xev.c: ../x/xev.c
|
||||
+xev.c: ../x/xev.c ../x/xev.h
|
||||
+xev.c: ../x/xev.c xev.h
|
||||
rm -f xev.c
|
||||
ln -s ../x/xev.c .
|
||||
-
|
||||
-xev.lo:
|
||||
- rm -f xev.lo
|
||||
- ln -s ../x/xev.lo .
|
||||
+xev.h: ../x/xev.h
|
||||
+ rm -f xev.h
|
||||
+ ln -s ../x/xev.h .
|
||||
|
||||
|
|
|
@ -1,21 +1,22 @@
|
|||
$NetBSD: patch-ac,v 1.1 2002/11/25 20:16:27 jlam Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2003/04/02 12:03:44 wiz Exp $
|
||||
|
||||
--- input/xwin/Makefile.in.orig Sun May 16 13:50:59 1999
|
||||
--- input/xwin/Makefile.in.orig Wed Mar 19 22:19:06 2003
|
||||
+++ input/xwin/Makefile.in
|
||||
@@ -334,13 +334,11 @@ mostlyclean-generic distclean-generic cl
|
||||
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
||||
@@ -382,13 +382,13 @@ uninstall-am: uninstall-info-am uninstal
|
||||
uninstall-am uninstall-info-am uninstall-inputlibLTLIBRARIES
|
||||
|
||||
|
||||
-xev.c: ../x/xev.c
|
||||
+xev.c: ../x/xev.c ../x/xev.h
|
||||
+xev.c: ../x/xev.c xev.h
|
||||
rm -f xev.c
|
||||
ln -s ../x/xev.c .
|
||||
-
|
||||
-xev.lo:
|
||||
- rm -f xev.lo
|
||||
- ln -s ../x/xev.lo .
|
||||
+xev.h: ../x/xev.h
|
||||
+ rm -f xev.h
|
||||
+ ln -s ../x/xev.h .
|
||||
|
||||
-xev.lo:
|
||||
- rm -f xev.lo
|
||||
- ln -s ../x/xev.lo .
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1 2003/01/02 23:15:45 jmmv Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2003/04/02 12:03:44 wiz Exp $
|
||||
|
||||
--- Makefile.in.orig Sun May 16 22:48:52 1999
|
||||
--- Makefile.in.orig Wed Mar 19 22:18:49 2003
|
||||
+++ Makefile.in
|
||||
@@ -93,7 +93,7 @@ AUTOMAKE_OPTIONS = foreign
|
||||
@@ -121,7 +121,7 @@ AUTOMAKE_OPTIONS = 1.4 foreign
|
||||
|
||||
SUBDIRS = include gg gii input filter demos doc
|
||||
SUBDIRS = include gg gii input filter demos doc m4 dist
|
||||
|
||||
-giiconfdatadir = @gii_confdir@
|
||||
+giiconfdatadir = @datadir@/examples/ggi
|
||||
-giiconfdatadir = ${sysconfdir}/${ggi_subdir}
|
||||
+giiconfdatadir = $(datadir)/examples/ggi
|
||||
giiconfdata_DATA = libgii.conf
|
||||
|
||||
DISTCLEANFILES = libgii.conf
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2003/01/02 23:15:46 jmmv Exp $
|
||||
$NetBSD: patch-ae,v 1.2 2003/04/02 12:03:44 wiz Exp $
|
||||
|
||||
--- configure.orig Sun May 16 19:53:19 1999
|
||||
--- configure.orig Wed Mar 19 22:19:13 2003
|
||||
+++ configure
|
||||
@@ -4238,7 +4238,7 @@ test "x$exec_prefix" = xNONE && exec_pre
|
||||
|
||||
eval foo="$libdir"
|
||||
eval gii_libdir="$foo"
|
||||
-eval gii_confdir="$sysconfdir/ggi"
|
||||
+eval gii_confdir="$sysconfdir"
|
||||
|
||||
@@ -12990,7 +12990,7 @@ cat >>confdefs.h <<EOF
|
||||
EOF
|
||||
|
||||
cat >>confdefs.h <<EOF
|
||||
-#define GIICONFDIR "$PATHTAG$static_sysconfdir/$ggi_subdir"
|
||||
+#define GIICONFDIR "$PATHTAG$static_sysconfdir"
|
||||
EOF
|
||||
|
||||
# Add the stamp file to the list of files AC keeps track of,
|
||||
|
|
13
graphics/libgii/patches/patch-af
Normal file
13
graphics/libgii/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1 2003/04/02 12:03:44 wiz Exp $
|
||||
|
||||
--- filter/mouse/Makefile.in.orig Wed Apr 2 10:23:23 2003
|
||||
+++ filter/mouse/Makefile.in
|
||||
@@ -125,7 +125,7 @@ mouse_la_LDFLAGS = ${extra_libraries} -m
|
||||
-export-symbols ${srcdir}/EXPSYMS
|
||||
|
||||
|
||||
-giiconfdatadir = ${sysconfdir}/${ggi_subdir}/filter
|
||||
+giiconfdatadir = $(datadir)/examples/ggi/filter
|
||||
giiconfdata_DATA = mouse
|
||||
|
||||
filterlibdir = ${libdir}/${ggi_subdir}/filter
|
13
graphics/libgii/patches/patch-ag
Normal file
13
graphics/libgii/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1 2003/04/02 12:03:45 wiz Exp $
|
||||
|
||||
--- filter/keytrans/Makefile.in.orig Wed Apr 2 10:23:23 2003
|
||||
+++ filter/keytrans/Makefile.in
|
||||
@@ -125,7 +125,7 @@ keytrans_la_LDFLAGS = ${extra_libraries}
|
||||
-export-symbols ${srcdir}/EXPSYMS
|
||||
|
||||
|
||||
-giiconfdatadir = ${sysconfdir}/${ggi_subdir}/filter
|
||||
+giiconfdatadir = $(datadir)/examples/ggi/filter
|
||||
giiconfdata_DATA = keytrans
|
||||
|
||||
filterlibdir = ${libdir}/${ggi_subdir}/filter
|
Loading…
Reference in a new issue