Add patch from upstream, fixing a core dump in amarok.

This commit is contained in:
wiz 2010-04-16 11:45:27 +00:00
parent 34db679fac
commit e4bf26f803
3 changed files with 19 additions and 2 deletions

View file

@ -1,10 +1,11 @@
# $NetBSD: Makefile,v 1.45 2010/02/16 13:08:09 adam Exp $
# $NetBSD: Makefile,v 1.46 2010/04/16 11:45:27 wiz Exp $
PKG_DESTDIR_SUPPORT= user-destdir
.include "../../x11/qt4-libs/Makefile.common"
PKGNAME= qt4-libs-${QTVERSION}
PKGREVISION= 1
COMMENT= C++ X GUI toolkit
# XXX this is to test what really gets installed when 'do-install' is disabled

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.42 2010/03/12 08:19:38 mrg Exp $
$NetBSD: distinfo,v 1.43 2010/04/16 11:45:27 wiz Exp $
SHA1 (qt-everywhere-opensource-src-4.6.2.tar.gz) = 977c10b88a2230e96868edc78a9e3789c0fcbf70
RMD160 (qt-everywhere-opensource-src-4.6.2.tar.gz) = 5f3fea120f2dba274c4150b02162bba40b65a872
@ -29,3 +29,4 @@ SHA1 (patch-aw) = 1e716a1f39cb4aee4872184f700f3e4b455463b6
SHA1 (patch-ax) = 0c17ee0d865a39ed167b6134e73d12a57b9f84a9
SHA1 (patch-ay) = d1e903fd7d4bf0f84d5151303db941702f02e5dc
SHA1 (patch-az) = 8c8cf4f77b28d092ce05ab2d4a8a87d1a22c61a1
SHA1 (patch-ba) = 97f9f21909cf42d04d6c40f1e297791e592b6532

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ba,v 1.4 2010/04/16 11:45:27 wiz Exp $
http://bugreports.qt.nokia.com/browse/QTBUG-6932
--- src/gui/graphicsview/qgraphicsitem_p.h.orig 2010-02-11 15:55:22.000000000 +0000
+++ src/gui/graphicsview/qgraphicsitem_p.h
@@ -678,7 +678,7 @@ inline bool qt_closestItemFirst(const QG
// item1Ancestor is now at the same level as item2Ancestor, but not the same.
const QGraphicsItem *p1 = t1;
const QGraphicsItem *p2 = t2;
- while (t1 && t1 != t2) {
+ while (t1 && t2 && t1 != t2) {
p1 = t1;
p2 = t2;
t1 = t1->d_ptr->parent;