Update to 4.2.1

Changelog:
4.2.1:
This release is primarily a bugfix release; notable changes include:

Oracle:
  * Resolve numerous issues with the 4.0 -> 4.2 upgrade steps on Oracle
  * In-database sessions on Oracle are no longer truncated at 8k,
    leading to spurious logouts

Internet Explorer:
  * Fix submission issues under Internet Explorer

Rich text editor:
  * If returning to a reply/correspond page with the back button, the
    rich text editor will no longer double-escape previously written
    content.

REST:
  * Fix an empty 'text/plain' part when tickets are created using the
    REST interface.

Other bugfixes:
  * Optimize transaction display code to speed up long ticket displays
    by short-circuiting transaction custom field checking.
  * Supply a default $PATH for SMIME and GnuPG under FastCGI
  * Support index upgrade steps on Pg when in a custom schema
  * Close a memory leak in ColumnMap
  * Fix "check all" checkboxes for new jQuery version
  * Secondarily sort user ticket lists by id, as well as priority.
  * Remove call to deprecated function used by PreviewScripMessages
  * Many localization fixes (thanks to Emmanuel Lacour)
  * Show customized rights in their correct tabs
  * Ensure RFC2822 date format uses two-digit days in output
  * Display iCal dates in the user's timezone, resolving off-by-one
    errors for timezones significantly off from GMT.
  * Correctly parse complex format strings for listing in the bottom of
    the Query Builder

Callbacks:
  * Move ModifyQueryProperties callback to before its values are used
  * Additional callbacks on ticket modify pages
  * Additional callbacks on ticket reply/comment page
  * Additional callback on search results page
  * Additional callback before transactions in history list
  * Allow header callback to modify %ARGS

Features
  * Allow bulk update to delete _all_ CF values for a given CF
  * Support CF.Foo in columnmaps, in addition to CF.{Foo} and
    __CF.{Foo}__
  * Autocompletion CFs now autocomplete in search builder
  * Support cascaded selects with any combination of listbox, dropdown,
    and radio button
  * Support ShowUnreadMessageNotifications in SelfService


4.2.0:
RT 4.2.0 -- 2013-10-03
----------------------

We're incredibly pleased to announce the availability of RT 4.2.0 - the
first release for the next major version of RT.  This release adds
exciting new functionality, as well as streamlining and generalizing the
internals.

When upgrading, please be sure to review the upgrading documentation
available in docs/UPGRADING-4.2, as there are a number of
backward-incompatible changes that come along with the new version
number.  Upgrading documentation is also available at
http://www.bestpractical.com/docs/rt/latest/UPGRADING-4.2.html

http://download.bestpractical.com/pub/rt/release/rt-4.2.0.tar.gz
http://download.bestpractical.com/pub/rt/release/rt-4.2.0.tar.gz.asc

a24bd767263cdcee92bf52c6b06a1a573aa0a615  rt-4.2.0.tar.gz
0717fd7d928efaadba2228de855c014e6be735cb  rt-4.2.0.tar.gz.asc

A partial list of the new features in RT 4.2.0 is included below, and on
http://bestpractical.com/rt/whats-new/  Many of the new features will also
be described and demoed in a series of blog posts on
http://blog.bestpractical.com/ in the coming weeks.

If you have questions as you upgrade, please don't hesitate to write to
rt-users@lists.bestpractical.com for community support.  If you'd rather
have professional support from the folks who built RT, drop us a line at
contact@bestpractical.com.

 - Alex Vandiver, for Best Practical


  * Much improved reporting via search result charting
      - Multiple group by and statistic calculations in a table
      - Time statistics such as average, minimum, and maximum durations
        between Created and Resolved, Created and Started, Started and
        Resolved, and more.
      - More robust layout of charts

  * Increased performance for searches and ticket pages
      - Faster searches on all databases (especially Pg)
      - Ticket pages load quicker
      - Menus load before the rest of the page is loaded
      - History is loaded asynchronously
      - Faster serving of static assets

  * Scrips per queue
      - Apply scrips globally or ad-hoc to individual queues, a la custom
        fields
      - Less duplication of scrips and/or need for empty templates

  * Custom field groupings
      - Display CFs in configurable groupings (boxes) on the ticket
        display/edit pages
      - Includes arbitrary grouping names as well as standard ticket
        groupings (Basics, Dates, People, Links, etc.)

  * User summary pages

      - Display information about users such as tickets, history, groups,
        etc.
      - An extended "More about requestors" page for any user
      - Easy to get to via links and user search

  * HTML templates enabled by default for new installs, available for
    upgrades too

  * History improvements
      - Rich text/HTML messages are preferred for display by default
      - Images are inlined with text in ticket history display instead of
        presented at bottom
      - Clickable users, tickets, articles, and other items

  * Many interface improvements, such as:
      - Per-user preferences for the dashboards which appear in the Home
        menu
      - Floating page menu for quicker access to ticket actions, subpages,
        etc.
      - Autocomplete for ticket links, including when merging
      - Autocomplete available to self service users
      - Improved CF and links display in search results
      - Sticky simple search for quick search refinements
      - Attachments on reply can no longer be mixed up when replying to
        multiple tickets at once
      - ReassignTicket right to assign tickets without stealing first;
        useful for managers

  * S/MIME support integrated with GnuPG support
      - Decrypt and verify incoming GPG and SMIME messages
      - Send all outgoing messages as either GPG or SMIME

  * Migration tools
      - Migrate from one database type to another (MySQL, Pg, Oracle)
      - Merge multiple RT instances together

  * Thousands of bug fixes; nearly 2000 commits totalling more than
    250,000 lines of code changed.

4.0.18:
This release is primarily a bugfix release; most notably, it addresses
compatibility issues with recent versions of the Encode perl module.
Notable changes include:

Email
 * Cope with Encode version 2.33 and later, which altered their internal
   functionality and caused RT to double-encode Subject lines in
   outgoing email.
 * Fix HTML rendering errors in dashboard emails.
 * Fix overzealous quoting around decoded MIME words.

Administration
 * In the rights UI, entering the name of a user or group which already
   has rights will now correctly select them for rights granting, as if
   their name had been selected.
 * Display types in the "applies to" dropdown for custom fields in
   consistent order
 * Paginate the Queues list in the administrative interface into 50
   results per page.
 * Support for cascading selections with a multiple-select parent.
 * Clarify that $ParseNewMessageForTicketCcs only applies to new, and
   not existing, tickets.
 * Clarify how an undefined $RTAddressRegexp is treated, and that it
   does not come at any notable performance penalty.

Logging
 * Fix verbosity of syslog messages; now only the 'debug' level includes
   originating filename and line.
 * Include process ID in log messages, for ease of isolation in a
   multi-process environment.
 * Log the From: address of incoming mail which triggered an error, for
   ease of debugging.

Other Bugfixes
 * Avoid linking trailing punctuation, or html tags, in URL anchors in
   MakeClicky
 * Fix the Quick Search (QueueSummary) portlet when non-lowercase statuses are used.
 * Show Date and DateTime custom fields in the user's format and time
   zone in search results.
 * Allow rt-email-group-admin to be passed an email address that RT is
   not already aware of.
 * Show submitted content from the user on errors in REST submission,
   for ease of re-editing and re-submission.
This commit is contained in:
ryoon 2014-01-01 03:31:50 +00:00
parent 3ccee9b765
commit e4c9a125fc
6 changed files with 699 additions and 679 deletions

View file

@ -1,5 +1,5 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2013/04/21 13:59:34 ryoon Exp $
$NetBSD: MESSAGE,v 1.2 2014/01/01 03:31:50 ryoon Exp $
To use RT 4, you will need to perform the following steps.
@ -35,6 +35,12 @@ To use RT 4, you will need to perform the following steps.
$ sudo -u www ${PREFIX}/share/rt4/sbin/rt-server --port 8080
If you configure RT from non-localhost web browser, you should add
the following line to your ${PREFIX}/share/rt4/etc/RT_SiteConfig.pm
before run of rt-server.
Set( $WebDomain, 'your-rt-hostname' );
7. Access http://localhost:8080/ and setup RT 4. After setting up, kill
rt-server with Ctrl-C.

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.6 2013/12/09 14:17:47 obache Exp $
# $NetBSD: Makefile,v 1.7 2014/01/01 03:31:50 ryoon Exp $
DISTNAME= rt-4.0.17
DISTNAME= rt-4.2.1
PKGNAME= ${DISTNAME:S/rt/rt4/}
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/
@ -13,135 +12,132 @@ LICENSE= gnu-gpl-v2
# Dependency info. from sbin/rt-test-dependencies
# Core dependencies
DEPENDS+= p5-Apache-Session>=1.53:../../www/p5-Apache-Session
DEPENDS+= {perl>=5.004,p5-CGI>=3.38}:../../www/p5-CGI
# CGI::Cookie is a part of p5-CGI.
DEPENDS+= p5-CGI-Emulate-PSGI-[0-9]*:../../www/p5-CGI-Emulate-PSGI
DEPENDS+= p5-CGI-PSGI-[0-9]*:../../www/p5-CGI-PSGI
DEPENDS+= p5-Class-Accessor>=0.34:../../devel/p5-Class-Accessor
DEPENDS+= p5-DateTime>=0.44:../../time/p5-DateTime
DEPENDS+= p5-DateTime-Locale>=0.40:../../time/p5-DateTime-Locale
DEPENDS+= p5-Class-ReturnValue>=0.40:../../devel/p5-Class-ReturnValue
DEPENDS+= p5-DBIx-SearchBuilder>=1.59:../../databases/p5-DBIx-SearchBuilder
DEPENDS+= p5-Text-Template>=1.44:../../textproc/p5-Text-Template
DEPENDS+= p5-File-ShareDir-[0-9]*:../../devel/p5-File-ShareDir
DEPENDS+= p5-HTML-Quoted-[0-9]*:../../www/p5-HTML-Quoted
DEPENDS+= p5-HTML-Scrubber>=0.08:../../www/p5-HTML-Scrubber
DEPENDS+= p5-HTML-Tree-[0-9]*:../../www/p5-HTML-Tree
DEPENDS+= p5-HTML-Format-[0-9]*:../../www/p5-HTML-Format
DEPENDS+= p5-Log-Dispatch>=2.23:../../devel/p5-Log-Dispatch
DEPENDS+= {perl>=5.8.9,p5-Sys-Syslog>=0.16}:../../sysutils/p5-Sys-Syslog
DEPENDS+= p5-MIME-tools>=5.425:../../mail/p5-MIME-tools
DEPENDS+= p5-MailTools>=1.57:../../mail/p5-MailTools
DEPENDS+= p5-Locale-Maketext-Lexicon>=0.32:../../misc/p5-Locale-Maketext-Lexicon
DEPENDS+= p5-Locale-Maketext-Fuzzy-[0-9]*:../../misc/p5-Locale-Maketext-Fuzzy
DEPENDS+= p5-Email-Address-[0-9]*:../../mail/p5-Email-Address
DEPENDS+= p5-Text-Wrapper-[0-9]*:../../textproc/p5-Text-Wrapper
DEPENDS+= p5-Time-modules-[0-9]*:../../time/p5-Time-modules
DEPENDS+= {perl>=5.7.3,p5-Time-HiRes-[0-9]*}:../../time/p5-Time-HiRes
DEPENDS+= {perl>=5.10.1,p5-File-Temp>=0.19}:../../devel/p5-File-Temp
DEPENDS+= p5-Text-Quoted>=2.02:../../textproc/p5-Text-Quoted
DEPENDS+= p5-Tree-Simple>=1.04:../../devel/p5-Tree-Simple
DEPENDS+= p5-UNIVERSAL-require-[0-9]*:../../devel/p5-UNIVERSAL-require
DEPENDS+= p5-Regexp-Common-[0-9]*:../../textproc/p5-Regexp-Common
DEPENDS+= p5-Scalar-List-Utils-[0-9]*:../../devel/p5-Scalar-List-Utils
DEPENDS+= p5-Module-Versions-Report>=1.05:../../devel/p5-Module-Versions-Report
DEPENDS+= p5-Cache-Simple-TimedExpiry-[0-9]*:../../devel/p5-Cache-Simple-TimedExpiry
DEPENDS+= {perl>=5.11.3,p5-Encode>=2.39}:../../textproc/p5-Encode
DEPENDS+= p5-Crypt-Eksblowfish-[0-9]*:../../security/p5-Crypt-Eksblowfish
DEPENDS+= p5-Data-GUID-[0-9]*:../../devel/p5-Data-GUID
DEPENDS+= p5-CSS-Squish>=0.06:../../www/p5-CSS-Squish
# File::Glob is a part of perl base.
DEPENDS+= p5-Devel-StackTrace>=1.19:../../devel/p5-Devel-StackTrace
DEPENDS+= p5-Text-Password-Pronounceable-[0-9]*:../../security/p5-Text-Password-Pronounceable
DEPENDS+= p5-Date-Extract>=0.02:../../time/p5-Date-Extract
DEPENDS+= p5-Date-Manip-[0-9]*:../../devel/p5-Date-Manip
DEPENDS+= p5-DateTime>=0.44:../../time/p5-DateTime
DEPENDS+= p5-DateTime-Format-Natural>0.67:../../time/p5-DateTime-Format-Natural
DEPENDS+= p5-DateTime-Locale>=0.40:../../time/p5-DateTime-Locale
DEPENDS+= p5-DBI-[0-9]*:../../databases/p5-DBI
DEPENDS+= p5-DBIx-SearchBuilder>=1.65:../../databases/p5-DBIx-SearchBuilder
DEPENDS+= p5-Devel-GlobalDestruction-[0-9]*:../../devel/p5-Devel-GlobalDestruction
DEPENDS+= p5-Devel-StackTrace>=1.19:../../devel/p5-Devel-StackTrace
# Digest::base is a part of perl base.
DEPENDS+= {perl>=5.8.1,p5-Digest-MD5>=2.27}:../../security/p5-Digest-MD5
DEPENDS+= p5-Digest-SHA-[0-9]*:../../security/p5-Digest-SHA
DEPENDS+= p5-Email-Address>=1.897:../../mail/p5-Email-Address
DEPENDS+= p5-Email-Address-List-[0-9]*:../../mail/p5-Email-Address-List
DEPENDS+= {perl>=5.11.3,p5-Encode>=2.39}:../../textproc/p5-Encode
# Errno is a part of perl base.
# File::Glob is a part of perl base.
DEPENDS+= p5-File-ShareDir-[0-9]*:../../devel/p5-File-ShareDir
# File::Spec is a part of perl base.
DEPENDS+= {perl>=5.10.1,p5-File-Temp>=0.19}:../../devel/p5-File-Temp
# HTML::Entities is a part of p5-HTML-Parser.
DEPENDS+= p5-HTML-FormatText-WithLinks>=0.14:../../textproc/p5-HTML-FormatText-WithLinks
DEPENDS+= p5-HTML-FormatText-WithLinks-AndTables-[0-9]*:../../textproc/p5-HTML-FormatText-WithLinks-AndTables
DEPENDS+= p5-HTML-Mason-PSGIHandler>=0.52:../../www/p5-HTML-Mason-PSGIHandler
DEPENDS+= p5-HTML-Quoted-[0-9]*:../../www/p5-HTML-Quoted
DEPENDS+= p5-HTML-RewriteAttributes>=0.05:../../www/p5-HTML-RewriteAttributes
DEPENDS+= p5-HTML-Scrubber>=0.08:../../www/p5-HTML-Scrubber
DEPENDS+= p5-IPC-Run3-[0-9]*:../../devel/p5-IPC-Run3
DEPENDS+= p5-JSON-[0-9]*:../../converters/p5-JSON
DEPENDS+= p5-List-MoreUtils-[0-9]*:../../devel/p5-List-MoreUtils
DEPENDS+= p5-Locale-Maketext>=1.06:../../misc/p5-Locale-Maketext
DEPENDS+= p5-Locale-Maketext-Fuzzy-[0-9]*:../../misc/p5-Locale-Maketext-Fuzzy
DEPENDS+= p5-Locale-Maketext-Lexicon>=0.32:../../misc/p5-Locale-Maketext-Lexicon
DEPENDS+= p5-Log-Dispatch>=2.30:../../devel/p5-Log-Dispatch
# Mail::Header is a part of p5-MailTools.
DEPENDS+= p5-MailTools>=1.57:../../mail/p5-MailTools
# Mail::Mailer is a part of p5-MailTools.
DEPENDS+= p5-MIME-tools>=5.504:../../mail/p5-MIME-tools
DEPENDS+= p5-Module-Refresh>=0.03:../../devel/p5-Module-Refresh
DEPENDS+= p5-Module-Versions-Report>=1.05:../../devel/p5-Module-Versions-Report
DEPENDS+= p5-Net-CIDR-[0-9]*:../../devel/p5-Net-CIDR
DEPENDS+= p5-Plack>=1.0002:../../www/p5-Plack
# Plack::Handler::Starlet is a part of p5-Startlet.
DEPENDS+= p5-Starlet-[0-9]*:../../www/p5-Starlet
DEPENDS+= p5-Regexp-Common-[0-9]*:../../textproc/p5-Regexp-Common
DEPENDS+= p5-Regexp-Common-net-CIDR-[0-9]*:../../net/p5-Regexp-Common-net-CIDR
DEPENDS+= p5-Regexp-IPv6-[0-9]*:../../net/p5-Regexp-IPv6
# Mason dependencies
DEPENDS+= p5-HTML-Mason>=1.43:../../www/p5-HTML-Mason
# Errno is a part of perl base.
DEPENDS+= {perl>=5.8.1,p5-Digest-MD5>=2.27}:../../security/p5-Digest-MD5
DEPENDS+= {perl>=5.004,p5-CGI>=1.20}:../../www/p5-CGI
#DEPENDS+= p5-Storable>=2.08:../../devel/p5-Storable
DEPENDS+= p5-Apache-Session>=1.53:../../www/p5-Apache-Session
DEPENDS+= p5-XML-RSS>=1.05:../../textproc/p5-XML-RSS
DEPENDS+= p5-Role-Basic-[0-9]*:../../devel/p5-Role-Basic
# Scalar::Util is a part of p5-Scalar-List-Utils.
DEPENDS+= p5-Scalar-List-Utils-[0-9]*:../../devel/p5-Scalar-List-Utils
DEPENDS+= p5-Storable>=2.08:../../devel/p5-Storable
DEPENDS+= p5-Symbol-Global-Name>=0.04:../../devel/p5-Symbol-Global-Name
DEPENDS+= {perl>=5.8.9,p5-Sys-Syslog>=0.16}:../../sysutils/p5-Sys-Syslog
DEPENDS+= p5-Text-Password-Pronounceable-[0-9]*:../../security/p5-Text-Password-Pronounceable
DEPENDS+= p5-Text-Quoted>=2.02:../../textproc/p5-Text-Quoted
DEPENDS+= p5-Text-Template>=1.44:../../textproc/p5-Text-Template
DEPENDS+= p5-Text-WikiFormat>=0.76:../../textproc/p5-Text-WikiFormat
DEPENDS+= p5-JSON-[0-9]*:../../converters/p5-JSON
DEPENDS+= p5-IPC-Run3-[0-9]*:../../devel/p5-IPC-Run3
# PSGI dependencies
DEPENDS+= p5-CGI-PSGI-[0-9]*:../../www/p5-CGI-PSGI
DEPENDS+= p5-HTML-Mason-PSGIHandler>=0.52:../../www/p5-HTML-Mason-PSGIHandler
DEPENDS+= p5-Plack>=0.9971:../../www/p5-Plack
DEPENDS+= p5-Starlet-[0-9]*:../../www/p5-Starlet
DEPENDS+= p5-CGI-Emulate-PSGI-[0-9]*:../../www/p5-CGI-Emulate-PSGI
DEPENDS+= p5-CGI-Emulate-PSGI-[0-9]*:../../www/p5-CGI-Emulate-PSGI
DEPENDS+= p5-Text-Wrapper-[0-9]*:../../textproc/p5-Text-Wrapper
DEPENDS+= {perl>=5.7.3,p5-Time-HiRes-[0-9]*}:../../time/p5-Time-HiRes
# Time::ParseDate is a part of p5-Time-modules.
DEPENDS+= p5-Time-modules-[0-9]*:../../time/p5-Time-modules
DEPENDS+= p5-Tree-Simple>=1.04:../../devel/p5-Tree-Simple
DEPENDS+= p5-UNIVERSAL-require-[0-9]*:../../devel/p5-UNIVERSAL-require
DEPENDS+= p5-XML-RSS>=1.05:../../textproc/p5-XML-RSS
DEPENDS+= p5-HTML-Mason>=1.43:../../www/p5-HTML-Mason
# Mailgate dependencies
DEPENDS+= p5-Crypt-SSLeay-[0-9]*:../../security/p5-Crypt-SSLeay
DEPENDS+= {perl>=5,p5-Getopt-Long-[0-9]*}:../../devel/p5-Getopt-Long
DEPENDS+= p5-LWP-Protocol-https-[0-9]*:../../www/p5-LWP-Protocol-https
# LWP::UserAgent is a part of p5-libwww.
DEPENDS+= p5-libwww-[0-9]*:../../www/p5-libwww
DEPENDS+= p5-Mozilla-CA-[0-9]*:../../security/p5-Mozilla-CA
# Net::SSL is a part of p5-Crypt-SSLeay.
DEPENDS+= {perl>=5.6.0,p5-Pod-Usage-[0-9]*}:../../devel/p5-Pod-Usage
# SSL-Mailgate dependencies
DEPENDS+= p5-Crypt-SSLeay-[0-9]*:../../security/p5-Crypt-SSLeay
DEPENDS+= p5-LWP-Protocol-https-[0-9]*:../../www/p5-LWP-Protocol-https
DEPENDS+= p5-Mozilla-CA-[0-9]*:../../security/p5-Mozilla-CA
# CLI dependencies
# p5-Getopt-Long is duplicate with Mailgate dependencies.
# HTTP::Request::Common is a part of p5-HTTP-Message.
DEPENDS+= p5-HTTP-Message-[0-9]*:../../www/p5-HTTP-Message
# Text::ParseWords is a part of perl base.
# Term::ReadLine is a part of perl base.
# LWP is a pert of perl base.
DEPENDS+= p5-Term-ReadKey-[0-9]*:../../devel/p5-Term-ReadKey
# Term::ReadLine is a part of perl base.
# Text::ParseWords is a pert of perl base.
# Dev dependencies
#DEPENDS+= p5-Email-Abstract-[0-9]*:../../mail/p5-Email-Abstract
#DEPENDS+= p5-Test-Email-[0-9]*:../../mail/p5-Test-Email
#DEPENDS+= p5-HTML-Form-[0-9]*:../../www/p5-HTML-Form
#DEPENDS+= p5-HTML-Parser-[0-9]*:../../www/p5-HTML-Parser
#DEPENDS+= p5-WWW-Mechanize>=1.52:../../www/p5-WWW-Mechanize
#DEPENDS+= p5-Test-WWW-Mechanize>=1.30:../../www/p5-Test-WWW-Mechanize
#DEPENDS+= p5-Module-Refresh>=0.03:../../devel/p5-Module-Refresh
#DEPENDS+= p5-Test-Expect>=0.31:../../devel/p5-Test-Expect
#DEPENDS+= p5-XML-Simple-[0-9]*:../../textproc/p5-XML-Simple
#DEPENDS+= p5-XML-Simple-[0-9]*:../../textproc/p5-XML-Simple
# File::Find is a part of perl base.
#DEPENDS+= p5-Test-Deep>=0:../../devel/p5-Test-Deep
#DEPENDS+= p5-String-ShellQuote-[0-9]*:../../textproc/p5-String-ShellQuote
#DEPENDS+= p5-Log-Dispatch-Perl-[0-9]*:../../devel/p5-Log-Dispatch-Perl
#DEPENDS+= p5-Test-Warn-[0-9]*:../../devel/p5-Test-Warn
#DEPENDS+= {perl>=5.10.1,p5-Test-Simple>=0.90}:../../devel/p5-Test-Simple
#DEPENDS+= p5-Test-MockTime-[0-9]*:../../time/p5-Test-MockTime
#DEPENDS+= p5-Test-WWW-Mechanize-PSGI-[0-9]*:../../www/p5-Test-WWW-Mechanize-PSGI
#DEPENDS+= p5-Plack-Middleware-Test-StashWarnings-[0-9]*:../../www/p5-Plack-Middleware-Test-StashWarnings
#DEPENDS+= p5-Test-LongString-[0-9]*:../../devel/p5-Test-LongString
#DEPENDS+= p5-Test-NoWarnings-[0-9]*:../../devel/p5-Test-NoWarnings
# Developer dependencies
# These are not used for normal use.
# DASHBOARD dependencies
DEPENDS+= p5-URI>=1.59:../../www/p5-URI
DEPENDS+= p5-MIME-Types-[0-9]*:../../mail/p5-MIME-Types
# URI::QueryParam is a part of p5-URI.
# GD dependencies
DEPENDS+= p5-GD-[0-9]*:../../graphics/p5-GD
DEPENDS+= p5-GDGraph-[0-9]*:../../graphics/p5-GDGraph
# GD::Text is a part of p5-GDTextUtil.
DEPENDS+= p5-GDTextUtil-[0-9]*:../../graphics/p5-GDTextUtil
# GPG dependencies
DEPENDS+= p5-File-Which-[0-9]*:../../devel/p5-File-Which
DEPENDS+= p5-GnuPG-Interface-[0-9]*:../../security/p5-GnuPG-Interface
DEPENDS+= p5-PerlIO-eol-[0-9]*:../../devel/p5-PerlIO-eol
# ICAL dependency
DEPENDS+= p5-Data-ICal-[0-9]*:../../time/p5-Data-ICal
# SMTP dependency
DEPENDS+= p5-Net-[0-9]*:../../net/p5-Net
# DASHBOARD dependencies
DEPENDS+= p5-HTML-RewriteAttributes>=0.05:../../www/p5-HTML-RewriteAttributes
DEPENDS+= p5-MIME-Types-[0-9]*:../../mail/p5-MIME-Types
DEPENDS+= p5-URI>=1.59:../../www/p5-URI
# GRAPHVIS dependencies
#DEPENDS+= p5-GraphViz-[0-9]*:../../graphics/p5-GraphViz
#DEPENDS+= p5-IPC-Run>=0.90:../../devel/p5-IPC-Run
# GD dependencies
DEPENDS+= p5-GD-[0-9]*:../../graphics/p5-GD
DEPENDS+= p5-GDGraph-[0-9]*:../../graphics/p5-GDGraph
DEPENDS+= p5-GDTextUtil-[0-9]*:../../graphics/p5-GDTextUtil
# SMIME dependencies
DEPENDS+= p5-String-ShellQuote-[0-9]*:../../textproc/p5-String-ShellQuote
DEPENDS+= p5-Crypt-X509-[0-9]*:../../security/p5-Crypt-X509
# File::Which is in GPG dependencies.
# USERLOGO dependency
# Module::Pluggable will be removed from the Perl core distribution...
DEPENDS+= p5-Module-Pluggable-[0-9]*:../../devel/p5-Module-Pluggable
DEPENDS+= p5-Convert-Color-[0-9]*:../../converters/p5-Convert-Color
# HTML-DOC dependency
DEPENDS+= {perl>=5.9.3,p5-Pod-Simple-[0-9]*}:../../textproc/p5-Pod-Simple
.include "options.mk"
RT4DIR= ${PREFIX}/share/rt4

File diff suppressed because it is too large Load diff

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.3 2013/08/24 00:27:50 ryoon Exp $
$NetBSD: distinfo,v 1.4 2014/01/01 03:31:50 ryoon Exp $
SHA1 (rt-4.0.17.tar.gz) = b348fa687001db08198bc2b014a348083108e801
RMD160 (rt-4.0.17.tar.gz) = 3136f0bab20d95a68786ca62e39e51a013648560
Size (rt-4.0.17.tar.gz) = 6925490 bytes
SHA1 (patch-config.layout) = 8199ae2d9e3b400380e24eaa54a76d8b2dcecf57
SHA1 (rt-4.2.1.tar.gz) = 08bd8e4d28c065030aac7b33c0a15a789a6e11f9
RMD160 (rt-4.2.1.tar.gz) = 0a6bd58d228914de518d1707b62a34be50d2c6ab
Size (rt-4.2.1.tar.gz) = 7630594 bytes
SHA1 (patch-config.layout) = d5f4a93d06c80a8dc7bb55db7054bf4be53a3998
SHA1 (patch-share_html_Install_Initialize.html) = 44b2ae9727ca3de7f0fafa226ec9e83c424e6ade

View file

@ -1,10 +1,10 @@
$NetBSD: patch-config.layout,v 1.1 2013/04/21 13:59:34 ryoon Exp $
$NetBSD: patch-config.layout,v 1.2 2014/01/01 03:31:50 ryoon Exp $
* Add layout for pkgsrc.
--- config.layout.orig 2013-04-09 15:22:04.000000000 +0000
--- config.layout.orig 2013-11-13 18:25:50.000000000 +0000
+++ config.layout
@@ -226,3 +226,27 @@
@@ -215,6 +215,32 @@
customlibdir: ${customdir}/lib
customplugindir: ${customdir}/plugins
</Layout>
@ -18,17 +18,22 @@ $NetBSD: patch-config.layout,v 1.1 2013/04/21 13:59:34 ryoon Exp $
+ plugindir: @RT4DIR@/plugins
+ libdir: @RT4DIR@/lib
+ datadir: @RT4DIR@/data
+ htmldir: ${datadir}/html
+ fontdir: ${datadir}/fonts
+ lexdir: ${datadir}/po
+ htmldir: ${datadir}/html
+ manualdir: ${datadir}/docs
+ localstatedir: @RT4DIR@/var
+ logfiledir: ${localstatedir}/log
+ masonstatedir: ${localstatedir}/mason_data
+ sessionstatedir: ${localstatedir}/session_data
+ staticdir: ${datadir}/static
+ customdir: @RT4DIR@/local
+ custometcdir: ${customdir}/etc
+ customhtmldir: ${customdir}/html
+ customlexdir: ${customdir}/po
+ customlibdir: ${customdir}/lib
+ customstaticdir: ${customdir}/static
+</Layout>
<Layout vessel>
prefix: /opt/rt4
exec_prefix: ${prefix}

View file

@ -0,0 +1,15 @@
$NetBSD: patch-share_html_Install_Initialize.html,v 1.1 2014/01/01 03:31:50 ryoon Exp $
From upstream, https://github.com/bestpractical/rt/commit/b4517c1.patch
Fix installation finish fail.
--- share/html/Install/Initialize.html.orig 2013-11-13 18:25:50.000000000 +0000
+++ share/html/Install/Initialize.html
@@ -119,6 +119,7 @@ if ( $Run ) {
$RT::Handle->dbh( undef );
RT::ConnectToDatabase();
RT::InitLogging();
+ RT::InitClasses();
($status, $msg) = $RT::Handle->InsertInitialData;
}
elsif ( $action eq 'insert' ) {