Import libzrtpcpp-2.3.2 as net/libzrtpcpp.
libzrtpcpp, a separate extension package to ccrtp, provides support for the ZRTP protocol (as defined in the Internet draft draft-zimmermann-avt-zrtp).
This commit is contained in:
parent
cb2398dd85
commit
e4e417472f
6 changed files with 98 additions and 0 deletions
2
net/libzrtpcpp/DESCR
Normal file
2
net/libzrtpcpp/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
libzrtpcpp, a separate extension package to ccrtp, provides support for the ZRTP
|
||||
protocol (as defined in the Internet draft draft-zimmermann-avt-zrtp).
|
30
net/libzrtpcpp/Makefile
Normal file
30
net/libzrtpcpp/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/04/17 00:55:35 rodent Exp $
|
||||
|
||||
DISTNAME= libzrtpcpp-2.3.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=ccrtp/}
|
||||
|
||||
MAINTAINER= rodent@NetBSD.org
|
||||
HOMEPAGE= http://wiki.gnutelephony.org/
|
||||
COMMENT= ZRTP extension for GNU ccRTP
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES+= c c++
|
||||
USE_CMAKE= yes
|
||||
PKG_DESTDIR_SUPPORT= destdir
|
||||
CMAKE_ARGS+= -DLIBDIRNAME=lib
|
||||
|
||||
BUILDLINK_API_DEPENDS.openssl+= openssl>=0.9.7i
|
||||
BUILDLINK_DEPMETHOD.openssl= build
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../security/libgpg-error/buildlink3.mk"
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../devel/ucommon/buildlink3.mk"
|
||||
.include "../../net/ccrtp/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
13
net/libzrtpcpp/PLIST
Normal file
13
net/libzrtpcpp/PLIST
Normal file
|
@ -0,0 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2013/04/17 00:55:35 rodent Exp $
|
||||
include/libzrtpcpp/TimeoutProvider.h
|
||||
include/libzrtpcpp/ZrtpCWrapper.h
|
||||
include/libzrtpcpp/ZrtpCallback.h
|
||||
include/libzrtpcpp/ZrtpCodes.h
|
||||
include/libzrtpcpp/ZrtpConfigure.h
|
||||
include/libzrtpcpp/ZrtpQueue.h
|
||||
include/libzrtpcpp/ZrtpUserCallback.h
|
||||
include/libzrtpcpp/zrtpccrtp.h
|
||||
lib/libzrtpcpp.so
|
||||
lib/libzrtpcpp.so.2
|
||||
lib/libzrtpcpp.so.${PKGVERSION}
|
||||
lib/pkgconfig/libzrtpcpp.pc
|
22
net/libzrtpcpp/buildlink3.mk
Normal file
22
net/libzrtpcpp/buildlink3.mk
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2013/04/17 00:55:35 rodent Exp $
|
||||
|
||||
BUILDLINK_TREE+= libzrtpcpp
|
||||
|
||||
.if !defined(LIBZRTPCPP_BUILDLINK3_MK)
|
||||
LIBZRTPCPP_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libzrtpcpp+= libzrtpcpp>=0.9.0
|
||||
BUILDLINK_ABI_DEPENDS.libzrtpcpp?= libzrtpcpp>=1.4.6nb1
|
||||
BUILDLINK_PKGSRCDIR.libzrtpcpp?= ../../net/libzrtpcpp
|
||||
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../security/libgpg-error/buildlink3.mk"
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../devel/ucommon/buildlink3.mk"
|
||||
.include "../../net/ccrtp/buildlink3.mk"
|
||||
.endif # LIBZRTPCPP_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libzrtpcpp
|
6
net/libzrtpcpp/distinfo
Normal file
6
net/libzrtpcpp/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/04/17 00:55:35 rodent Exp $
|
||||
|
||||
SHA1 (libzrtpcpp-2.3.2.tar.gz) = 75714bf9eb705bb4e430119f5d2527d5dcfa6f26
|
||||
RMD160 (libzrtpcpp-2.3.2.tar.gz) = 5a30d848b755afe3036e67d7fe881d0ec9c71fd4
|
||||
Size (libzrtpcpp-2.3.2.tar.gz) = 256951 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 4c47e69e4b1d48748c14268a25e192e7bb1ae953
|
25
net/libzrtpcpp/patches/patch-CMakeLists.txt
Normal file
25
net/libzrtpcpp/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2013/04/17 00:55:36 rodent Exp $
|
||||
|
||||
Don't set LIB_SUFFIX for pkgsrc. LIBDIRNAME is set via CMAKE_ARGS.
|
||||
|
||||
--- CMakeLists.txt.orig 2012-10-17 13:16:16.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -71,18 +71,6 @@ endif()
|
||||
enable_arg(ccrtp true "Enable GNU ccRTP support for GNU ZRTP")
|
||||
args_help()
|
||||
|
||||
-if (NOT LIB_SUFFIX)
|
||||
- set(LIBDIRNAME "lib")
|
||||
- # this caused problems in debian where it has to always be lib....
|
||||
- if (NOT EXISTS /etc/debian_version)
|
||||
- if ( "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64" )
|
||||
- set(LIBDIRNAME "lib64")
|
||||
- endif()
|
||||
- endif()
|
||||
-else()
|
||||
- set(LIBDIRNAME "lib${LIB_SUFFIX}")
|
||||
-endif()
|
||||
-
|
||||
# setup the Thread include and lib
|
||||
find_package(Threads)
|
||||
if(CMAKE_HAVE_PTHREAD_H)
|
Loading…
Reference in a new issue