Update package to version 9.3.1 and make it work on alpha. Update supplied

by Tim Rightnour in PR pkg/5621.
This commit is contained in:
tron 1998-06-27 22:03:40 +00:00
parent f7c296ed67
commit e4ede79924
55 changed files with 561 additions and 407 deletions

View file

@ -1,15 +1,17 @@
# $NetBSD: Makefile,v 1.8 1998/06/22 12:44:30 agc Exp $
# $NetBSD: Makefile,v 1.9 1998/06/27 22:03:40 tron Exp $
# FreeBSD Id: Makefile,v 1.8 1997/02/12 08:39:15 tg Exp
#
DISTNAME= unix
PKGNAME= icon-9.3
PKGNAME= icon-9.3.1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.cs.arizona.edu/icon/packages/unix/
ONLY_FOR_ARCHS= i386
MASTER_SITES= http://www.cs.arizona.edu/icon/ftp/packages/unix/
EXTRACT_SUFX= .tgz
ONLY_FOR_ARCHS= alpha i386
MAINTAINER= packages@netbsd.org
DIST_SUBDIR= icon
NO_WRKSUBDIR= true
ALL_TARGET= Icon Icon-iconc
@ -18,4 +20,6 @@ OPSYS!= uname -s
MANCOMPRESSED= yes
.endif
MAN1= icon.1
.include "../../mk/bsd.pkg.mk"

View file

@ -1 +1 @@
MD5 (unix.tar.gz) = 6fa53241bb6eff844b155c22a98c2150
MD5 (icon/unix.tgz) = 87b8628e24c1e7c14edbe593f46e06e4

View file

@ -1,17 +1,20 @@
--- config/unix/i386_freebsd/define.h.orig Tue Mar 7 21:50:58 1995
+++ config/unix/i386_freebsd/define.h Sat Nov 2 17:24:10 1996
@@ -21,6 +21,7 @@
--- src/runtime/rmisc.r 1997/10/02 09:28:35 1.1
+++ src/runtime/rmisc.r 1997/10/02 09:30:08
@@ -123,14 +123,15 @@
return buf;
#endif /* OS2EMX */
#define Standard
#define Double
+#define IconEcvt
#define IconGcvt
#define GetHost
#define SysOpt
@@ -41,5 +42,5 @@
#define LoadFunc
#define SystemFnc
-#if FreeBSD
+#if (defined(GenericBSD) && !defined(FreeBSD))
+/* This is commented out in the FreeBSD ports collection */
#define ecvt(w,x,y,z) 0
-
+#define LinkLibs " -lm"
#define COpts "-I/usr/X11R6/include"
sprintf(buf, "%f", number);
for(i=strlen(buf); i>1 && buf[i-1]=='0' && buf[i-2]!='.'; i--)
buf[i-1] = '\0';
return buf;
-#endif /* FreeBSD */
+#endif /* GenericBSD && !FreeBSD */
p1 = ecvt(number, ndigit, &decpt, &sign);
p2 = buf;

View file

@ -1,20 +1,21 @@
--- src/runtime/rmisc.r 1997/10/02 09:28:35 1.1
+++ src/runtime/rmisc.r 1997/10/02 09:30:08
@@ -123,14 +123,15 @@
return buf;
#endif /* OS2EMX */
-#if FreeBSD
+#if (defined(GenericBSD) && !defined(FreeBSD))
+/* This is commented out in the FreeBSD ports collection */
#define ecvt(w,x,y,z) 0
sprintf(buf, "%f", number);
for(i=strlen(buf); i>1 && buf[i-1]=='0' && buf[i-2]!='.'; i--)
buf[i-1] = '\0';
return buf;
-#endif /* FreeBSD */
+#endif /* GenericBSD && !FreeBSD */
p1 = ecvt(number, ndigit, &decpt, &sign);
p2 = buf;
--- Makefile.orig Fri Feb 13 07:18:30 1998
+++ Makefile Fri Jun 19 04:31:38 1998
@@ -188 +188,18 @@
##################################################################
+
+install:
+ @bin/patchstr bin/iconc ${PREFIX}/share/icon/
+ @bin/patchstr bin/icont ${PREFIX}/bin/iconx
+ install -c -s -g bin -o bin -m 755 bin/iconc ${PREFIX}/bin/iconc
+ install -c -s -g bin -o bin -m 755 bin/icont ${PREFIX}/bin/icont
+ install -c -s -g bin -o bin -m 755 bin/iconx ${PREFIX}/bin/iconx
+ install -c -s -g bin -o bin -m 755 bin/patchstr ${PREFIX}/bin/patchstr
+ @mkdir -p ${PREFIX}/share/icon
+ install -c -g bin -o bin -m 644 bin/dlrgint.o ${PREFIX}/share/icon/dlrgint.o
+ install -c -g bin -o bin -m 644 bin/rt.a ${PREFIX}/share/icon/rt.a
+ install -c -g bin -o bin -m 644 bin/rt.db ${PREFIX}/share/icon/rt.db
+ install -c -g bin -o bin -m 644 bin/rt.h ${PREFIX}/share/icon/rt.h
+# @mkdir -p ${PREFIX}/man/man1
+# install -c -g bin -o bin -m 444 docs/icon.1 ${PREFIX}/man/man1/icon.1
+# @gzip -9fn ${PREFIX}/man/man1/icon.1
+# XXX (icon.1 missing from this distribution!)

View file

@ -0,0 +1,17 @@
*** config/unix/Config/Makefile.orig Fri Jul 29 21:40:55 1994
--- config/unix/Config/Makefile Wed Mar 1 14:27:05 1995
***************
*** 1,7 ****
- CC=cc
- CFLAGS= -DVarTran
- LDFLAGS=
SHELL=/bin/sh
MAKE=make
all:
--- 1,5 ----
SHELL=/bin/sh
+ CFLAGS+= -DVarTran
MAKE=make
all:

View file

@ -0,0 +1,21 @@
*** src/h/sys.h.orig Fri Jul 29 21:24:57 1994
--- src/h/sys.h Wed Mar 1 15:43:55 1995
***************
*** 181,192 ****
--- 181,196 ----
#include <sys/ioctl.h>
#include <errno.h>
#include <sys/signal.h>
+ #include <sys/param.h>
+ #if (defined(BSD) && BSD >= 199306)
+ #include <sgtty.h>
+ #endif
#endif /* HaveTioc */
#endif /* KeyboardFncs */
#ifdef LoadFunc
#include <dlfcn.h>
#endif /* LoadFunc */
#endif /* UNIX */

View file

@ -1,24 +1,3 @@
*** src/h/sys.h.orig Fri Jul 29 21:24:57 1994
--- src/h/sys.h Wed Mar 1 15:43:55 1995
***************
*** 181,192 ****
--- 181,196 ----
#include <sys/ioctl.h>
#include <errno.h>
#include <sys/signal.h>
+ #include <sys/param.h>
+ #if (defined(BSD) && BSD >= 199306)
+ #include <sgtty.h>
+ #endif
#endif /* HaveTioc */
#endif /* KeyboardFncs */
#ifdef LoadFunc
#include <dlfcn.h>
#endif /* LoadFunc */
#endif /* UNIX */
*** src/runtime/fload.r.orig Fri Jul 29 21:22:51 1994
--- src/runtime/fload.r Sun Apr 16 14:02:26 1995
***************

View file

@ -0,0 +1,13 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/common.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,10 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CFLAGS+= -D$D
+SHELL=/bin/sh
+RSWITCH=rswitch.c

View file

@ -0,0 +1,6 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/copybin.c Wed Oct 1 17:32:26 1997
@@ -0,0 +1,3 @@
+#include "../../../src/h/define.h"
+#include "paths.h"
+#include "../Generic/copybin.h"

View file

@ -0,0 +1,25 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/define.h Wed Oct 1 17:32:26 1997
@@ -0,0 +1,22 @@
+#define Standard
+#define IconGcvt
+#define index strchr
+#define rindex strrchr
+#define GetHost
+#define Hz 100
+#define MaxHdr 13400
+#define MaxStatSize 20480
+
+#define GenericBSD
+#define BSD_4_4_LITE 1 /* This is new, for 4.4Lite specific stuff */
+#define UNIX 1
+#define LoadFunc
+#define ExecImages
+
+#define KeyboardFncs
+#define HaveTioc
+#define USE_OLD_TTY
+#define AllowConst
+#define SysOpt
+#define CComp "gcc"
+#define COpts "-O2"

View file

@ -0,0 +1,5 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/icon_pi.c Wed Oct 1 17:32:26 1997
@@ -0,0 +1,2 @@
+#include "paths.h"
+#include "../Generic/icon_pi.h"

View file

@ -0,0 +1,12 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/iconc.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1,9 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CFLAGS+= -D$D
+SHELL=/bin/sh

View file

@ -0,0 +1,4 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/icont.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1 @@
+SHELL=/bin/sh

View file

@ -0,0 +1,10 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/iconx.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1,7 @@
+SHELL=/bin/sh
+# the seek stuff is defined in a header file that they don't
+# include. This is the easiest. -Dconst= causes const to
+# be ignored. This is needed because otherwise we get complaints
+# due to stdio.h defining some functions with const when they
+# are not defined that way in Icon's header files
+RSWITCH=rswitch.c

View file

@ -0,0 +1,6 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/paths.h Wed Oct 1 17:32:26 1997
@@ -0,0 +1,3 @@
+#define RootPath "/usr/local"
+#define IcontPath "/usr/local/lib/icon/icont"
+#define IconxPath "/usr/local/lib/icon/iconx"

View file

@ -0,0 +1,5 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/pi.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+=-DPersInterp

View file

@ -0,0 +1,13 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/preproc.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,10 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CC=cc
+CFLAGS+= -O -D$D
+SHELL=/bin/sh

View file

@ -0,0 +1,31 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/rswitch.c Wed Oct 1 17:32:25 1997
@@ -0,0 +1,28 @@
+/*
+ * This is the co-expression context switch for the Intel 80386
+ * under Microport Unix System V/386
+ */
+
+/*
+ * coswitch
+ */
+
+coswitch(old_cs, new_cs, first)
+int *old_cs, *new_cs;
+int first;
+ {
+ asm(" movl 8(%ebp),%eax");
+ asm(" movl %esp,0(%eax)");
+ asm(" movl %ebp,4(%eax)");
+ asm(" movl 12(%ebp),%eax");
+ if (first == 0) { /* this is the first activation */
+ asm(" movl 0(%eax),%esp");
+ asm(" movl $0,%ebp");
+ new_context(0, 0);
+ syserr("interp() returned in coswitch");
+ }
+ else {
+ asm(" movl 0(%eax),%esp");
+ asm(" movl 4(%eax),%ebp");
+ }
+ }

View file

@ -0,0 +1,5 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/rtt.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+CFLAGS+= -DTokDotH="\"../rtt/ltoken.h\""
+SHELL=/bin/sh

View file

@ -0,0 +1,4 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/runtime.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1 @@
+SHELL=/bin/sh

View file

@ -0,0 +1,5 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/setpath.c Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+#include "paths.h"
+#include "../Generic/setpath.h"

View file

@ -0,0 +1,31 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/status Wed Oct 1 17:36:09 1997
@@ -0,0 +1,28 @@
+System configuration:
+
+ Intel 486-type processor or better running BSD 4.4.lite derivative
+
+Latest Icon version:
+
+ Version 9.3
+
+Installer:
+
+ Alistair G. Crooks
+ <agc@netbsd.org>
+
+Missing features:
+
+ None.
+
+Known bugs:
+
+ None.
+
+Comments:
+
+ None.
+
+Date:
+
+ Wed Oct 1 17:36:04 BST 1997

View file

@ -0,0 +1,5 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/vt.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+= -DVarTran

View file

@ -0,0 +1,5 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/vtran.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+= -DVarTran

View file

@ -0,0 +1,6 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/xiconx.mak Wed Oct 1 17:32:25 1997
@@ -0,0 +1,3 @@
+# If you define EventMon, add the -lgmon below to get profil(2) under Linux
+#XLIB= -lX11 -lgmon
+XLIB= -L/usr/X11R6/lib -lX11

View file

@ -0,0 +1,18 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/intel_netbsd/xpm.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1 @@
+DEFINES= -DZPIPE
--- src/common/save.c 1997/10/02 07:49:07 1.1
+++ src/common/save.c 1997/10/02 08:00:57
@@ -91,7 +91,11 @@
* Construct the header. The text and data region sizes must be multiples
* of 1024.
*/
+#ifdef __NetBSD__
+ N_SETMAGIC(hdr, ZMAGIC, MID_I386, EX_DYNAMIC);
+#else
hdr.a_magic = ZMAGIC;
+#endif
tsize = (int)&etext;
hdr.a_text = (tsize + 1024) & ~(1024-1);
dsize = sbrk(0) - (int)&environ;

View file

@ -0,0 +1,10 @@
--- src/iconc/ccode.c.orig Fri Jun 19 02:25:13 1998
+++ src/iconc/ccode.c Fri Jun 19 02:26:35 1998
@@ -3428,5 +3428,6 @@
/*
+ XXX the Z thing is getting eaten by the comment!
cd->ElemTyp(i) = A_Str;
str = (char *)alloc(strlen(cur->csym->image)+8);
- sprintf(str, "\"%s\"/*Z*/", cur->csym->image);
+ sprintf(str, "\"%s\"X/*Z*X/", cur->csym->image);
cd->Str(i) = str;

View file

@ -0,0 +1,13 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/common.hdr Fri Jun 19 02:48:05 1998
@@ -0,0 +1,10 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CFLAGS+= -D$D
+SHELL=/bin/sh
+RSWITCH=rswitch.s

View file

@ -0,0 +1,4 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/xpm.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1 @@
+DEFINES= -DZPIPE

View file

@ -0,0 +1,49 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/rswitch.s Fri Jun 19 02:47:53 1998
@@ -0,0 +1,46 @@
+/*
+ * coswitch(old_cs, new_cs, first) for Dec Alpha architecture
+ * $16 $17 $18
+ */
+ .data
+errmsg: .ascii "new_context() returned in coswitch\X00"
+
+ .text
+ .globl coswitch
+ .ent coswitch
+coswitch:
+ lda $sp, -72($sp) /* make room on stack */
+ stq $sp, 0($16) /* save stack pointer */
+ stq $9, 0($sp) /* save registers on stack */
+ stq $10, 8($sp)
+ stq $11, 16($sp)
+ stq $12, 24($sp)
+ stq $13, 32($sp)
+ stq $14, 40($sp)
+ stq $15, 48($sp)
+ stq $27, 56($sp)
+ stq $26, 64($sp) /* return address */
+ beq $18, first /* if first time */
+
+ ldq $sp, 0($17) /* load new stack pointer */
+ ldq $9, 0($sp) /* load registers from stack */
+ ldq $10, 8($sp)
+ ldq $11, 16($sp)
+ ldq $12, 24($sp)
+ ldq $13, 32($sp)
+ ldq $14, 40($sp)
+ ldq $15, 48($sp)
+ ldq $27, 56($sp)
+ ldq $26, 64($sp) /* return address */
+ lda $sp, 72($sp) /* reset sp */
+ jsr_coroutine $31, ($26), 0 /* jump into new_context */
+
+first:
+ ldq $sp, 0($17) /* load stack pointer only */
+ bis $31, $31, $16 /* r16 = 0 */
+ bis $31, $31, $17 /* r17 = 0 */
+ jsr $26, new_context /* new_context(0,0) */
+ lda $16, errmsg
+ jsr $26, syserr /* shouldn't get here */
+
+ .end coswitch

View file

@ -0,0 +1,6 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/xiconx.mak Fri Jun 19 02:44:07 1998
@@ -0,0 +1,3 @@
+# If you define EventMon, add the -lgmon below to get profil(2) under Linux
+#XLIB= -lX11 -lgmon
+XLIB= -L/usr/X11R6/lib -lX11

View file

@ -0,0 +1,5 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/vtran.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+= -DVarTran

View file

@ -0,0 +1,5 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/vt.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+= -DVarTran

View file

@ -0,0 +1,32 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/status Fri Jun 19 02:46:17 1998
@@ -0,0 +1,28 @@
+System configuration:
+
+ Alpha 21064 processor or better running NetBSD
+
+Latest Icon version:
+
+ Version 9.3.1
+
+Installer:
+
+ Tim Rightnour
+ root@garbled.net
+
+Missing features:
+
+ None.
+
+Known bugs:
+
+ None.
+
+Comments:
+
+ Most of this was taken directly from dec_osf and intel_netbsd.
+ The same errata that applies to the dec_osf version applies here.
+
+Date:
+
+ Fri Jun 19 02:46:07 MST 1998

View file

@ -0,0 +1,5 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/setpath.c Fri Jun 19 02:44:07 1998
@@ -0,0 +1,2 @@
+#include "paths.h"
+#include "../Generic/setpath.h"

View file

@ -0,0 +1,4 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/runtime.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1 @@
+SHELL=/bin/sh

View file

@ -0,0 +1,5 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/rtt.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1,2 @@
+CFLAGS+= -DTokDotH="\"../rtt/ltoken.h\""
+SHELL=/bin/sh

View file

@ -0,0 +1,13 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/preproc.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1,10 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CC=cc
+CFLAGS+= -O -D$D
+SHELL=/bin/sh

View file

@ -0,0 +1,5 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/pi.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+=-DPersInterp

View file

@ -0,0 +1,6 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/paths.h Fri Jun 19 02:44:07 1998
@@ -0,0 +1,3 @@
+#define RootPath "/usr/local"
+#define IcontPath "/usr/local/lib/icon/icont"
+#define IconxPath "/usr/local/lib/icon/iconx"

View file

@ -0,0 +1,10 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/iconx.hdr Fri Jun 19 02:48:20 1998
@@ -0,0 +1,7 @@
+SHELL=/bin/sh
+# the seek stuff is defined in a header file that they don't
+# include. This is the easiest. -Dconst= causes const to
+# be ignored. This is needed because otherwise we get complaints
+# due to stdio.h defining some functions with const when they
+# are not defined that way in Icon's header files
+RSWITCH=rswitch.s

View file

@ -0,0 +1,4 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/icont.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1 @@
+SHELL=/bin/sh

View file

@ -0,0 +1,12 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/iconc.hdr Fri Jun 19 02:44:07 1998
@@ -0,0 +1,9 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CFLAGS+= -D$D
+SHELL=/bin/sh

View file

@ -0,0 +1,5 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/icon_pi.c Fri Jun 19 02:44:07 1998
@@ -0,0 +1,2 @@
+#include "paths.h"
+#include "../Generic/icon_pi.h"

View file

@ -0,0 +1,32 @@
--- /dev/null Fri Jun 19 03:24:28 1998
+++ config/unix/alpha_netbsd/define.h Fri Jun 19 05:00:47 1998
@@ -0,0 +1,28 @@
+#define Standard
+#define IconGcvt
+#define index strchr
+#define rindex strrchr
+#define GetHost
+#define MaxHdr 13400
+#define MaxStatSize 20480
+
+#define GenericBSD
+#define BSD_4_4_LITE 1 /* This is new, for 4.4Lite specific stuff */
+#define UNIX 1
+#define LoadFunc
+#define ExecImages
+
+#define KeyboardFncs
+#define HaveTioc
+#define USE_OLD_TTY
+#define AllowConst
+#define SysOpt
+#define CComp "gcc"
+#define COpts "-O2"
+
+/* CPU architecture */
+#define IntBits 32
+#define WordBits 64
+#define Double
+#define StackAlign 8
+#define Hz 1024

View file

@ -0,0 +1,6 @@
--- /dev/null Fri Jun 19 02:02:36 1998
+++ config/unix/alpha_netbsd/copybin.c Fri Jun 19 02:44:07 1998
@@ -0,0 +1,3 @@
+#include "../../../src/h/define.h"
+#include "paths.h"
+#include "../Generic/copybin.h"

View file

@ -0,0 +1,7 @@
--- config/unix/Config/iconc.make.orig Fri Jun 19 04:53:34 1998
+++ config/unix/Config/iconc.make Fri Jun 19 04:53:44 1998
@@ -25,3 +25,3 @@
cp iconc ../../bin
- strip ../../bin/iconc
+# strip ../../bin/iconc

View file

@ -0,0 +1,12 @@
--- config/unix/Config/icont.make.orig Fri Jun 19 04:53:49 1998
+++ config/unix/Config/icont.make Fri Jun 19 04:54:09 1998
@@ -27,3 +27,3 @@
cp icont ../../bin
- strip ../../bin/icont
+# strip ../../bin/icont
@@ -67,3 +67,3 @@
-o iconx.hdr $(LIBS)
- strip iconx.hdr
+# strip iconx.hdr
ixhdr.o: ../h/path.h ../h/header.h

View file

@ -0,0 +1,7 @@
--- config/unix/Config/rtt.make.orig Fri Jun 19 04:54:16 1998
+++ config/unix/Config/rtt.make Fri Jun 19 04:54:24 1998
@@ -29,3 +29,3 @@
cp rtt ../../bin
- strip ../../bin/rtt
+# strip ../../bin/rtt

View file

@ -0,0 +1,7 @@
--- config/unix/Config/runtime.make.orig Fri Jun 19 04:54:30 1998
+++ config/unix/Config/runtime.make Fri Jun 19 04:54:37 1998
@@ -40,3 +40,3 @@
cp iconx ../../bin
- strip ../../bin/iconx
+# strip ../../bin/iconx

View file

@ -1,58 +0,0 @@
*** Makefile.orig Fri Jul 29 21:41:19 1994
--- Makefile Wed Mar 1 19:34:18 1995
***************
*** 241,243 ****
--- 241,259 ----
-cd tests; $(MAKE) Clean
##################################################################
+
+ install:
+ @bin/patchstr bin/iconc ${PREFIX}/share/icon/
+ @bin/patchstr bin/icont ${PREFIX}/bin/iconx
+ install -c -s -g bin -o bin -m 755 bin/iconc ${PREFIX}/bin/iconc
+ install -c -s -g bin -o bin -m 755 bin/icont ${PREFIX}/bin/icont
+ install -c -s -g bin -o bin -m 755 bin/iconx ${PREFIX}/bin/iconx
+ install -c -s -g bin -o bin -m 755 bin/patchstr ${PREFIX}/bin/patchstr
+ @mkdir -p ${PREFIX}/share/icon
+ install -c -g bin -o bin -m 644 bin/dlrgint.o ${PREFIX}/share/icon/dlrgint.o
+ install -c -g bin -o bin -m 644 bin/rt.a ${PREFIX}/share/icon/rt.a
+ install -c -g bin -o bin -m 644 bin/rt.db ${PREFIX}/share/icon/rt.db
+ install -c -g bin -o bin -m 644 bin/rt.h ${PREFIX}/share/icon/rt.h
+ @mkdir -p ${PREFIX}/man/man1
+ install -c -g bin -o bin -m 444 docs/icon.1 ${PREFIX}/man/man1/icon.1
+ @gzip -9fn ${PREFIX}/man/man1/icon.1
*** config/unix/Config/Makefile.orig Fri Jul 29 21:40:55 1994
--- config/unix/Config/Makefile Wed Mar 1 14:27:05 1995
***************
*** 1,7 ****
- CC=cc
- CFLAGS= -DVarTran
- LDFLAGS=
SHELL=/bin/sh
MAKE=make
all:
--- 1,5 ----
SHELL=/bin/sh
+ CFLAGS+= -DVarTran
MAKE=make
all:
*** src/vtran/Vtmake2.orig Fri Jul 29 21:25:28 1994
--- src/vtran/Vtmake2 Wed Mar 1 14:27:14 1995
***************
*** 1,7 ****
- CC=cc
- CFLAGS= -DVarTran
- LDFLAGS=
SHELL=/bin/sh
MAKE=make
OBJS= cat.o tparse.o tlex.o tmem.o trans.o \
--- 1,5 ----
SHELL=/bin/sh
+ CFLAGS+= -DVarTran
MAKE=make
OBJS= cat.o tparse.o tlex.o tmem.o trans.o \

View file

@ -1,76 +0,0 @@
*** ipl/procs/evinit.icn.orig Fri Jul 29 21:32:02 1994
--- ipl/procs/evinit.icn Wed Mar 1 20:50:24 1995
***************
*** 17,23 ****
#
############################################################################
! $include "evdefs.icn"
procedure EvInit(f,input,output,error)
if not MTEvInit(f,input,output,error) then fail
--- 17,23 ----
#
############################################################################
! $include "../incl/evdefs.icn"
procedure EvInit(f,input,output,error)
if not MTEvInit(f,input,output,error) then fail
*** ipl/procs/evnames.icn.orig Fri Jul 29 21:32:02 1994
--- ipl/procs/evnames.icn Wed Mar 1 20:50:34 1995
***************
*** 29,35 ****
link twt
! $include "evdefs.icn"
procedure evnames()
static namemap
--- 29,35 ----
link twt
! $include "../incl/evdefs.icn"
procedure evnames()
static namemap
*** ipl/procs/evsyms.icn.orig Fri Jul 29 21:31:37 1994
--- ipl/procs/evsyms.icn Wed Mar 1 20:50:48 1995
***************
*** 28,34 ****
link twt
! $include "evdefs.icn"
procedure evsyms()
static symmap
--- 28,34 ----
link twt
! $include "../incl/evdefs.icn"
procedure evsyms()
static symmap
*** ipl/procs/typesyms.icn.orig Fri Jul 29 21:32:08 1994
--- ipl/procs/typesyms.icn Wed Mar 1 20:50:59 1995
***************
*** 27,33 ****
#
############################################################################
! $include "evdefs.icn"
procedure typesyms()
static typetable
--- 27,33 ----
#
############################################################################
! $include "../incl/evdefs.icn"
procedure typesyms()
static typetable

View file

@ -1,209 +0,0 @@
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/common.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,10 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CFLAGS+= -D$D
+SHELL=/bin/sh
+RSWITCH=rswitch.c
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/copybin.c Wed Oct 1 17:32:26 1997
@@ -0,0 +1,3 @@
+#include "../../../src/h/define.h"
+#include "paths.h"
+#include "../Generic/copybin.h"
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/define.h Wed Oct 1 17:32:26 1997
@@ -0,0 +1,22 @@
+#define Standard
+#define IconGcvt
+#define index strchr
+#define rindex strrchr
+#define GetHost
+#define Hz 100
+#define MaxHdr 13400
+#define MaxStatSize 20480
+
+#define GenericBSD
+#define BSD_4_4_LITE 1 /* This is new, for 4.4Lite specific stuff */
+#define UNIX 1
+#define LoadFunc
+#define ExecImages
+
+#define KeyboardFncs
+#define HaveTioc
+#define USE_OLD_TTY
+#define AllowConst
+#define SysOpt
+#define CComp "gcc"
+#define COpts "-O2"
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/icon_pi.c Wed Oct 1 17:32:26 1997
@@ -0,0 +1,2 @@
+#include "paths.h"
+#include "../Generic/icon_pi.h"
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/iconc.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1,9 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CFLAGS+= -D$D
+SHELL=/bin/sh
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/icont.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1 @@
+SHELL=/bin/sh
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/iconx.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1,7 @@
+SHELL=/bin/sh
+# the seek stuff is defined in a header file that they don't
+# include. This is the easiest. -Dconst= causes const to
+# be ignored. This is needed because otherwise we get complaints
+# due to stdio.h defining some functions with const when they
+# are not defined that way in Icon's header files
+RSWITCH=rswitch.c
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/paths.h Wed Oct 1 17:32:26 1997
@@ -0,0 +1,3 @@
+#define RootPath "/usr/local"
+#define IcontPath "/usr/local/lib/icon/icont"
+#define IconxPath "/usr/local/lib/icon/iconx"
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/pi.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+=-DPersInterp
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/preproc.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,10 @@
+# The -D$D option to CFLAGS makes it possible to specify a definition
+# at the Make command level without revising the Makefile, as
+# in
+#
+# make D=Debug
+#
+D=NOTHING
+CC=cc
+CFLAGS+= -O -D$D
+SHELL=/bin/sh
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/rswitch.c Wed Oct 1 17:32:25 1997
@@ -0,0 +1,28 @@
+/*
+ * This is the co-expression context switch for the Intel 80386
+ * under Microport Unix System V/386
+ */
+
+/*
+ * coswitch
+ */
+
+coswitch(old_cs, new_cs, first)
+int *old_cs, *new_cs;
+int first;
+ {
+ asm(" movl 8(%ebp),%eax");
+ asm(" movl %esp,0(%eax)");
+ asm(" movl %ebp,4(%eax)");
+ asm(" movl 12(%ebp),%eax");
+ if (first == 0) { /* this is the first activation */
+ asm(" movl 0(%eax),%esp");
+ asm(" movl $0,%ebp");
+ new_context(0, 0);
+ syserr("interp() returned in coswitch");
+ }
+ else {
+ asm(" movl 0(%eax),%esp");
+ asm(" movl 4(%eax),%ebp");
+ }
+ }
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/rtt.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+CFLAGS+= -DTokDotH="\"../rtt/ltoken.h\""
+SHELL=/bin/sh
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/runtime.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1 @@
+SHELL=/bin/sh
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/setpath.c Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+#include "paths.h"
+#include "../Generic/setpath.h"
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/status Wed Oct 1 17:36:09 1997
@@ -0,0 +1,28 @@
+System configuration:
+
+ Intel 486-type processor or better running BSD 4.4.lite derivative
+
+Latest Icon version:
+
+ Version 9.3
+
+Installer:
+
+ Alistair G. Crooks
+ <agc@netbsd.org>
+
+Missing features:
+
+ None.
+
+Known bugs:
+
+ None.
+
+Comments:
+
+ None.
+
+Date:
+
+ Wed Oct 1 17:36:04 BST 1997
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/vt.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+= -DVarTran
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/vtran.hdr Wed Oct 1 17:32:25 1997
@@ -0,0 +1,2 @@
+SHELL=/bin/sh
+CFLAGS+= -DVarTran
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/xiconx.mak Wed Oct 1 17:32:25 1997
@@ -0,0 +1,3 @@
+# If you define EventMon, add the -lgmon below to get profil(2) under Linux
+#XLIB= -lX11 -lgmon
+XLIB= -L/usr/X11R6/lib -lX11
--- /dev/null Wed Oct 1 17:23:30 1997
+++ config/unix/i386_netbsd/xpm.hdr Wed Oct 1 17:32:26 1997
@@ -0,0 +1 @@
+DEFINES= -DZPIPE
--- src/common/save.c 1997/10/02 07:49:07 1.1
+++ src/common/save.c 1997/10/02 08:00:57
@@ -91,7 +91,11 @@
* Construct the header. The text and data region sizes must be multiples
* of 1024.
*/
+#ifdef __NetBSD__
+ N_SETMAGIC(hdr, ZMAGIC, MID_I386, EX_DYNAMIC);
+#else
hdr.a_magic = ZMAGIC;
+#endif
tsize = (int)&etext;
hdr.a_text = (tsize + 1024) & ~(1024-1);
dsize = sbrk(0) - (int)&environ;

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 1997/11/06 10:00:24 agc Exp $
@comment $NetBSD: PLIST,v 1.4 1998/06/27 22:03:47 tron Exp $
bin/iconc
bin/icont
bin/iconx
@ -7,5 +7,4 @@ share/icon/dlrgint.o
share/icon/rt.a
share/icon/rt.db
share/icon/rt.h
man/man1/icon.1.gz
@dirrm share/icon

View file

@ -1,3 +1,3 @@
#!/bin/sh
cd ${WRKSRC}; make Configure name=`uname -m`_`uname -s|tr '[A-Z]' '[a-z]'`
cd ${WRKSRC}; make Configure name=`uname -m| sed -e 's/i386/intel/'`_`uname -s|tr '[A-Z]' '[a-z]'`