Fixed "test ==".

This commit is contained in:
rillig 2006-10-08 21:35:13 +00:00
parent ed7c93f18f
commit e528a3d5ed
3 changed files with 74 additions and 1 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.2 2006/09/01 15:44:44 gdt Exp $
$NetBSD: distinfo,v 1.3 2006/10/08 21:35:13 rillig Exp $
SHA1 (flite-1.3-release.tar.gz) = 233144a772de72741ae1aa2292f672c30224afb3
RMD160 (flite-1.3-release.tar.gz) = a908acfd196754783ee4665ac84ea860d54bcf80
Size (flite-1.3-release.tar.gz) = 10663835 bytes
SHA1 (patch-aa) = 1b603b6595d97526913d7d91a02993e6ad5a4ce1
SHA1 (patch-ab) = 253876a3edc65b60a5891375b2a90a4fcc01da24
SHA1 (patch-ac) = 9e533a22ed3a59cb6d99b6bbd6eacdfaa1695285

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2006/10/08 21:35:13 rillig Exp $
--- lang/cmulex/make_cmulex.orig 2005-07-11 00:28:52.000000000 +0200
+++ lang/cmulex/make_cmulex 2006-10-08 23:33:26.000000000 +0200
@@ -36,7 +36,7 @@
## ##
###########################################################################
-if [ "x$FLITEDIR" == "x" ]
+if [ "x$FLITEDIR" = "x" ]
then
FLITEDIR=`pwd`/../..
fi

View file

@ -0,0 +1,58 @@
$NetBSD: patch-ac,v 1.1 2006/10/08 21:35:13 rillig Exp $
--- tools/huff_table.orig 2005-01-20 18:01:53.000000000 +0100
+++ tools/huff_table 2006-10-08 23:34:05.000000000 +0200
@@ -62,7 +62,7 @@ export LANG
## 0 is reserved, 1 is reserved too
ALPHABET_SIZE=254
-if [ $1 == "entries" ]
+if [ $1 = "entries" ]
then
infile=$2
outfile=$3
@@ -74,7 +74,7 @@ then
printf("\n");}' >huff.tmp.corpus
fi
-if [ $1 == "phones" ]
+if [ $1 = "phones" ]
then
infile=$2
outfile=$3
@@ -83,7 +83,7 @@ then
sed 's/\\/ /g' >huff.tmp.corpus
fi
-if [ $1 == "residual" ]
+if [ $1 = "residual" ]
then
# This really doesn't work: just some tests to see what's worthwhile
infile=$2
@@ -110,7 +110,7 @@ then
sed 's/,//g;s/};//' >huff.tmp.corpus
fi
-if [ $1 == "other" ]
+if [ $1 = "other" ]
then
infile=$2
outfile=$3
@@ -242,7 +242,7 @@ awk 'BEGIN {'"$maptable"'}
printf("\n");
}' > huff.tmp.corpus.uncompressed
-if [ $1 == "phones" ]
+if [ $1 = "phones" ]
then
cat huff.tmp.corpus.best |
sed 's/+/\\/g' |
@@ -259,7 +259,7 @@ then
mv huff.tmp.corpus.compressed huff.phones.compressed
fi
-if [ $1 == "entries" ]
+if [ $1 = "entries" ]
then
cat huff.tmp.corpus.best |
sed 's/+//g' |