Update Mesa package to version 3.0.
This commit is contained in:
parent
6715b4b2de
commit
e5667e53bd
6 changed files with 111 additions and 131 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.19 1998/09/22 06:11:37 garbled Exp $
|
||||
# $NetBSD: Makefile,v 1.20 1998/09/30 19:46:36 tron Exp $
|
||||
#
|
||||
|
||||
DISTNAME= MesaLib-2.6
|
||||
PKGNAME= Mesa-2.6
|
||||
DISTNAME= MesaLib-3.0
|
||||
PKGNAME= Mesa-3.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/ \
|
||||
ftp://ftp.fu-berlin.de/unix/X11/graphics/Mesa/ \
|
||||
|
@ -10,18 +10,20 @@ MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/ \
|
|||
DISTFILES= MesaLib-${MESA_VERSION}${EXTRACT_SUFX} \
|
||||
MesaDemos-${MESA_VERSION}${EXTRACT_SUFX}
|
||||
|
||||
NOT_FOR_ARCHS= alpha #gcc lossage
|
||||
|
||||
MAINTAINER= mycroft@netbsd.org
|
||||
HOMEPAGE= http://www.ssec.wisc.edu/~brianp/Mesa.html
|
||||
|
||||
CONFLICTS= Mesa-2.4 Mesa-2.6
|
||||
|
||||
NOT_FOR_ARCHS= alpha #gcc lossage
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME}
|
||||
ALL_TARGET= netbsd
|
||||
USE_X11= yes
|
||||
MESA_LIBS= libMesaGL libMesaGLU libMesaaux libMesatk
|
||||
MESA_VERSION= 2.6
|
||||
MESA_LIBS= libMesaGL libMesaGLU
|
||||
MESA_VERSION= 3.0
|
||||
GLUT_LIBS= libglut
|
||||
GLUT_VERSION= 3.6
|
||||
GLUT_VERSION= 3.7
|
||||
|
||||
post-extract:
|
||||
@chmod +r ${WRKSRC}/demos/*
|
||||
|
@ -50,8 +52,8 @@ do-install:
|
|||
${CP} -Rp ${WRKSRC}/book ${PREFIX}/share/examples/Mesa
|
||||
${CP} -Rp ${WRKSRC}/widgets-sgi ${PREFIX}/share/examples/Mesa
|
||||
chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/examples/Mesa
|
||||
${LN} -f ${PREFIX}/lib/libMesaGL.so.2.6 ${PREFIX}/lib/libGL.so.2.6
|
||||
${LN} -f ${PREFIX}/lib/libMesaGLU.so.2.6 ${PREFIX}/lib/libGLU.so.2.6
|
||||
${LN} -f ${PREFIX}/lib/libMesaGL.so.3.0 ${PREFIX}/lib/libGL.so.3.0
|
||||
${LN} -f ${PREFIX}/lib/libMesaGLU.so.3.0 ${PREFIX}/lib/libGLU.so.3.0
|
||||
${LN} -f ${PREFIX}/lib/libMesaGL.a ${PREFIX}/lib/libGL.a
|
||||
${LN} -f ${PREFIX}/lib/libMesaGLU.a ${PREFIX}/lib/libGLU.a
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: md5,v 1.6 1998/08/07 13:21:35 agc Exp $
|
||||
$NetBSD: md5,v 1.7 1998/09/30 19:46:36 tron Exp $
|
||||
|
||||
MD5 (MesaLib-2.6.tar.gz) = ee27bf2548dbc2031974c33ee6226c0c
|
||||
MD5 (MesaDemos-2.6.tar.gz) = 6eef61e387f71a76b855ab6b3d2c89e5
|
||||
MD5 (MesaLib-3.0.tar.gz) = 34af82a8ab6b8283ea77855f3fdf7ef5
|
||||
MD5 (MesaDemos-3.0.tar.gz) = 6ec326092bf8f634a23f7203dc66baad
|
||||
|
|
|
@ -1,59 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.3 1998/08/07 10:40:46 agc Exp $
|
||||
$NetBSD: patch-aa,v 1.4 1998/09/30 19:46:36 tron Exp $
|
||||
|
||||
*** Make-config~ Sat Feb 7 09:17:53 1998
|
||||
--- Make-config Thu Mar 5 15:27:14 1998
|
||||
***************
|
||||
*** 688,696 ****
|
||||
netbsd:
|
||||
$(MAKE) $(MFLAGS) targets \
|
||||
! "GL_LIB = libMesaGL.so" \
|
||||
! "GLU_LIB = libMesaGLU.so" \
|
||||
! "GLUT_LIB = libglut.so" \
|
||||
! "TK_LIB = libMesatk.so" \
|
||||
! "AUX_LIB = libMesaaux.so" \
|
||||
"CC = gcc" \
|
||||
"CFLAGS = -O2 -fPIC -DSHM -I/usr/X11R6/include -DHZ=100" \
|
||||
--- 688,696 ----
|
||||
netbsd:
|
||||
$(MAKE) $(MFLAGS) targets \
|
||||
! "GL_LIB = libMesaGL.a" \
|
||||
! "GLU_LIB = libMesaGLU.a" \
|
||||
! "GLUT_LIB = libglut.a" \
|
||||
! "TK_LIB = libMesatk.a" \
|
||||
! "AUX_LIB = libMesaaux.a" \
|
||||
"CC = gcc" \
|
||||
"CFLAGS = -O2 -fPIC -DSHM -I/usr/X11R6/include -DHZ=100" \
|
||||
*** mklib.netbsd~ Mon Nov 3 21:55:42 1997
|
||||
--- mklib.netbsd Thu Mar 5 15:29:05 1998
|
||||
***************
|
||||
*** 41,54 ****
|
||||
set -x
|
||||
|
||||
! LIBRARY=`basename ${LIBRARY} .so`
|
||||
|
||||
! VERSION="${MAJOR}.${MINOR}"
|
||||
|
||||
! echo "Building PIC library $LIBRARY"
|
||||
! rm -f ${LIBRARY}_pic.a ${LIBRARY}.so.${VERSION}
|
||||
! ar cq ${LIBRARY}_pic.a ${OBJECTS}
|
||||
! ranlib ${LIBRARY}_pic.a
|
||||
|
||||
! ld -x -Bshareable -Bforcearchive -o ${LIBRARY}.so.${VERSION} ${LIBRARY}_pic.a
|
||||
|
||||
! cp ${LIBRARY}_pic.a ${LIBRARY}.so.${VERSION} ../lib
|
||||
--- 41,55 ----
|
||||
set -x
|
||||
|
||||
! VERSION=$MAJOR.$MINOR
|
||||
|
||||
! BASENAME=`echo ${LIBRARY} | sed "s/\.a//g"`
|
||||
! SHLIB=${BASENAME}.so.${VERSION}
|
||||
! STLIB=${BASENAME}.a
|
||||
|
||||
! rm -f ${SHLIB} ${STLIB}
|
||||
|
||||
! ar cq ${STLIB} ${OBJECTS}
|
||||
! ranlib ${STLIB}
|
||||
! ld -Bshareable -o ${SHLIB} ${OBJECTS}
|
||||
|
||||
! mv ${SHLIB} ../lib
|
||||
--- Make-config.orig Sun Aug 30 05:27:56 1998
|
||||
+++ Make-config Wed Sep 30 20:23:27 1998
|
||||
@@ -773,9 +773,9 @@
|
||||
|
||||
netbsd:
|
||||
$(MAKE) $(MFLAGS) targets \
|
||||
- "GL_LIB = libMesaGL.so" \
|
||||
- "GLU_LIB = libMesaGLU.so" \
|
||||
- "GLUT_LIB = libglut.so" \
|
||||
+ "GL_LIB = libMesaGL.a" \
|
||||
+ "GLU_LIB = libMesaGLU.a" \
|
||||
+ "GLUT_LIB = libglut.a" \
|
||||
"CC = gcc" \
|
||||
"CFLAGS = -O2 -fPIC -DSHM -I/usr/X11R6/include -DHZ=100" \
|
||||
"MAKELIB = ../mklib.netbsd" \
|
||||
|
|
|
@ -1,17 +1,15 @@
|
|||
$NetBSD: patch-ab,v 1.4 1998/08/07 10:40:46 agc Exp $
|
||||
$NetBSD: patch-ab,v 1.5 1998/09/30 19:46:36 tron Exp $
|
||||
|
||||
--- Makefile.orig Thu Feb 12 04:38:13 1998
|
||||
+++ Makefile Fri May 8 17:16:16 1998
|
||||
@@ -194,12 +194,9 @@
|
||||
--- Makefile.orig Tue Sep 1 05:14:24 1998
|
||||
+++ Makefile Wed Sep 30 20:34:36 1998
|
||||
@@ -234,10 +234,7 @@
|
||||
cd src ; $(MAKE) $@
|
||||
cd src-glu ; $(MAKE) $@
|
||||
cd src-glut ; $(MAKE) $@
|
||||
- cd demos ; $(MAKE) $@
|
||||
if [ -d src-tk ] ; then cd src-tk ; $(MAKE) $@ ; fi
|
||||
if [ -d src-aux ] ; then cd src-aux ; $(MAKE) $@ ; fi
|
||||
if [ -d xdemos ] ; then cd xdemos ; $(MAKE) $@ ; fi
|
||||
- if [ -d samples ] ; then cd samples ; $(MAKE) $@ ; fi
|
||||
- if [ -d book ] ; then cd book ; $(MAKE) $@ ; fi
|
||||
if [ -d src-glut ] ; then cd src-glut ; $(MAKE) $@ ; fi
|
||||
- if [ -d demos ] ; then cd demos ; $(MAKE) $@ ; fi
|
||||
if [ -d xdemos ] ; then cd xdemos ; $(MAKE) $@ ; fi
|
||||
- if [ -d samples ] ; then cd samples ; $(MAKE) $@ ; fi
|
||||
- if [ -d book ] ; then cd book ; $(MAKE) $@ ; fi
|
||||
|
||||
amiwin:
|
||||
mklib.amiwin
|
||||
|
||||
irix6-n32 irix6-n32-dso irix6-gcc-n32-sl:
|
||||
|
|
36
graphics/Mesa/patches/patch-ac
Normal file
36
graphics/Mesa/patches/patch-ac
Normal file
|
@ -0,0 +1,36 @@
|
|||
$NetBSD: patch-ac,v 1.1 1998/09/30 19:46:37 tron Exp $
|
||||
|
||||
*** mklib.netbsd~ Mon Nov 3 21:55:42 1997
|
||||
--- mklib.netbsd Thu Mar 5 15:29:05 1998
|
||||
***************
|
||||
*** 41,54 ****
|
||||
set -x
|
||||
|
||||
! LIBRARY=`basename ${LIBRARY} .so`
|
||||
|
||||
! VERSION="${MAJOR}.${MINOR}"
|
||||
|
||||
! echo "Building PIC library $LIBRARY"
|
||||
! rm -f ${LIBRARY}_pic.a ${LIBRARY}.so.${VERSION}
|
||||
! ar cq ${LIBRARY}_pic.a ${OBJECTS}
|
||||
! ranlib ${LIBRARY}_pic.a
|
||||
|
||||
! ld -x -Bshareable -Bforcearchive -o ${LIBRARY}.so.${VERSION} ${LIBRARY}_pic.a
|
||||
|
||||
! cp ${LIBRARY}_pic.a ${LIBRARY}.so.${VERSION} ../lib
|
||||
--- 41,55 ----
|
||||
set -x
|
||||
|
||||
! VERSION=$MAJOR.$MINOR
|
||||
|
||||
! BASENAME=`echo ${LIBRARY} | sed "s/\.a//g"`
|
||||
! SHLIB=${BASENAME}.so.${VERSION}
|
||||
! STLIB=${BASENAME}.a
|
||||
|
||||
! rm -f ${SHLIB} ${STLIB}
|
||||
|
||||
! ar cq ${STLIB} ${OBJECTS}
|
||||
! ranlib ${STLIB}
|
||||
! ld -Bshareable -o ${SHLIB} ${OBJECTS}
|
||||
|
||||
! mv ${SHLIB} ../lib
|
|
@ -1,5 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.10 1998/09/05 18:44:34 hubertf Exp $
|
||||
include/GL/FooMesa.h
|
||||
@comment $NetBSD: PLIST,v 1.11 1998/09/30 19:46:37 tron Exp $
|
||||
include/GL/foomesa.h
|
||||
include/GL/ggimesa.h
|
||||
include/GL/osmesa3.h
|
||||
include/GL/dosmesa.h
|
||||
include/GL/fxmesa.h
|
||||
include/GL/gl.h
|
||||
|
@ -9,57 +11,53 @@ include/GL/glu_mangle.h
|
|||
include/GL/glut.h
|
||||
include/GL/glx.h
|
||||
include/GL/glx_mangle.h
|
||||
include/GL/gmesa.h
|
||||
include/GL/mglmesa.h
|
||||
include/GL/osmesa.h
|
||||
include/GL/svgamesa.h
|
||||
include/GL/wmesa.h
|
||||
include/GL/xmesa.h
|
||||
lib/libMesaGL.so.2.6
|
||||
lib/libGL.so.2.6
|
||||
lib/libMesaGLU.so.2.6
|
||||
lib/libGLU.so.2.6
|
||||
lib/libMesaGL.a
|
||||
lib/libGL.so.3.0
|
||||
lib/libGL.a
|
||||
lib/libMesaGLU.a
|
||||
lib/libGLU.so.3.0
|
||||
lib/libGLU.a
|
||||
lib/libMesaaux.so.2.6
|
||||
lib/libMesaaux.a
|
||||
lib/libMesatk.so.2.6
|
||||
lib/libMesatk.a
|
||||
lib/libglut.so.3.6
|
||||
lib/libMesaGL.so.3.0
|
||||
lib/libMesaGL.a
|
||||
lib/libMesaGLU.so.3.0
|
||||
lib/libMesaGLU.a
|
||||
lib/libglut.so.3.7
|
||||
lib/libglut.a
|
||||
share/examples/Mesa/book/Imakefile
|
||||
share/examples/Mesa/book/aaindex.c
|
||||
share/examples/Mesa/book/aapoly.c
|
||||
share/examples/Mesa/book/aargb.c
|
||||
share/examples/Mesa/book/hello.c
|
||||
share/examples/Mesa/book/image.c
|
||||
share/examples/Mesa/book/polyoff.c
|
||||
share/examples/Mesa/book/quadric.c
|
||||
share/examples/Mesa/book/tess.c
|
||||
share/examples/Mesa/book/tesswind.c
|
||||
share/examples/Mesa/book/texbind.c
|
||||
share/examples/Mesa/book/texprox.c
|
||||
share/examples/Mesa/book/texsub.c
|
||||
share/examples/Mesa/book/torus.c
|
||||
share/examples/Mesa/book/unproject.c
|
||||
share/examples/Mesa/book/varray.c
|
||||
share/examples/Mesa/book/wrap.c
|
||||
share/examples/Mesa/book/Makefile
|
||||
share/examples/Mesa/book/Makefile.win
|
||||
share/examples/Mesa/book/README
|
||||
share/examples/Mesa/book/accanti.c
|
||||
share/examples/Mesa/book/accnot.c
|
||||
share/examples/Mesa/book/accpersp.c
|
||||
share/examples/Mesa/book/accum.c
|
||||
share/examples/Mesa/book/aim.c
|
||||
share/examples/Mesa/book/alpha.c
|
||||
share/examples/Mesa/book/alpha3D.c
|
||||
share/examples/Mesa/book/anti.c
|
||||
share/examples/Mesa/book/antiindex.c
|
||||
share/examples/Mesa/book/antipindex.c
|
||||
share/examples/Mesa/book/antipoint.c
|
||||
share/examples/Mesa/book/antipoly.c
|
||||
share/examples/Mesa/book/bezcurve.c
|
||||
share/examples/Mesa/book/bezmesh.c
|
||||
share/examples/Mesa/book/bezsurf.c
|
||||
share/examples/Mesa/book/checker.c
|
||||
share/examples/Mesa/book/checker2.c
|
||||
share/examples/Mesa/book/chess.c
|
||||
share/examples/Mesa/book/clip.c
|
||||
share/examples/Mesa/book/colormat.c
|
||||
share/examples/Mesa/book/cone.c
|
||||
share/examples/Mesa/book/cube.c
|
||||
share/examples/Mesa/book/curve.c
|
||||
share/examples/Mesa/book/depthcue.c
|
||||
share/examples/Mesa/book/disk.c
|
||||
share/examples/Mesa/book/dof.c
|
||||
share/examples/Mesa/book/dofnot.c
|
||||
share/examples/Mesa/book/double.c
|
||||
share/examples/Mesa/book/drawf.c
|
||||
share/examples/Mesa/book/feedback.c
|
||||
|
@ -68,22 +66,17 @@ share/examples/Mesa/book/fogindex.c
|
|||
share/examples/Mesa/book/font.c
|
||||
share/examples/Mesa/book/jitter.h
|
||||
share/examples/Mesa/book/light.c
|
||||
share/examples/Mesa/book/linelist.c
|
||||
share/examples/Mesa/book/lines.c
|
||||
share/examples/Mesa/book/list.c
|
||||
share/examples/Mesa/book/list2.c
|
||||
share/examples/Mesa/book/maplight.c
|
||||
share/examples/Mesa/book/material.c
|
||||
share/examples/Mesa/book/mipmap.c
|
||||
share/examples/Mesa/book/model.c
|
||||
share/examples/Mesa/book/movelight.c
|
||||
share/examples/Mesa/book/nurbs.c
|
||||
share/examples/Mesa/book/pickdepth.c
|
||||
share/examples/Mesa/book/pickline.c
|
||||
share/examples/Mesa/book/picksquare.c
|
||||
share/examples/Mesa/book/plane.c
|
||||
share/examples/Mesa/book/planet.c
|
||||
share/examples/Mesa/book/planetup.c
|
||||
share/examples/Mesa/book/polys.c
|
||||
share/examples/Mesa/book/robot.c
|
||||
share/examples/Mesa/book/sccolorlight.c
|
||||
|
@ -91,23 +84,20 @@ share/examples/Mesa/book/scene.c
|
|||
share/examples/Mesa/book/scenebamb.c
|
||||
share/examples/Mesa/book/sceneflat.c
|
||||
share/examples/Mesa/book/select.c
|
||||
share/examples/Mesa/book/simple.c
|
||||
share/examples/Mesa/book/smooth.c
|
||||
share/examples/Mesa/book/sphere.c
|
||||
share/examples/Mesa/book/stencil.c
|
||||
share/examples/Mesa/book/stroke.c
|
||||
share/examples/Mesa/book/surface.c
|
||||
share/examples/Mesa/book/tea.c
|
||||
share/examples/Mesa/book/teaambient.c
|
||||
share/examples/Mesa/book/teapots.c
|
||||
share/examples/Mesa/book/texgen.c
|
||||
share/examples/Mesa/book/texturesurf.c
|
||||
share/examples/Mesa/book/trim.c
|
||||
share/examples/Mesa/book/xfont.c
|
||||
share/examples/Mesa/demos/multiext.c
|
||||
share/examples/Mesa/demos/multitex.c
|
||||
share/examples/Mesa/demos/renormal.c
|
||||
share/examples/Mesa/demos/Makefile
|
||||
share/examples/Mesa/demos/Makefile.DJ
|
||||
share/examples/Mesa/demos/Makefile.cygnus
|
||||
share/examples/Mesa/demos/Makefile.win
|
||||
share/examples/Mesa/demos/bounce.c
|
||||
share/examples/Mesa/demos/clearspd.c
|
||||
share/examples/Mesa/demos/descrip.mms
|
||||
|
@ -132,14 +122,8 @@ share/examples/Mesa/demos/texcyl.c
|
|||
share/examples/Mesa/demos/texobj.c
|
||||
share/examples/Mesa/demos/trispd.c
|
||||
share/examples/Mesa/demos/winpos.c
|
||||
share/examples/Mesa/samples/1.rgb
|
||||
share/examples/Mesa/samples/2.rgb
|
||||
share/examples/Mesa/samples/3.rgb
|
||||
share/examples/Mesa/samples/4.rgb
|
||||
share/examples/Mesa/samples/Imakefile
|
||||
share/examples/Mesa/samples/Makefile
|
||||
share/examples/Mesa/samples/Makefile.DJ
|
||||
share/examples/Mesa/samples/Makefile.win
|
||||
share/examples/Mesa/samples/README
|
||||
share/examples/Mesa/samples/accum.c
|
||||
share/examples/Mesa/samples/bitmap1.c
|
||||
|
@ -163,7 +147,6 @@ share/examples/Mesa/samples/prim.c
|
|||
share/examples/Mesa/samples/quad.c
|
||||
share/examples/Mesa/samples/select.c
|
||||
share/examples/Mesa/samples/shape.c
|
||||
share/examples/Mesa/samples/speed.c
|
||||
share/examples/Mesa/samples/sphere.c
|
||||
share/examples/Mesa/samples/star.c
|
||||
share/examples/Mesa/samples/stencil.c
|
||||
|
@ -171,6 +154,9 @@ share/examples/Mesa/samples/stretch.c
|
|||
share/examples/Mesa/samples/texture.c
|
||||
share/examples/Mesa/samples/tri.c
|
||||
share/examples/Mesa/samples/wave.c
|
||||
share/examples/Mesa/samples/loadppm.c
|
||||
share/examples/Mesa/samples/rgbtoppm.c
|
||||
share/examples/Mesa/samples/tkmap.c
|
||||
share/examples/Mesa/widgets-sgi/GLwDrawA.c
|
||||
share/examples/Mesa/widgets-sgi/GLwDrawA.h
|
||||
share/examples/Mesa/widgets-sgi/GLwDrawAP.h
|
||||
|
|
Loading…
Reference in a new issue