Upgrade to tcsh-6.12.00:

New Features:
	* %j in prompt
	* utf8 support

New Ports:
	* darwin support

Locale Support:
	* russian locale fixes
	* polish locale fixes

Highlights from Bug Fixes:
	* Dissallow setting of environment variables that do not contain
	  alphanumeric names
	* Don't expand path components that don't resolve to path names
	* Make $ignoreeof agree with the man page
	* Don't close file descriptors too early because setuid scripts fail
This commit is contained in:
kim 2002-07-24 17:51:32 +00:00
parent cb20bdff4f
commit e56e1884c9
7 changed files with 6 additions and 111 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.32 2002/03/22 11:13:41 uebayasi Exp $
# $NetBSD: Makefile,v 1.33 2002/07/24 17:51:32 kim Exp $
#
DISTNAME= tcsh-6.11
PKGNAME= tcsh-6.11.00
DISTNAME= tcsh-6.12.00
CATEGORIES= shells
MASTER_SITES= ftp://ftp.astron.com/pub/tcsh/ \
ftp://ftp.gw.com/pub/unix/tcsh/ \
@ -28,7 +27,6 @@ OS_VERSION!= ${ECHO} ${OS_VERSION} | ${SED} -e 's|5\.|2.|'
LOWER_OPSYS= solaris${OS_VERSION}
.endif
# XXX broken: pl:ISO_8859-2:pl:PL
post-install:
@${ECHO} "Installing message catalogues"
@${INSTALL_DATA} ${WRKSRC}/tcsh.C.cat ${PREFIX}/${NLSDIR}/C/tcsh.cat
@ -42,6 +40,7 @@ post-install:
greek:ISO_8859-7:el:GR \
italian:ISO_8859-1:it:CH:IT \
ja:EUC:ja:JP \
pl:ISO_8859-2:pl:PL \
russian:KOI8-R:ru:RU:SU \
spanish:ISO_8859-1:es:ES \
ukrainian:KOI8-U:uk:UA \
@ -57,7 +56,6 @@ post-install:
o=; \
while [ $$# -gt 0 ]; do \
d=${NLSDIR}/$${c}_$$1.$${s}; \
${INSTALL_DATA_DIR} ${PREFIX}/$$d; \
if [ -z "$$o" ]; then \
o="$$d"; \
${INSTALL_DATA} ${WRKSRC}/tcsh.$${l}.cat \

View file

@ -1,11 +1,6 @@
$NetBSD: distinfo,v 1.8 2002/04/11 15:26:19 abs Exp $
$NetBSD: distinfo,v 1.9 2002/07/24 17:51:32 kim Exp $
SHA1 (tcsh-6.11.tar.gz) = bfc2ccd2d9e04975308cdf0a50b7383e580594b6
Size (tcsh-6.11.tar.gz) = 716863 bytes
SHA1 (tcsh-6.12.00.tar.gz) = c54fd7a6823a4d30a4195f0fb9f31c6e2ddbd8e5
Size (tcsh-6.12.00.tar.gz) = 824297 bytes
SHA1 (patch-aa) = 51b96fff19fcfb55e6c841460c7a771c4678978f
SHA1 (patch-ab) = beb167a266e96ac84325615d437ef8474763756d
SHA1 (patch-ac) = 3d2ed4818c3dce640fd754ee54af1e4c51be694d
SHA1 (patch-ad) = aa39de839e228bb1da8c38f67aa6f7019f040040
SHA1 (patch-ae) = e7a00876ac67d836833f6c1145f2b03086f91a6f
SHA1 (patch-af) = 7c367f927f0207baa174a7eaa76db329e19a0e6c
SHA1 (patch-ag) = 2a2cc3052a2459b599df5b7511fa54f3a2838a92

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ab,v 1.7 2002/04/11 15:26:46 abs Exp $
--- config.guess.orig Sun Mar 18 19:06:27 2001
+++ config.guess
@@ -593,8 +593,11 @@
fi
echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
exit 0 ;;
- *:NetBSD:*:*)
+ *:NetBSD:0.*:* | *:NetBSD:1.[0123]*:*)
echo ${UNAME_MACHINE}-unknown-netbsd`echo ${UNAME_RELEASE}|sed -e 's/[-_].*//'`
+ exit 0 ;;
+ *:NetBSD:*:*)
+ echo `uname -p`-unknown-netbsd`echo ${UNAME_RELEASE}|sed -e 's/[-_].*//'`
exit 0 ;;
*:OpenBSD:*:*)
echo ${UNAME_MACHINE}-unknown-openbsd`echo ${UNAME_RELEASE}|sed -e 's/[-_].*/\./'`

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ac,v 1.7 2002/04/11 15:26:20 abs Exp $
--- config.sub.orig Sun Mar 18 19:06:28 2001
+++ config.sub
@@ -172,7 +172,8 @@
| hppa | hppa1.0 | hppa1.1 | hppa2.0 | hppa2.0w | hppa2.0n \
| alpha | alphaev[4-7] | alphaev56 | alphapca5[67] \
| we32k | ns16k | clipper | i370 | sh | powerpc | powerpcle \
- | 1750a | dsp16xx | pdp11 | mips16 | mips64 | mipsel | mips64el \
+ | 1750a | dsp16xx | pdp11 | mips16 | mips64 \
+ | mipseb | mipsel | mips64el \
| mips64orion | mips64orionel | mipstx39 | mipstx39el \
| mips64vr4300 | mips64vr4300el | mips64vr4100 | mips64vr4100el \
| mips64vr5000 | miprs64vr5000el | mcore \
@@ -206,7 +207,8 @@
| we32k-* | cydra-* | ns16k-* | pn-* | np1-* | xps100-* \
| clipper-* | orion-* \
| sparclite-* | pdp11-* | sh-* | powerpc-* | powerpcle-* \
- | sparc64-* | sparcv9-* | sparc86x-* | mips16-* | mips64-* | mipsel-* \
+ | sparc64-* | sparcv9-* | sparc86x-* | mips16-* | mips64-* \
+ | mipseb-* | mipsel-* \
| mips64el-* | mips64orion-* | mips64orionel-* \
| mips64vr4100-* | mips64vr4100el-* | mips64vr4300-* | mips64vr4300el-* \
| mipstx39-* | mipstx39el-* | mcore-* \

View file

@ -1,11 +0,0 @@
$NetBSD: patch-ae,v 1.5 2002/04/11 15:26:48 abs Exp $
--- nls/Makefile.orig Tue Aug 7 00:48:45 2001
+++ nls/Makefile
@@ -1,5 +1,5 @@
-SUBDIRS= C et finnish french german greek italian ja pl russian \
+SUBDIRS= C et finnish french german greek italian ja russian \
spanish ukrainian
#GENCAT= gencat -new
GENCAT= gencat

View file

@ -1,17 +0,0 @@
$NetBSD: patch-af,v 1.8 2002/04/11 15:26:20 abs Exp $
--- sh.dol.c.orig Wed Jul 25 16:48:04 2001
+++ sh.dol.c
@@ -585,10 +585,8 @@
c = DgetC(0);
} while (Isdigit(c));
unDredc(c);
- if (subscr < 0) {
- dolerror(vp->v_name);
- return;
- }
+ if (subscr < 0)
+ stderror(ERR_RANGE);
if (subscr == 0) {
if (bitset) {
dolp = dolzero ? STR1 : STR0;

View file

@ -1,29 +0,0 @@
$NetBSD: patch-ag,v 1.8 2002/04/11 15:26:21 abs Exp $
--- sh.func.c.orig Tue Mar 13 12:53:50 2001
+++ sh.func.c
@@ -2143,6 +2143,9 @@
else
rlim.rlim_cur = limit;
+ if (rlim.rlim_cur > rlim.rlim_max)
+ rlim.rlim_max = rlim.rlim_cur;
+
if (setrlimit(lp->limconst, &rlim) < 0) {
# else /* BSDLIMIT */
if (limit != RLIM_INFINITY && lp->limconst == RLIMIT_FSIZE)
@@ -2153,10 +2156,10 @@
# endif /* aiws */
if (ulimit(toset(lp->limconst), limit) < 0) {
# endif /* BSDLIMIT */
- xprintf(CGETS(15, 1, "%s: %s: Can't %s%s limit\n"), bname, lp->limname,
- limit == RLIM_INFINITY ? CGETS(15, 2, "remove") :
- CGETS(15, 3, "set"),
- hard ? CGETS(14, 4, " hard") : "");
+ xprintf(CGETS(15, 1, "%s: %s: Can't %s%s limit (%s)\n"), bname,
+ lp->limname, limit == RLIM_INFINITY ? CGETS(15, 2, "remove") :
+ CGETS(15, 3, "set"), hard ? CGETS(14, 4, " hard") : "",
+ strerror(errno));
return (-1);
}
return (0);