Update to OpenOBEX 1.7. The maintainer has changed, to Hendrik Sattler

and the sources are now stored at gitorius.org. The build system is changed
to CMake

From the ChangeLog:

ver 1.7:
	Add support for CMake config files
	Internal code reorganisation and rewrite
	Add new function set for better control than OBEX_HandleInput():
	  * OBEX_SetTimeout(),
	  * OBEX_Work() and
	  * OBEX_GetDataDirection()

ver 1.6:
	Change ABI from 1 to 2 because:
	  * Redo the USB changes from version 1.4
	  * Remove InOBEX_* function, use the TcpOBEX_* functions instead
	  * Remove the simple Unicode<->ASCII functions
	Add support for Single Response Mode
	Add manpages for all example applications
	Add udev support
	Add new example app to find IrDA and USB OBEX devices
	Add fixes for FreeBSD
	Add support for libusb-1.x
	Add support for close-on-exec
This commit is contained in:
plunky 2013-03-15 08:10:04 +00:00
parent eda88483da
commit e63cdfd7a9
5 changed files with 85 additions and 44 deletions

View file

@ -1,24 +1,20 @@
# $NetBSD: Makefile,v 1.20 2012/10/03 11:24:42 asau Exp $
# $NetBSD: Makefile,v 1.21 2013/03/15 08:10:04 plunky Exp $
#
DISTNAME= openobex-1.5
DISTNAME= openobex-1.7-Source
PKGNAME= openobex-1.7
CATEGORIES= comms
MASTER_SITES= http://www.kernel.org/pub/linux/bluetooth/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=openobex/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.openobex.org/
HOMEPAGE= https://gitorious.org/openobex
COMMENT= Implementation of the Object Exchange (OBEX) protocol
LICENSE= gnu-lgpl-v2
GNU_CONFIGURE= yes
USE_TOOLS+= autoconf gmake pkg-config
USE_LIBTOOL= yes
USE_CMAKE= yes
USE_TOOLS+= cmake pkg-config
PKGCONFIG_OVERRIDE= openobex.pc.in
post-patch:
cd ${WRKSRC} && autoconf
.include "../../devel/libusb/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,75 @@
@comment $NetBSD: PLIST,v 1.5 2009/08/07 12:18:33 plunky Exp $
@comment $NetBSD: PLIST,v 1.6 2013/03/15 08:10:04 plunky Exp $
include/openobex/obex.h
include/openobex/obex_const.h
lib/libopenobex.la
include/openobex/version.h
lib/cmake/OpenObex-1.7/openobex-config-version.cmake
lib/cmake/OpenObex-1.7/openobex-config.cmake
lib/cmake/OpenObex-1.7/openobex-target-release.cmake
lib/cmake/OpenObex-1.7/openobex-target.cmake
lib/libopenobex.so
lib/libopenobex.so.1.7
lib/libopenobex.so.2
lib/pkgconfig/openobex.pc
share/doc/openobex/html/annotated.html
share/doc/openobex/html/api_8c.html
share/doc/openobex/html/bc_s.png
share/doc/openobex/html/bdwn.png
share/doc/openobex/html/classes.html
share/doc/openobex/html/closed.png
share/doc/openobex/html/dir_000000.html
share/doc/openobex/html/dir_000001.html
share/doc/openobex/html/dir_000002.html
share/doc/openobex/html/doxygen.css
share/doc/openobex/html/doxygen.png
share/doc/openobex/html/dynsections.js
share/doc/openobex/html/files.html
share/doc/openobex/html/ftv2blank.png
share/doc/openobex/html/ftv2cl.png
share/doc/openobex/html/ftv2doc.png
share/doc/openobex/html/ftv2folderclosed.png
share/doc/openobex/html/ftv2folderopen.png
share/doc/openobex/html/ftv2lastnode.png
share/doc/openobex/html/ftv2link.png
share/doc/openobex/html/ftv2mlastnode.png
share/doc/openobex/html/ftv2mnode.png
share/doc/openobex/html/ftv2mo.png
share/doc/openobex/html/ftv2node.png
share/doc/openobex/html/ftv2ns.png
share/doc/openobex/html/ftv2plastnode.png
share/doc/openobex/html/ftv2pnode.png
share/doc/openobex/html/ftv2splitbar.png
share/doc/openobex/html/ftv2vertline.png
share/doc/openobex/html/functions.html
share/doc/openobex/html/functions_vars.html
share/doc/openobex/html/globals.html
share/doc/openobex/html/globals_0x66.html
share/doc/openobex/html/globals_0x69.html
share/doc/openobex/html/globals_0x6f.html
share/doc/openobex/html/globals_0x74.html
share/doc/openobex/html/globals_defs.html
share/doc/openobex/html/globals_enum.html
share/doc/openobex/html/globals_eval.html
share/doc/openobex/html/globals_func.html
share/doc/openobex/html/globals_type.html
share/doc/openobex/html/index.html
share/doc/openobex/html/jquery.js
share/doc/openobex/html/nav_f.png
share/doc/openobex/html/nav_g.png
share/doc/openobex/html/nav_h.png
share/doc/openobex/html/obex_8h.html
share/doc/openobex/html/obex__const_8h.html
share/doc/openobex/html/open.png
share/doc/openobex/html/openobex_8coverpage.html
share/doc/openobex/html/structobex__ctrans__t.html
share/doc/openobex/html/structobex__irda__intf__t.html
share/doc/openobex/html/structobex__usb__intf__service__t.html
share/doc/openobex/html/structobex__usb__intf__t.html
share/doc/openobex/html/sync_off.png
share/doc/openobex/html/sync_on.png
share/doc/openobex/html/tab_a.png
share/doc/openobex/html/tab_b.png
share/doc/openobex/html/tab_h.png
share/doc/openobex/html/tab_s.png
share/doc/openobex/html/tabs.css
share/doc/openobex/html/unionobex__headerdata__t.html
share/doc/openobex/html/unionobex__interface__t.html

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.12 2009/08/07 12:18:33 plunky Exp $
# $NetBSD: buildlink3.mk,v 1.13 2013/03/15 08:10:04 plunky Exp $
BUILDLINK_TREE+= openobex
.if !defined(OPENOBEX_BUILDLINK3_MK)
OPENOBEX_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.openobex+= openobex>=1.5
BUILDLINK_API_DEPENDS.openobex+= openobex>=1.7
BUILDLINK_PKGSRCDIR.openobex?= ../../comms/openobex
.include "../../devel/libusb/buildlink3.mk"

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.6 2009/08/07 12:18:33 plunky Exp $
$NetBSD: distinfo,v 1.7 2013/03/15 08:10:04 plunky Exp $
SHA1 (openobex-1.5.tar.gz) = ff5fc07287d67fa73ec55998f76ed73787a2ddb1
RMD160 (openobex-1.5.tar.gz) = 9c57faabd6e63ff809e27ab90ed5db788802c45c
Size (openobex-1.5.tar.gz) = 400876 bytes
SHA1 (patch-ag) = 3276e9836c02e2e7fc56ba819e08c647369b1cff
SHA1 (openobex-1.7-Source.tar.gz) = 9fb8de31b551fd116991641f296d64be98f84b27
RMD160 (openobex-1.7-Source.tar.gz) = f4b80ac9533953312c0482e83ec5445550100eb6
Size (openobex-1.7-Source.tar.gz) = 130372 bytes

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ag,v 1.1 2009/08/07 12:18:33 plunky Exp $
fix BSD bluetooth support (this is submitted upstream)
--- lib/bluez_compat.h.orig 2009-02-08 18:30:23.000000000 +0000
+++ lib/bluez_compat.h
@@ -53,6 +53,8 @@ static bdaddr_t bluez_compat_bdaddr_any
#define rc_family rfcomm_family
#define rc_bdaddr rfcomm_bdaddr
#define rc_channel rfcomm_channel
+#define BDADDR_ANY NG_HCI_BDADDR_ANY
+#define BTPROTO_RFCOMM BLUETOOTH_PROTO_RFCOMM
#elif defined(HAVE_BLUETOOTH_NETBSD)
#include <bluetooth.h>
@@ -61,7 +63,7 @@ static bdaddr_t bluez_compat_bdaddr_any
#define rc_family bt_family
#define rc_bdaddr bt_bdaddr
#define rc_channel bt_channel
-#define BDADDR_ANY NG_HCI_BDADDR_ANY
+#define bacpy(dst,src) memcpy((dst),(src),sizeof(bdaddr_t))
#endif /* HAVE_BLUETOOTH_* */