phoon 29jun2005. Mostly an update to astronomy routines derived from

J. Walker's Moontool 2.5 (used to be 2.0).
This commit is contained in:
is 2012-08-28 17:14:13 +00:00
parent ea16421304
commit e64f6fce13
6 changed files with 56 additions and 23 deletions

View file

@ -1,6 +1,4 @@
phoon - display current moon phase on ASCII terminal
Distribution of 01apr95
Previous distribution 07jun88
phoon - display current moon phase
phoon - program to display the PHase of the mOON. Unlike other
such programs, which just tell you how long since first quarter
@ -9,4 +7,4 @@ picture. I've put an example at the end of this file. I first
wrote this program in Pascal / TOPS-20 at CMU in 1979; I translated
it to Ratfor / Software Tools in 1981; and now it's in C / Unix.
Jef Poskanzer jef@acme.com http://www.acme.com/jef/
Jef Poskanzer jef@mail.acme.com http://www.acme.com/jef/

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.11 2008/06/12 02:14:53 joerg Exp $
# $NetBSD: Makefile,v 1.12 2012/08/28 17:14:13 is Exp $
#
DISTNAME= phoon_01apr1995
PKGNAME= phoon-19950401
DISTNAME= phoon_29jun2005
PKGNAME= phoon-20050629
CATEGORIES= time
MASTER_SITES= http://www.acme.com/software/phoon/

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.5 2012/05/10 22:16:54 dholland Exp $
$NetBSD: distinfo,v 1.6 2012/08/28 17:14:13 is Exp $
SHA1 (phoon_01apr1995.tar.gz) = b0e81c9cd6f1d332bc25340c12e1f0fcc274c8b5
RMD160 (phoon_01apr1995.tar.gz) = e5521bc9a78b34070f5072a112bf99d59f3ed7ac
Size (phoon_01apr1995.tar.gz) = 15769 bytes
SHA1 (patch-aa) = 3c51027cf81895628774dd59dd002b62668b8560
SHA1 (phoon_29jun2005.tar.gz) = d646af184b83e1a4104fe82588daadae2938e08c
RMD160 (phoon_29jun2005.tar.gz) = 5a03f83965e8b6dd490a6fffd0ec6bf36d155853
Size (phoon_29jun2005.tar.gz) = 17450 bytes
SHA1 (patch-aa) = 96167efc32d02cbd4b17f096438d03b034d6ac78
SHA1 (patch-ab) = 2a2aa975027dad5392a69c1238c2805417484c32
SHA1 (patch-ac) = 5fe9ed29dfdcfa61405eb1d9baab6f20f640dd93

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2012/05/10 22:16:55 dholland Exp $
diff -r -u phoon.orig/Makefile Makefile
--- phoon.orig/Makefile Sat Nov 11 20:57:08 1995
+++ Makefile Sat Nov 10 20:10:33 2001
@@ -1,15 +1,15 @@
$NetBSD: patch-aa,v 1.4 2012/08/28 17:14:13 is Exp $
--- Makefile.orig 2003-01-21 03:04:36.000000000 +0000
+++ Makefile
@@ -1,15 +1,14 @@
# Makefile for phoon
-BINDIR = /usr/local/bin
@ -12,19 +12,19 @@ diff -r -u phoon.orig/Makefile Makefile
+
+INSTALL = install
DEFINES = -DBSD
#DEFINES = -DSYSV
DEFINES = -DOS_BSD
#DEFINES = -DOS_SYSV
-CC = gcc
-CFLAGS = -O $(DEFINES)
+CFLAGS += $(DEFINES)
-
-LDFLAGS = -s
+CFLAGS = $(DEFINES)
all: phoon
@@ -21,10 +21,8 @@
$(CC) $(CFLAGS) -c $<
@@ -24,10 +23,8 @@ date_parse.o: date_parse.h
astro.o: astro.h
install: all
- rm -f $(BINDIR)/phoon

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1 2012/08/28 17:14:13 is Exp $
--- astro.c.orig 2003-01-28 00:56:55.000000000 +0000
+++ astro.c
@@ -25,6 +25,7 @@
** See http://www.fourmilab.ch/moontool/
*/
+#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <time.h>

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ac,v 1.1 2012/08/28 17:14:13 is Exp $
--- phoon.c.orig 2005-05-20 19:10:24.000000000 +0000
+++ phoon.c
@@ -45,6 +45,7 @@
*/
+#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <time.h>
@@ -354,7 +355,7 @@ putmoon( time_t t, int numlines, char* a
struct tm* tmP;
double jd, pctphase, angphase, cphase, aom, cdist, cangdia, csund, csuang;
double phases[2], which[2];
- long clocknow;
+ time_t clocknow;
int atflrlen, atflridx, numcols, lin, col, midlin;
double mcap, yrad, xrad, y, xright, xleft;
int colright, colleft;