Include the static definition of strlcpy() only when it is not available

on the system.  This makes the package build with gcc-4.
This commit is contained in:
minskim 2006-03-21 18:18:15 +00:00
parent 5fd70b7cdc
commit e65728eb0f
5 changed files with 65 additions and 6 deletions

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.3 2005/12/23 16:19:12 wiz Exp $
$NetBSD: distinfo,v 1.4 2006/03/21 18:18:15 minskim Exp $
SHA1 (cgdb-0.4.0.tar.gz) = 900105c73e8c16dec9f3e37343abbba120d36df6
RMD160 (cgdb-0.4.0.tar.gz) = f79e567ccf96d5d473e1cd4859ac97bc17619f67
Size (cgdb-0.4.0.tar.gz) = 471395 bytes
SHA1 (patch-aa) = 923af14fee3272739126e05ebe591c627ffdd934
SHA1 (patch-aa) = 9fe547d5491d2c84ef1fd6e8fa634dd0f789c078
SHA1 (patch-ab) = 934748a6293e3f1bfc14381b72b613c44a906542
SHA1 (patch-ac) = 37ebf2e9e6a2620e48363651903c8114858f91c0
SHA1 (patch-ad) = cf16c7f044783e5d57f2e4e4a4cbdda7b0cca1ce

View file

@ -1,8 +1,24 @@
$NetBSD: patch-aa,v 1.1 2005/12/23 16:19:12 wiz Exp $
$NetBSD: patch-aa,v 1.2 2006/03/21 18:18:15 minskim Exp $
--- various/util/src/pseudo.c.orig 2003-04-28 02:04:04.000000000 +0200
--- various/util/src/pseudo.c.orig 2003-04-27 17:04:04.000000000 -0700
+++ various/util/src/pseudo.c
@@ -327,6 +327,7 @@ int pty_open(int *masterfd, int *slavefd
@@ -88,6 +88,7 @@
#define set_errno(errnum) (errno = (errnum), -1)
+#ifndef HAVE_STRLCPY
/* strlcpy: Used instead of strcpy. Copies src into dst size bytes long.
*
* dst: destination
@@ -119,6 +120,7 @@ static size_t strlcpy(char *dst, const c
return s - src - 1;
}
+#endif
static int groupname2gid(const char *groupname) {
FILE *group = fopen("/etc/group", "r");
@@ -327,6 +329,7 @@ int pty_open(int *masterfd, int *slavefd
#ifndef HAVE_CYGWIN
#ifndef HAVE_LINUX /* linux does not use the streams module */
@ -10,7 +26,7 @@ $NetBSD: patch-aa,v 1.1 2005/12/23 16:19:12 wiz Exp $
/*
* Push the appropriate streams modules, as described in Solaris pts(7).
* HP-UX pts(7) doesn't have ttcompat module.
@@ -355,6 +356,7 @@ int pty_open(int *masterfd, int *slavefd
@@ -355,6 +358,7 @@ int pty_open(int *masterfd, int *slavefd
#endif
#endif
#endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2006/03/21 18:18:15 minskim Exp $
--- configure.in.orig 2003-10-28 19:13:49.000000000 -0800
+++ configure.in
@@ -119,7 +119,7 @@ AC_PROG_GCC_TRADITIONAL
AC_FUNC_SETPGRP
AC_TYPE_SIGNAL
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS(mkdir putenv select strdup strerror)
+AC_CHECK_FUNCS(mkdir putenv select strdup strerror strlcpy)
#tgdb/Makefile tgdb/annotate-two-src/Makefile tgdb/gdbmi-src/Makefile tgdb/lib/Makefile)
AC_OUTPUT(Makefile \

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ac,v 1.1 2006/03/21 18:18:15 minskim Exp $
--- config.h.in.orig 2003-03-29 09:17:22.000000000 -0800
+++ config.h.in
@@ -126,6 +126,9 @@
/* Define to 1 if you have the <string.h> header file. */
#undef HAVE_STRING_H
+/* Define to 1 if you have the `strlcpy' function. */
+#undef HAVE_STRLCPY
+
/* Define to 1 if you have the <sys/ioctl.h> header file. */
#undef HAVE_SYS_IOCTL_H

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2006/03/21 18:18:15 minskim Exp $
--- configure.orig 2006-03-21 10:06:15.000000000 -0800
+++ configure
@@ -6026,7 +6026,7 @@ done
-for ac_func in mkdir putenv select strdup strerror
+for ac_func in mkdir putenv select strdup strerror strlcpy
do
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
echo "$as_me:$LINENO: checking for $ac_func" >&5