net/py-twisted19: import py27-twisted-19.10.0
Twisted is a framework, written in Python, for writing networked applications. It includes implementations of a number of commonly used network services such as a web server, an IRC chat server, a mail server, a relational database interface and an object broker. Developers can build applications using all of these services as well as custom services that they write themselves. Twisted also includes a user authentication system that controls access to services and provides services with user context information to implement their own security models. Note that while this package provides most of Twisted, Twisted Conch (SSH client/server) only functions if security/py-amkCrypto is also installed. This package contains the last version supporting Python 2.
This commit is contained in:
parent
90c873fb84
commit
e6c566d6cb
6 changed files with 2687 additions and 0 deletions
9
net/py-twisted19/ALTERNATIVES
Normal file
9
net/py-twisted19/ALTERNATIVES
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/cftp @PREFIX@/bin/cftp-@PYVERSSUFFIX@
|
||||
bin/ckeygen @PREFIX@/bin/ckeygen-@PYVERSSUFFIX@
|
||||
bin/conch @PREFIX@/bin/conch-@PYVERSSUFFIX@
|
||||
bin/mailmail @PREFIX@/bin/mailmail-@PYVERSSUFFIX@
|
||||
bin/pyhtmlizer @PREFIX@/bin/pyhtmlizer-@PYVERSSUFFIX@
|
||||
bin/tkconch @PREFIX@/bin/tkconch-@PYVERSSUFFIX@
|
||||
bin/trial @PREFIX@/bin/trial-@PYVERSSUFFIX@
|
||||
bin/twist @PREFIX@/bin/twist-@PYVERSSUFFIX@
|
||||
bin/twistd @PREFIX@/bin/twistd-@PYVERSSUFFIX@
|
14
net/py-twisted19/DESCR
Normal file
14
net/py-twisted19/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
Twisted is a framework, written in Python, for writing networked applications.
|
||||
It includes implementations of a number of commonly used network services such
|
||||
as a web server, an IRC chat server, a mail server, a relational database
|
||||
interface and an object broker. Developers can build applications using all of
|
||||
these services as well as custom services that they write themselves. Twisted
|
||||
also includes a user authentication system that controls access to services
|
||||
and provides services with user context information to implement their own
|
||||
security models.
|
||||
|
||||
Note that while this package provides most of Twisted, Twisted Conch
|
||||
(SSH client/server) only functions if security/py-amkCrypto is also
|
||||
installed.
|
||||
|
||||
This package contains the last version supporting Python 2.
|
43
net/py-twisted19/Makefile
Normal file
43
net/py-twisted19/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
# $NetBSD: Makefile,v 1.1 2022/02/13 08:43:12 wiz Exp $
|
||||
|
||||
DISTNAME= Twisted-19.10.0
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
|
||||
CATEGORIES= net python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=T/Twisted/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
COMMENT= Framework for writing networked applications
|
||||
HOMEPAGE= https://www.twistedmatrix.com/
|
||||
LICENSE= mit
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-attrs>=17.4.0:../../devel/py-attrs
|
||||
DEPENDS+= ${PYPKGPREFIX}-automat>=0.3.0:../../devel/py-automat
|
||||
DEPENDS+= ${PYPKGPREFIX}-constantly>=15.1:../../devel/py-constantly
|
||||
DEPENDS+= ${PYPKGPREFIX}-hamcrest>=1.9.0:../../devel/py-hamcrest
|
||||
DEPENDS+= ${PYPKGPREFIX}-hyperlink>=17.1.1:../../www/py-hyperlink
|
||||
DEPENDS+= ${PYPKGPREFIX}-incremental>=16.10.1:../../devel/py-incremental
|
||||
DEPENDS+= ${PYPKGPREFIX}-ZopeInterface>=4.4.2:../../devel/py-ZopeInterface
|
||||
# TLS
|
||||
DEPENDS+= ${PYPKGPREFIX}-OpenSSL>=16.0.0:../../security/py-OpenSSL
|
||||
DEPENDS+= ${PYPKGPREFIX}-service_identity>=18.1.0:../../security/py-service_identity
|
||||
DEPENDS+= ${PYPKGPREFIX}-idna>=2.4:../../www/py-idna
|
||||
|
||||
REPLACE_PYTHON+= src/twisted/mail/test/pop3testserver.py
|
||||
REPLACE_PYTHON+= src/twisted/trial/test/scripttest.py
|
||||
|
||||
USE_LANGUAGES= c99
|
||||
|
||||
USE_PKG_RESOURCES= yes
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
|
||||
post-install:
|
||||
.for bin in cftp ckeygen conch mailmail pyhtmlizer tkconch trial twist twistd
|
||||
cd ${DESTDIR}${PREFIX}/bin && \
|
||||
${MV} ${bin} ${bin}-${PYVERSSUFFIX} || ${TRUE}
|
||||
.endfor
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2599
net/py-twisted19/PLIST
Normal file
2599
net/py-twisted19/PLIST
Normal file
File diff suppressed because it is too large
Load diff
6
net/py-twisted19/distinfo
Normal file
6
net/py-twisted19/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2022/02/13 08:43:13 wiz Exp $
|
||||
|
||||
BLAKE2s (Twisted-19.10.0.tar.bz2) = f95c24cdc967cc543a3de66e2df20d8b4cf920bf281cc9817bd02213c067de0b
|
||||
SHA512 (Twisted-19.10.0.tar.bz2) = de8d7fd0b2081cebeff68b060c8469377011648bc563a94a993d3530fb007ed42c3a54925c9a10c465ee7a3065cc9108ace12d10d358223fab13494becb9ac4b
|
||||
Size (Twisted-19.10.0.tar.bz2) = 3118485 bytes
|
||||
SHA1 (patch-src_twisted_python___setup.py) = 3094320805707f13c64e0f9b4e2e67b5b26dac37
|
16
net/py-twisted19/patches/patch-src_twisted_python___setup.py
Normal file
16
net/py-twisted19/patches/patch-src_twisted_python___setup.py
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-src_twisted_python___setup.py,v 1.1 2022/02/13 08:43:13 wiz Exp $
|
||||
|
||||
Allow building with a c99 compiler on SunOS
|
||||
|
||||
--- src/twisted/python/_setup.py.orig 2019-11-02 16:29:27.000000000 +0000
|
||||
+++ src/twisted/python/_setup.py
|
||||
@@ -355,8 +355,7 @@ class build_ext_twisted(build_ext.build_
|
||||
# https://stackoverflow.com/questions/1034587). See the documentation
|
||||
# of X/Open CAE in the standards(5) man page of Solaris.
|
||||
if sys.platform.startswith('sunos'):
|
||||
- self.define_macros.append(('_XOPEN_SOURCE', 1))
|
||||
- self.define_macros.append(('_XOPEN_SOURCE_EXTENDED', 1))
|
||||
+ self.define_macros.append(('_XOPEN_SOURCE', 600))
|
||||
|
||||
self.extensions = [
|
||||
x for x in self.conditionalExtensions if x.condition(self)
|
Loading…
Reference in a new issue