znapzend: update to 0.20.0
Changes: Version 0.20.0 / 2020-03-23 * build system switched to carton for better dependency tracking * docker version available in `oetiker/znapzend:master` see README.md for details * `--recursive` option for run-once datasets. * `--inherited` allow run-once on datasets with only an inherited plan. * `--focedSnapshotSuffix=x` for non generated snapshot suffix in run-once. * `--nodelay` temporarily ignore delays in backup plans for speedy debugging. * new `--features` * `sendRaw` to NOT decrypt datasets prior to sending * `skipIntermediates` do not send intermediate snapshots * `lowmemRecurse` trade memory for speed when running large recursive jobs * `zfsGetType` speed up recursive dataset handling ... see znapzend manual page for details. * znapzendzetup supports `--features` too * new options for znapzendztatz: `--inherited` and `--setup`
This commit is contained in:
parent
6f3dfbc940
commit
e6e380730d
5 changed files with 28 additions and 50 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.17 2019/08/11 13:23:21 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2020/04/29 20:15:33 wiedi Exp $
|
||||
|
||||
DISTNAME= znapzend-0.19.1
|
||||
PKGREVISION= 2
|
||||
DISTNAME= znapzend-0.20.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=oetiker/}
|
||||
|
||||
|
@ -14,7 +13,7 @@ GITHUB_TAG= v${PKGVERSION_NOREV}
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= # none
|
||||
USE_TOOLS+= perl gmake
|
||||
USE_TOOLS+= perl gmake autoreconf autoconf automake
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
|
@ -23,4 +22,8 @@ DEPENDS+= p5-Mojo-IOLoop-ForkCall>=0.17:../../devel/p5-Mojo-IOLoop-ForkCall
|
|||
DEPENDS+= p5-Scalar-List-Utils>=1.45:../../devel/p5-Scalar-List-Utils
|
||||
DEPENDS+= p5-Test-Harness>=3.35:../../devel/p5-Test-Harness
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoreconf --force --install --verbose --make
|
||||
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.15 2018/07/08 09:03:24 wiedi Exp $
|
||||
$NetBSD: distinfo,v 1.16 2020/04/29 20:15:33 wiedi Exp $
|
||||
|
||||
SHA1 (znapzend-0.19.1.tar.gz) = a9d08e7325c42c8e44e158bc83e048debef81b20
|
||||
RMD160 (znapzend-0.19.1.tar.gz) = a09787f27b7c3aeb20be6527c3daad416fbdf737
|
||||
SHA512 (znapzend-0.19.1.tar.gz) = 46cecb1d6a54dd92c87192d0d4dfa089f54dce4fa3260f9adfd0f059c1f61cafe90b9d09df122a0efad8f2443801fc3d5ce9e36c90abf56911d0763c12dd2412
|
||||
Size (znapzend-0.19.1.tar.gz) = 164991 bytes
|
||||
SHA1 (patch-Makefile.in) = 5ddb527ada8d3657f806d0731dd24856dde35cc7
|
||||
SHA1 (patch-lib_ZnapZend.pm) = a3c13d9cdb7a276df564794a62600801f26d42b8
|
||||
SHA1 (znapzend-0.20.0.tar.gz) = bbf71e30db16e0e27b1fd0b32496e55f33b88743
|
||||
RMD160 (znapzend-0.20.0.tar.gz) = bd8c5cc32e7382267e3b1c9f6c5ca67dfeb3ab28
|
||||
SHA512 (znapzend-0.20.0.tar.gz) = 5168b39d1cb21a9eddd49726f9e823ebbf449c73ee499a82ac8cf3b5a72be654054b01f42aa240d44e1ae644afb641e8d7e36aaeed45a46b7e4cd5c46d57bd0b
|
||||
Size (znapzend-0.20.0.tar.gz) = 165742 bytes
|
||||
SHA1 (patch-Makefile.am) = 9f6f4e936ef84b08131884699d0fb8399b4dc67c
|
||||
|
|
15
sysutils/znapzend/patches/patch-Makefile.am
Normal file
15
sysutils/znapzend/patches/patch-Makefile.am
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Makefile.am,v 1.1 2020/04/29 20:15:33 wiedi Exp $
|
||||
|
||||
thirdparty deps are provided by pkgsrc
|
||||
|
||||
--- Makefile.am.orig 2020-03-23 14:59:16.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -5,7 +5,7 @@ AUTOMAKE_OPTIONS = foreign
|
||||
|
||||
SUFFIXES = .1 .man .pm
|
||||
|
||||
-SUBDIRS = lib thirdparty
|
||||
+SUBDIRS = lib
|
||||
|
||||
BIN = bin/@PACKAGE@ bin/znapzendzetup bin/znapzendztatz
|
||||
PM := $(shell find lib/ -name "*.pm")
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.4 2016/03/17 00:26:16 wiedi Exp $
|
||||
thirdparty deps are provided by pkgsrc
|
||||
|
||||
--- Makefile.in.orig 2016-02-25 14:00:38.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -314,7 +314,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = foreign
|
||||
SUFFIXES = .1 .man .pm
|
||||
-SUBDIRS = thirdparty lib
|
||||
+SUBDIRS = lib
|
||||
BIN = bin/@PACKAGE@ bin/znapzendzetup bin/znapzendztatz
|
||||
PM := $(shell find lib/ -name "*.pm")
|
||||
MAN = man/znapzend.1 man/znapzendzetup.1 man/znapzendztatz.1
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-lib_ZnapZend.pm,v 1.1 2017/09/25 10:50:28 wiedi Exp $
|
||||
|
||||
Fix Mojo::Util::slurp is DEPRECATED
|
||||
https://github.com/oetiker/znapzend/pull/283
|
||||
--- lib/ZnapZend.pm.orig 2017-02-08 07:38:40.000000000 +0000
|
||||
+++ lib/ZnapZend.pm
|
||||
@@ -2,7 +2,8 @@ package ZnapZend;
|
||||
|
||||
use Mojo::Base -base;
|
||||
use Mojo::IOLoop::ForkCall;
|
||||
-use Mojo::Util qw(slurp);
|
||||
+use Mojo::File 'path';
|
||||
+use Mojo::Util;
|
||||
use Mojo::Log;
|
||||
use ZnapZend::Config;
|
||||
use ZnapZend::ZFS;
|
||||
@@ -573,7 +574,7 @@ my $daemonize = sub {
|
||||
my $pidFile = $self->pidfile || $self->defaultPidFile;
|
||||
|
||||
if (-f $pidFile){
|
||||
- chomp(my $pid = slurp $pidFile);
|
||||
+ chomp(my $pid = path($pidFile)->slurp);
|
||||
#pid is not empty and is numeric
|
||||
if ($pid && ($pid = int($pid)) && kill 0, $pid){
|
||||
die "I Quit! Another copy of znapzend ($pid) seems to be running. See $pidFile\n";
|
Loading…
Reference in a new issue