Convert to buildlink3.

This commit is contained in:
snj 2004-05-11 03:33:57 +00:00
parent 21a83360cf
commit e70ce482af
3 changed files with 27 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2003/08/09 10:59:06 seb Exp $
# $NetBSD: Makefile,v 1.17 2004/05/11 03:33:57 snj Exp $
DISTNAME= cim-3.30
CATEGORIES= lang
@ -8,12 +8,21 @@ MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.gnu.org/software/cim/cim.html
COMMENT= Simula compiler based on the C programming language
USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
INFO_FILES= cim.info
.include "../../lang/perl5/buildlink2.mk"
SUBST_CLASSES+= x
SUBST_STAGE.x= post-patch
SUBST_FILES.x= src/cimcomp.c
SUBST_SED.x= -e "s|SCC|\"${CC}\"|"
SUBST_SED.x+= -e "s|SCFLAGS|\"${CFLAGS} -I${PREFIX}/include\"|"
SUBST_SED.x+= -e "s|SLDFLAGS|\"-L${PREFIX}/lib -Wl,${RPATH_FLAG}${PREFIX}/lib\"|"
SUBST_SED.x+= -e "s|= LIBDIR|= \"${PREFIX}/lib\"|"
SUBST_SED.x+= -e "s|= INCLUDEDIR|= \"${PREFIX}/include\"|"
.include "../../lang/perl5/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2001/04/21 01:10:58 jtb Exp $
$NetBSD: distinfo,v 1.4 2004/05/11 03:33:57 snj Exp $
SHA1 (cim-3.30.tar.gz) = 8636ac8d1eaee793769051af60140af80b82b22f
Size (cim-3.30.tar.gz) = 416809 bytes
SHA1 (patch-aa) = f05149918e1a47017f9dbdcf0a3adaec6033a2b2
SHA1 (patch-ab) = 247f63ecbcccbafa84f1ae8b97a616d24591275d

13
lang/cim/patches/patch-ab Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2004/05/11 03:33:57 snj Exp $
--- src/Makefile.in.orig 2004-05-10 19:45:42.000000000 -0700
+++ src/Makefile.in 2004-05-10 19:46:20.000000000 -0700
@@ -355,7 +355,7 @@ maintainer-clean-generic clean mostlycle
cimcomp.o: cimcomp.c Makefile
- $(COMPILE) '-DSCC="$(SCC)"' '-DSCFLAGS="$(SCFLAGS)"' '-DSLDFLAGS="$(SLDFLAGS)"' '-DSLIBS="$(SLIBS)"' '-DLIBDIR="$(libdir)"' '-DINCLUDEDIR="$(includedir)"' -c $(srcdir)/cimcomp.c
+ $(COMPILE) '-DSLIBS="$(SLIBS)"' -c $(srcdir)/cimcomp.c
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.