firefox: limit what is noted as being a hack for NetBSD to NetBSD.

This is causing problems on fedora 31 which gets a function prototype
mismatch from this somehow.
This commit is contained in:
maya 2020-02-26 17:48:58 +00:00
parent d6b6004eab
commit e70f8a873e
2 changed files with 6 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.382 2020/02/21 15:13:12 ryoon Exp $
$NetBSD: distinfo,v 1.383 2020/02/26 17:48:58 maya Exp $
SHA1 (firefox-73.0.1.source.tar.xz) = 27948432e868f68951f885394c1165739d6902b3
RMD160 (firefox-73.0.1.source.tar.xz) = d95068e78604695e399b0cf7fa988869a5a33ac7
@ -7,7 +7,7 @@ Size (firefox-73.0.1.source.tar.xz) = 326596084 bytes
SHA1 (patch-aa) = 11060461fdaca5661e89651b8ded4a59d2abc4d7
SHA1 (patch-browser_app_profile_firefox.js) = 076cc2892547bac07fe907533f4e821f13f5738e
SHA1 (patch-build_moz.configure_rust.configure) = ee9e207e67709f3c9455b4d22f5f254890e99ca8
SHA1 (patch-config__make_system_wrappers.py) = 4e0a23d5b1f3a4fcb358ce319f6a2421be535375
SHA1 (patch-config__make_system_wrappers.py) = c17e03e6c0599f2d14de3688af8552c12bbc61ed
SHA1 (patch-dom_base_nsAttrName.h) = ac7ba441a3b27df2855cf2673eea36b1cb44ad49
SHA1 (patch-dom_media_CubebUtils.cpp) = 226821d961039ae5c9c50d8615757b73c6bcd80a
SHA1 (patch-gfx_angle_checkout_src_common_third__party_smhasher_src_PMurHash.cpp) = e458c9c8dc66edc69c1874734af28a77fc5e3993

View file

@ -1,15 +1,17 @@
$NetBSD: patch-config__make_system_wrappers.py,v 1.2 2019/12/03 14:21:20 ryoon Exp $
$NetBSD: patch-config__make_system_wrappers.py,v 1.3 2020/02/26 17:48:58 maya Exp $
This is a workaround for building firefox with clang from base,
with a conflict with __isinf(__x) in libc++ vs netbsd headers.
--- config/make-system-wrappers.py.orig 2019-12-02 12:22:52.000000000 +0000
+++ config/make-system-wrappers.py
@@ -7,6 +7,7 @@ import os
@@ -7,6 +7,9 @@ import os
from mozbuild.util import FileAvoidWrite
header_template = '''#pragma GCC system_header
+#ifdef __NetBSD__
+#define __isinf(x) __builtin_isinf(x)
+#endif
#pragma GCC visibility push(default)
{includes}
#pragma GCC visibility pop