php74: Fix build with ICU 68
This commit is contained in:
parent
5d92f03ff4
commit
e74f507a2a
7 changed files with 169 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2020/10/30 07:14:16 taca Exp $
|
||||
$NetBSD: distinfo,v 1.15 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
SHA1 (php-7.4.12.tar.xz) = d220ea35fefec870bd81e81116a178c57bb87321
|
||||
RMD160 (php-7.4.12.tar.xz) = 73c684b5b1acdd296b471fd89d06cb205cfd57ab
|
||||
|
@ -6,6 +6,12 @@ SHA512 (php-7.4.12.tar.xz) = 6c06fb74f8e479ead000b0e2e56602c217d012f1a80e47e1515
|
|||
Size (php-7.4.12.tar.xz) = 10311980 bytes
|
||||
SHA1 (patch-configure) = 5e9c9c06f6d819d5ba2832d648f41363f40f3108
|
||||
SHA1 (patch-disable-filter-url) = 0a2c19c18f089448a8d842e99738b292ab9e5640
|
||||
SHA1 (patch-ext_intl_breakiterator_codepointiterator__internal.cpp) = edca1147cda6dbbe809a2f0a4bdb20bbc08192ee
|
||||
SHA1 (patch-ext_intl_collator_collator__sort.c) = 2859c8b400aa3407b16487e571dd402d0ce3e896
|
||||
SHA1 (patch-ext_intl_dateformat_dateformat__attr.c) = 0311330874122cc29720a45a5294dd3b7dd75daa
|
||||
SHA1 (patch-ext_intl_normalizer_normalizer__normalize.c) = 183a7b82b951096542ff4d85e59ceb0bf9c07da6
|
||||
SHA1 (patch-ext_intl_timezone_timezone__class.cpp) = d89440cdb417607069b8e5bba00a9aa641efe966
|
||||
SHA1 (patch-ext_intl_timezone_timezone__methods.cpp) = 50fb08d6b2b79bb02e9770972ad9720225eef442
|
||||
SHA1 (patch-ext_phar_Makefile.frag) = 53ea5c58b0bc27d236118d5750a74b1cba43e5dd
|
||||
SHA1 (patch-ext_tidy_config.m4) = 380f4e8927582b2781faf58b17ad81b6dc967ba7
|
||||
SHA1 (patch-ext_xsl_php__xsl.h) = a9877bff7bacc77926a4541a0ac171c00ad1a627
|
||||
|
|
|
@ -0,0 +1,61 @@
|
|||
$NetBSD: patch-ext_intl_breakiterator_codepointiterator__internal.cpp,v 1.1 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
--- ext/intl/breakiterator/codepointiterator_internal.cpp.orig 2020-10-27 15:01:59.000000000 +0000
|
||||
+++ ext/intl/breakiterator/codepointiterator_internal.cpp
|
||||
@@ -58,7 +58,7 @@ CodePointBreakIterator& CodePointBreakIt
|
||||
return *this;
|
||||
}
|
||||
|
||||
- this->fText = utext_clone(this->fText, that.fText, FALSE, TRUE, &uec);
|
||||
+ this->fText = utext_clone(this->fText, that.fText, false, true, &uec);
|
||||
|
||||
//don't bother copying the character iterator, getText() is deprecated
|
||||
clearCurrentCharIter();
|
||||
@@ -78,17 +78,17 @@ CodePointBreakIterator::~CodePointBreakI
|
||||
UBool CodePointBreakIterator::operator==(const BreakIterator& that) const
|
||||
{
|
||||
if (typeid(*this) != typeid(that)) {
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
const CodePointBreakIterator& that2 =
|
||||
static_cast<const CodePointBreakIterator&>(that);
|
||||
|
||||
if (!utext_equals(this->fText, that2.fText)) {
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
- return TRUE;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
CodePointBreakIterator* CodePointBreakIterator::clone(void) const
|
||||
@@ -109,7 +109,7 @@ CharacterIterator& CodePointBreakIterato
|
||||
|
||||
UText *CodePointBreakIterator::getUText(UText *fillIn, UErrorCode &status) const
|
||||
{
|
||||
- return utext_clone(fillIn, this->fText, FALSE, TRUE, &status);
|
||||
+ return utext_clone(fillIn, this->fText, false, true, &status);
|
||||
}
|
||||
|
||||
void CodePointBreakIterator::setText(const UnicodeString &text)
|
||||
@@ -128,7 +128,7 @@ void CodePointBreakIterator::setText(UTe
|
||||
return;
|
||||
}
|
||||
|
||||
- this->fText = utext_clone(this->fText, text, FALSE, TRUE, &status);
|
||||
+ this->fText = utext_clone(this->fText, text, false, true, &status);
|
||||
|
||||
clearCurrentCharIter();
|
||||
}
|
||||
@@ -280,7 +280,7 @@ CodePointBreakIterator &CodePointBreakIt
|
||||
}
|
||||
|
||||
int64_t pos = utext_getNativeIndex(this->fText);
|
||||
- this->fText = utext_clone(this->fText, input, FALSE, TRUE, &status);
|
||||
+ this->fText = utext_clone(this->fText, input, false, true, &status);
|
||||
if (U_FAILURE(status)) {
|
||||
return *this;
|
||||
}
|
22
lang/php74/patches/patch-ext_intl_collator_collator__sort.c
Normal file
22
lang/php74/patches/patch-ext_intl_collator_collator__sort.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ext_intl_collator_collator__sort.c,v 1.1 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
--- ext/intl/collator/collator_sort.c.orig 2020-10-27 15:01:59.000000000 +0000
|
||||
+++ ext/intl/collator/collator_sort.c
|
||||
@@ -346,7 +346,7 @@ static void collator_sort_internal( int
|
||||
*/
|
||||
PHP_FUNCTION( collator_sort )
|
||||
{
|
||||
- collator_sort_internal( TRUE, INTERNAL_FUNCTION_PARAM_PASSTHRU );
|
||||
+ collator_sort_internal( true, INTERNAL_FUNCTION_PARAM_PASSTHRU );
|
||||
}
|
||||
/* }}} */
|
||||
|
||||
@@ -540,7 +540,7 @@ PHP_FUNCTION( collator_sort_with_sort_ke
|
||||
*/
|
||||
PHP_FUNCTION( collator_asort )
|
||||
{
|
||||
- collator_sort_internal( FALSE, INTERNAL_FUNCTION_PARAM_PASSTHRU );
|
||||
+ collator_sort_internal( false, INTERNAL_FUNCTION_PARAM_PASSTHRU );
|
||||
}
|
||||
/* }}} */
|
||||
|
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ext_intl_dateformat_dateformat__attr.c,v 1.1 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
--- ext/intl/dateformat/dateformat_attr.c.orig 2020-10-27 15:01:59.000000000 +0000
|
||||
+++ ext/intl/dateformat/dateformat_attr.c
|
||||
@@ -88,7 +88,7 @@ PHP_FUNCTION( datefmt_get_pattern )
|
||||
UChar value_buf[64];
|
||||
uint32_t length = USIZE( value_buf );
|
||||
UChar* value = value_buf;
|
||||
- zend_bool is_pattern_localized =FALSE;
|
||||
+ zend_bool is_pattern_localized =false;
|
||||
|
||||
DATE_FORMAT_METHOD_INIT_VARS;
|
||||
|
||||
@@ -131,7 +131,7 @@ PHP_FUNCTION( datefmt_set_pattern )
|
||||
size_t value_len = 0;
|
||||
int32_t slength = 0;
|
||||
UChar* svalue = NULL;
|
||||
- zend_bool is_pattern_localized =FALSE;
|
||||
+ zend_bool is_pattern_localized =false;
|
||||
|
||||
|
||||
DATE_FORMAT_METHOD_INIT_VARS;
|
||||
@@ -227,7 +227,7 @@ PHP_FUNCTION( datefmt_is_lenient )
|
||||
*/
|
||||
PHP_FUNCTION( datefmt_set_lenient )
|
||||
{
|
||||
- zend_bool isLenient = FALSE;
|
||||
+ zend_bool isLenient = false;
|
||||
|
||||
DATE_FORMAT_METHOD_INIT_VARS;
|
||||
|
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ext_intl_normalizer_normalizer__normalize.c,v 1.1 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
--- ext/intl/normalizer/normalizer_normalize.c.orig 2020-10-27 15:01:59.000000000 +0000
|
||||
+++ ext/intl/normalizer/normalizer_normalize.c
|
||||
@@ -90,7 +90,7 @@ static UBool intl_is_normalized(zend_lon
|
||||
const UNormalizer2 *norm = intl_get_normalizer(form, err);
|
||||
|
||||
if(U_FAILURE(*err)) {
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
return unorm2_isNormalized(norm, uinput, uinput_len, err);
|
||||
@@ -261,7 +261,7 @@ PHP_FUNCTION( normalizer_is_normalized )
|
||||
int uinput_len = 0;
|
||||
UErrorCode status = U_ZERO_ERROR;
|
||||
|
||||
- UBool uret = FALSE;
|
||||
+ UBool uret = false;
|
||||
|
||||
intl_error_reset( NULL );
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ext_intl_timezone_timezone__class.cpp,v 1.1 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
--- ext/intl/timezone/timezone_class.cpp.orig 2020-10-27 15:01:59.000000000 +0000
|
||||
+++ ext/intl/timezone/timezone_class.cpp
|
||||
@@ -325,7 +325,7 @@ static HashTable *TimeZone_get_debug_inf
|
||||
|
||||
int32_t rawOffset, dstOffset;
|
||||
UDate now = Calendar::getNow();
|
||||
- tz->getOffset(now, FALSE, rawOffset, dstOffset, uec);
|
||||
+ tz->getOffset(now, false, rawOffset, dstOffset, uec);
|
||||
if (U_FAILURE(uec)) {
|
||||
return debug_info;
|
||||
}
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ext_intl_timezone_timezone__methods.cpp,v 1.1 2020/11/08 23:51:18 otis Exp $
|
||||
|
||||
--- ext/intl/timezone/timezone_methods.cpp.orig 2020-10-27 15:01:59.000000000 +0000
|
||||
+++ ext/intl/timezone/timezone_methods.cpp
|
||||
@@ -95,7 +95,7 @@ U_CFUNC PHP_FUNCTION(intltz_from_date_ti
|
||||
RETURN_NULL();
|
||||
}
|
||||
|
||||
- tz = timezone_convert_datetimezone(tzobj->type, tzobj, FALSE, NULL,
|
||||
+ tz = timezone_convert_datetimezone(tzobj->type, tzobj, false, NULL,
|
||||
"intltz_from_date_time_zone");
|
||||
if (tz == NULL) {
|
||||
RETURN_NULL();
|
Loading…
Reference in a new issue