Adapt to using the pkg version of libtool rather than a private copy.
DTRT with INSTALL_{PROGRAM,DATA,SCRIPT}. Portlint: rename pkg to pilot-link-0.8.13, with dash before version.
This commit is contained in:
parent
7befe4b64d
commit
e754026789
4 changed files with 60 additions and 13 deletions
|
@ -1,22 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.10 1998/07/15 11:54:32 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.11 1998/07/17 20:59:41 tv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pilot-link.0.8.13
|
||||
PKGNAME= pilot-link-0.8.13
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= ftp://ryeham.ee.ryerson.ca/pub/PalmOS/
|
||||
|
||||
MAINTAINER= sommerfeld@alum.mit.edu
|
||||
|
||||
STRIPFLAG=
|
||||
GNU_CONFIGURE= yes
|
||||
BUILD_DEPENDS= ${PREFIX}/bin/libtool:../../devel/libtool
|
||||
|
||||
USE_PERL5= yes
|
||||
|
||||
# use "default" configure because overriding INSTALL_PROGRAM does the
|
||||
# wrong thing for libtool-based packages like pilot-link...
|
||||
|
||||
do-configure:
|
||||
@(cd ${WRKSRC} && CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
|
||||
INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
|
||||
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= LIBTOOL=${PREFIX}/bin/libtool \
|
||||
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
|
||||
INSTALL_DATA="${INSTALL_DATA}"
|
||||
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
19
comms/pilot-link/patches/patch-aa
Normal file
19
comms/pilot-link/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- configure.orig Fri Jul 17 16:01:39 1998
|
||||
+++ configure Fri Jul 17 16:03:49 1998
|
||||
@@ -1000,7 +1000,7 @@
|
||||
|
||||
|
||||
|
||||
-
|
||||
+if false; then
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(top_builddir)/libtool'
|
||||
|
||||
@@ -1063,6 +1063,7 @@
|
||||
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig \
|
||||
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
+fi
|
||||
|
||||
# Extract the first word of "ranlib", so it can be a program name with args.
|
||||
set dummy ranlib; ac_word=$2
|
31
comms/pilot-link/patches/patch-ab
Normal file
31
comms/pilot-link/patches/patch-ab
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- Makefile.in.orig Fri Jul 17 16:30:38 1998
|
||||
+++ Makefile.in Fri Jul 17 16:48:57 1998
|
||||
@@ -44,7 +44,7 @@
|
||||
libcclib = @libcclib@
|
||||
cclib = @cclib@
|
||||
|
||||
-INSTALL = $(LIBTOOL) @INSTALL@
|
||||
+INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
YACC = @YACC@
|
||||
@@ -112,12 +112,15 @@
|
||||
$(SHELL) ${srcdir}/scripts/mkinstalldirs $(bindir) $(includedir) $(libdir) $(pixdir) $(mandir1) $(mandir7)
|
||||
|
||||
install: $(EXECS) installdirs $(PILIB) $(PICCLIB)
|
||||
- $(INSTALL_DATA) $(PILIB) $(libdir)/libpisock.la
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(PILIB) $(libdir)/libpisock.la
|
||||
if test -n "$(PICCLIB)"; then \
|
||||
- $(INSTALL_DATA) $(PICCLIB) $(libdir)/libpicc.la; \
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(PICCLIB) $(libdir)/libpicc.la; \
|
||||
fi
|
||||
- for p in $(EXECS); do \
|
||||
- $(INSTALL_PROGRAM) $$p $(bindir)/$$p; \
|
||||
+ for p in $(CEXECS); do \
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(bindir)/$$p; \
|
||||
+ done
|
||||
+ for p in $(PERLEXECS); do \
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_SCRIPT) $$p $(bindir)/$$p; \
|
||||
done
|
||||
for h in include/*.h $(srcdir)/include/*.h include/*.hxx $(srcdir)/include/*.hxx; do \
|
||||
$(INSTALL_DATA) $$h $(includedir)/`basename $$h`; \
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 1998/07/15 11:54:32 agc Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 1998/07/17 20:59:41 tv Exp $
|
||||
bin/addresses
|
||||
bin/ccexample
|
||||
bin/debugsh
|
||||
|
@ -65,7 +65,6 @@ include/pi-todo.hxx
|
|||
include/pi-version.h
|
||||
lib/libpicc.a
|
||||
lib/libpisock.a
|
||||
lib/libpisock.la
|
||||
lib/libpisock.so.3.1
|
||||
lib/pix/b1.gif
|
||||
lib/pix/b2.gif
|
||||
|
|
Loading…
Reference in a new issue