without this patch it failed to compile on MacOS 10.6 in 64 bit mode
This commit is contained in:
parent
6088a87f49
commit
e7821cc4c7
2 changed files with 45 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.19 2007/10/11 18:25:19 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.20 2010/02/20 22:42:02 schwarz Exp $
|
||||
|
||||
SHA1 (libusb-0.1.12.tar.gz) = 599a5168590f66bc6f1f9a299579fd8500614807
|
||||
RMD160 (libusb-0.1.12.tar.gz) = 63848df717e00fff67ab30ba86a85466370d4e8e
|
||||
|
@ -8,3 +8,4 @@ SHA1 (patch-ab) = bc4756536ce7b2cc49d0c7c48c249f146f185839
|
|||
SHA1 (patch-ac) = cc92318e0979779f6ef03ee653bc94ee2b96a055
|
||||
SHA1 (patch-ad) = f81135a5f92bf0c2e1ca921368bd39482bd3b580
|
||||
SHA1 (patch-ae) = 49a01ebe66de4965f3611cf42db09703aa68c415
|
||||
SHA1 (patch-af) = e6771da24e1a695a8c7029f97a9c0d42aa23f5e5
|
||||
|
|
43
devel/libusb/patches/patch-af
Normal file
43
devel/libusb/patches/patch-af
Normal file
|
@ -0,0 +1,43 @@
|
|||
$NetBSD: patch-af,v 1.1 2010/02/20 22:42:02 schwarz Exp $
|
||||
|
||||
--- darwin.c.orig 2010-02-20 23:22:35.000000000 +0100
|
||||
+++ darwin.c 2010-02-20 23:36:10.000000000 +0100
|
||||
@@ -254,7 +254,7 @@
|
||||
|
||||
result = IOCreatePlugInInterfaceForService(usbDevice, kIOUSBDeviceUserClientTypeID,
|
||||
kIOCFPlugInInterfaceID, &plugInInterface,
|
||||
- &score);
|
||||
+ (SInt32*)&score);
|
||||
|
||||
result = IOObjectRelease(usbDevice);
|
||||
if (result || !plugInInterface)
|
||||
@@ -557,7 +557,7 @@
|
||||
result = IOCreatePlugInInterfaceForService(usbInterface,
|
||||
kIOUSBInterfaceUserClientTypeID,
|
||||
kIOCFPlugInInterfaceID,
|
||||
- &plugInInterface, &score);
|
||||
+ &plugInInterface, (SInt32*)&score);
|
||||
/* No longer need the usbInterface object after getting the plug-in */
|
||||
result = IOObjectRelease(usbInterface);
|
||||
if (result || !plugInInterface)
|
||||
@@ -758,7 +758,7 @@
|
||||
|
||||
/* argument to handle multiple parameters to rw_completed */
|
||||
struct rw_complete_arg {
|
||||
- UInt32 io_size;
|
||||
+ unsigned long io_size;
|
||||
IOReturn result;
|
||||
CFRunLoopRef cf_loop;
|
||||
};
|
||||
@@ -769,9 +769,9 @@
|
||||
|
||||
if (usb_debug > 2)
|
||||
fprintf(stderr, "io async operation completed: %s, size=%lu, result=0x%08x\n", darwin_error_str(result),
|
||||
- (UInt32)io_size, result);
|
||||
+ (unsigned long)io_size, result);
|
||||
|
||||
- rw_arg->io_size = (UInt32)io_size;
|
||||
+ rw_arg->io_size = (unsigned long)io_size;
|
||||
rw_arg->result = result;
|
||||
|
||||
CFRunLoopStop(rw_arg->cf_loop);
|
Loading…
Reference in a new issue