Initial import of lbrate 1.1 into the NetBSD packages collection

as archivers/lbrate.

lbrate extracts/decompresses files from the CP/M LBR format. (It can also list
and test such archives.) It does this in an `unzip'-like manner, mostly hiding
the details of individually compressed and renamed files, and transparently
dealing with the required decompression/renaming.

From the FreeBSD ports collection.
This commit is contained in:
cjep 2002-12-13 17:50:50 +00:00
parent 07c55f14c0
commit e783605514
5 changed files with 74 additions and 0 deletions

9
archivers/lbrate/DESCR Normal file
View file

@ -0,0 +1,9 @@
lbrate extracts/decompresses files from the CP/M LBR format. (It can also list
and test such archives.) It does this in an `unzip'-like manner, mostly hiding
the details of individually compressed and renamed files, and transparently
dealing with the required decompression/renaming.
lbrate is apparently the only non-CP/M program to fully support
decompressing files from all three CP/M compression schemes (Q, Z, Y). With
this in mind, it can decompress such files directly, treating them as if they
were single-entry LBRs.

21
archivers/lbrate/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/12/13 17:50:50 cjep Exp $
# FreeBSD Id: ports/archivers/lbrate/Makefile,v 1.4 2002/06/19 08:18:05 sobomax Exp
DISTNAME= lbrate-1.1
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.ibiblio.org/pub/Linux/utils/compress/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://rus.members.beeb.net/lbrate.html
COMMENT= Extract/decompress CP/M LBR archives
USE_BUILDLINK2= YES
MAKE_FLAGS+= PREFIX=${PREFIX}
LBRATE_DOCSDIR= ${PREFIX}/share/doc/lbrate
post-install:
@${INSTALL_DATA_DIR} ${LBRATE_DOCSDIR}
for f in COPYING ChangeLog README TODO; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${LBRATE_DOCSDIR}; done
.include "../../mk/bsd.pkg.mk"

7
archivers/lbrate/PLIST Normal file
View file

@ -0,0 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/12/13 17:50:50 cjep Exp $
bin/lbrate
share/doc/lbrate/COPYING
share/doc/lbrate/ChangeLog
share/doc/lbrate/README
share/doc/lbrate/TODO
@dirrm share/doc/lbrate

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2002/12/13 17:50:50 cjep Exp $
SHA1 (lbrate-1.1.tar.gz) = 8731283e79fa6c7a73ebd6c821b42854cb864ea9
Size (lbrate-1.1.tar.gz) = 29907 bytes
SHA1 (patch-aa) = ad34e92fefc99c16fe067810d3ed6c160557e0ae

View file

@ -0,0 +1,32 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/12/13 17:50:50 cjep Exp $
--- Makefile.orig Thu Aug 30 17:03:17 2001
+++ Makefile
@@ -1,7 +1,8 @@
# Makefile - makefile for lbrate
CC=gcc
-CFLAGS=-O2 -Wall
+#CFLAGS=-O2 -Wall
+CFLAGS+=-Wall
# Set BINDIR to directory for binary,
# MANDIR to directory for man page.
@@ -19,14 +20,14 @@ OBJ=main.o readrle.o readhuff.o readlzw.
all: lbrate
lbrate: $(OBJ)
- $(CC) $(CFLAGS) -o lbrate $(OBJ)
+ $(CC) $(CFLAGS) -o lbrate $(OBJ) -L$(PREFIX)/lib -Wl,-R$(PREFIX)/lib
installdirs:
/bin/sh ./mkinstalldirs $(BINDIR) $(MANDIR)
install: lbrate installdirs
- install -m 755 lbrate $(BINDIR)
- install -m 644 lbrate.1 $(MANDIR)
+ install -c -m 755 lbrate $(BINDIR)
+ install -c -m 644 lbrate.1 $(MANDIR)
uninstall:
$(RM) $(BINDIR)/lbrate $(MANDIR)/lbrate.1