Update to 0.69:

NEW in 0.69:
==============
- Display messages in notification, not count of tweets. (Thomas Thurman)
- Use https, not http api. (Evan McClain)
- Fix incorrect pluralising of relative time. (Deskin Miller)
- Fixed #1998551, the double-escaping of < and >. (Mike Lundy)
- Fixed #1961611, character count behavior. (Brian Pepple)

NEW in 0.68:
==============
- Fixed #1963695, Save avatars a little more sensibly. (Brian Pepple)
- Use Enchant, instead of ASpell. (Brian Pepple)
- Add option to have sound notication when new tweets arrive . (Brian Pepple)
- Add help (Brian Pepple)

NEW in 0.65:
==============
- Add support for Online Accounts Service (Marina Zhurakhinskaya, Colin Walters)
  * More info about OAS can be found here: https://fedoraproject.org/wiki/Features/OnlineAccountsService
- Fixed #2122886, Fix date parsing on other than C/POSIX locale (Hiroshi Miura)
- Fixed #2083410, have textview in send message dialog get focus.
- Fixed #1961570, time issue w/ "1 hour" & "1 minute". (Derick Rethans)
- add Japanese translation (Hiroshi Miura)
This commit is contained in:
jmmv 2009-10-11 17:48:21 +00:00
parent b37aaa0e8f
commit e7896ede08
4 changed files with 27 additions and 9 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.4 2009/08/26 19:58:11 sno Exp $
# $NetBSD: Makefile,v 1.5 2009/10/11 17:48:21 jmmv Exp $
#
DISTNAME= twitux-0.62
PKGREVISION= 1
DISTNAME= twitux-0.69
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=twitux/}
EXTRACT_SUFX= .tar.bz2
@ -34,6 +33,7 @@ CONFIGURE_ARGS+= --enable-aspell=yes
CONFIGURE_ARGS+= --enable-aspell=no
.endif
.include "../../audio/libcanberra/buildlink3.mk"
.include "../../devel/GConf/schemas.mk"
.include "../../devel/libsexy/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
@ -42,6 +42,7 @@ CONFIGURE_ARGS+= --enable-aspell=no
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../sysutils/libnotify/buildlink3.mk"
.include "../../textproc/gnome-doc-utils/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,14 +1,19 @@
@comment $NetBSD: PLIST,v 1.2 2009/06/14 18:09:46 joerg Exp $
@comment $NetBSD: PLIST,v 1.3 2009/10/11 17:48:21 jmmv Exp $
bin/twitux
share/applications/twitux.desktop
share/gconf/schemas/twitux.schemas
share/gnome/help/twitux/C/figures/client.png
share/gnome/help/twitux/C/legal.xml
share/gnome/help/twitux/C/twitux.xml
share/icons/hicolor/48x48/apps/twitux.png
share/icons/hicolor/scalable/apps/twitux.svg
share/locale/de/LC_MESSAGES/twitux.mo
share/locale/es/LC_MESSAGES/twitux.mo
share/locale/fr/LC_MESSAGES/twitux.mo
share/locale/ja/LC_MESSAGES/twitux.mo
share/locale/pt/LC_MESSAGES/twitux.mo
share/locale/sv/LC_MESSAGES/twitux.mo
share/omf/twitux/twitux-C.omf
share/twitux/account_dlg.xml
share/twitux/add_friend_dlg.xml
share/twitux/lists_dlg.xml
@ -16,4 +21,3 @@ share/twitux/main_window.xml
share/twitux/prefs_dlg.xml
share/twitux/send_message_dlg.xml
share/twitux/spell_dlg.xml
share/twitux/tray_menu.xml

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2008/11/21 00:21:31 jmcneill Exp $
$NetBSD: distinfo,v 1.2 2009/10/11 17:48:21 jmmv Exp $
SHA1 (twitux-0.62.tar.bz2) = 5d4fe9db47ba9236ef5f1746ef3be80f2effc2ec
RMD160 (twitux-0.62.tar.bz2) = 29a66998ef375bad9bf2dbfba66bfdef9f428125
Size (twitux-0.62.tar.bz2) = 369539 bytes
SHA1 (twitux-0.69.tar.bz2) = 8693115c0016aec33c859fbaaf2557e6c3102160
RMD160 (twitux-0.69.tar.bz2) = 68ef7e357fa69618f80a1356f116aa3ad7cb08ea
Size (twitux-0.69.tar.bz2) = 474366 bytes
SHA1 (patch-aa) = 29fdb6fe216c4163290f9ce88a8a87b596bd56fc

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1 2009/10/11 17:48:21 jmmv Exp $
--- src/twitux-parser.c.orig 2009-01-25 02:25:56.000000000 +0000
+++ src/twitux-parser.c
@@ -27,6 +27,7 @@
* Just make sure we include the prototype for strptime as well
*/
#define _XOPEN_SOURCE
+#include <locale.h>
#include <time.h>
#include <string.h> /* for g_memmove - memmove */