Update jwm to 2.3.4.

Pkgsrc changes:

- use ${PREFIX} for icon path in example.jwmrc
- rename patch files per new format
- add patch comments
- take maintainership


Upstream changes list from
 http://joewing.net/projects/jwm/release-2.3.shtml

JWM v2.3 Release Notes

This is a collection of major changes between JWM v2.2 and JWM v2.3.
Version 2.3.0 was released 20150618.
You can download the latest snapshot of JWM here: jwm-1356.tar.xz.

New Features

  * Added support for client requested XRaiseWindow (issue #117).
  * Added native language support for the confirm dialog.
  * Added support for _NET_RESTACK_WINDOW (issue #118).
  * Added key binding to send the current window to a different desktop (issue
    #119).
  * Support the specification of an alternate configuration file (patch from
    Brian Bidulock)
  * Added Corner option to configure the roundedness of windows.
  * Updated the look of borders around menus and trays.
  * Add support for _NET_WM_MOVERESIZE (issue #142).
  * Add the fullscreen group option (patch from George Shaw).
  * Made window style configuration more consistent (may break old
    configuration files).
  * Add scale background type.
  * Added group options: nomin, nomax, noclose, nomove, noresize (issue #152),
    and nofullscreen (issue #163).
  * Added the Outline tag to MenuStyle to specify the color of menu outlines
    (issue #31).
  * Added the Outline tag to TrayStyle to specify the color of tray outlines.
  * To conform with GNU standards, running "make install" no longer strips the
    executable. To strip the executable, "make install?strip" can be used
    instead.
  * Added the ability to swallow the same client into a tray multiple times.
  * Added the ability to specify where the tray is hidden when auto-hide is
    enabled (issue #34).
  * Menu Includes are now loaded dynamically when a menu is shown rather than
    when JWM starts.
  * Added the sendu, sendd, sendl and sendr key bindings to send a window to a
    different desktop (issue #119).
  * Added the maxh, maxv, maxtop, maxbottom, maxleft and maxright key bindings
    (issues #120 and #157).
  * Added the ability to have separate actions per mouse button for tray
    buttons (issue #171). This is accomplished using the Button tag. For
    example:
    <TrayButton label="My Button">
      <Button mask="1">
        exec:program_for_left_click
      </Button>
      <Button mask="45">
        exec:program_for_scroll_wheel
      </Button>
    </TrayButton>
    The Button tags are optional. By default the action will use mouse button
    mask 123.
  * Add the ability to have separate actions per mouse button for clock tray
    components (issue #171) and the ability to have clock tray components run
    actions like tray buttons (issue #172).
  * Add support for more than 10 menus. Now 26 additional menus can be defined
    using the letters a through z.

Configuration Changes

The following XSLT is available to update JWM v2.2 configuration files for use
with JWM v2.3: jwm-2.3.xslt.

To convert an existing v2.2 configuration file using xsltproc, run:

cp ~/.jwmrc ~/.jwmrc.old
xsltproc jwm-2.3.xslt ~/.jwmrc.old > ~/.jwmrc

If you have multiple configuration files, it may be necessary to apply the XSLT
to some or all of them depending on what configuration options are stored in
the file.

A summary of configuration changes follows.

  * The ActiveBackground and ActiveForeground tags have been replaced by
    Background and Foreground under the Active tag. This applies to TrayStyle,
    TaskListStyle, TrayButtonStyle, PagerStyle, and MenuStyle.
  * The Inactive tag under WindowStyle has been removed. The tags that used to
    go within this tag now go directly under the WindowStyle tag.
  * The autohide attribute in Tray now determines where the tray should be
    hidden (left, right, top, bottom, or off) instead of true or false.
  * Now actions in the Clock tag must be prefixed with exec: to run an external
    program.

See the configuration documentation for documentation on all configuration
options.

Bug Fixes

  * ICCCM 2.0 WM_S selection compliance (patch from Brian Bidulock).
  * Fixed client window position after maximize/restore (issue #115, patch from
    Biran Bidulock).
  * Fixed window mapping bug with show desktop (issue #114).
  * Give focus to the top-most window after show desktop (issue #64).
  * Fix uninitialized memory when loading images (patch from Brian Bidulock).
  * Fix overlapping string issue with FriBidi (patch from Brian Bidulock).
  * Fixed non-UTF8 locales (issue #56).
  * Fixed transparency issue with some applications (issue #130).
  * Fixed focus after key events (patch from Brian Bidulock).
  * Fixed loss of focus after restoring windows (issue #131).
  * Fix setting of _NET_WM_STATE_HIDDEN when a window is minimized (issue #133,
    patch from Brian Bidulock).
  * Grab input focus at startup if not already set (issue #148).

Updated Translations

  * Russian (Aleksandr Samusenko)
  * French (Pierrick)
  * Italian (Flavio aka Man from Mars)
  * Spanish (Pablo Lezaeta)

Changes in 2.3.1 (20150628)

  * Added an option to group windows by class in the task bar. (the group
    attribute of the TrayStyle tag).
  * Fixed an issue with menus showing up across monitors when Xinerama is
    enabled.
  * Added the ability to show Motif-style handles on windows (the decorations
    attribute of WindowStyle).
  * Fixed an issue where the next/prev key bindings would not advance past a
    window that does not accept input focus.
  * Fixed the behavior of the Include tag within menus so that it no longer
    creates a submenu.
  * Menus included using Include are no longer loaded each time the menu is
    accessed.
  * Added a Dynamic submenu that will re-load its menu contents each time it is
    accessed.

Changes in 2.3.2 (20150913)

  * Restored the ability to specifiy that windows should not have an icon
    (using the "icon:" group option).
  * JWM will now try several common extensions when loading icons.
  * Fixed the height and default label for dynamic menus (issue #188).
  * Improved handling of colormaps for pseudo-color displays.
  * Fixed handling of WM_STATE on big-endian machines.
  * Fixed an issue with menus getting stuck open.
  * Removed the TaskListStyle, TrayButtonStyle, and ClockStyle configuration
    options. These options are now set from TrayStyle.
  * Added the Hungarian translation (from Hermit).
  * Added the ability to give a 3D look to menus and trays by specifying
    decorations="motif" in MenuStyle and TrayStyle respectively.
  * Fixed an issue where JWM key bindings would not be available to
    applications (issue #201).
  * JWM now highlights the first menu item when opening a menu with the
    keyboard (issue #102).
  * Add the ability to selectively enable popups (issue #189).
  * Various other fixes.

Changes in 2.3.3 (20151118)

  * JWM windows now set _NET_WM_WINDOW_TYPE (issue #223).
  * Added the Chinese translation (from Christopher Meng).
  * Added the height attribute to TaskList (issue #227).
  * Fixed tray button mouse bindings for the scroll wheel buttons (issue #229).
  * Added the restore key binding (issue #233).
  * Made middle-click on a task list item close the window (issue #232).
  * Added support for tooltips in menus (issue #111).
  * Added Portuguese (Brazil) translation (from Holmes).
  * Fixed an issue where the dock would change size if its size was not
    explicitly set (issue #238).
  * Fixed the height calculation of vertical trays (issue #228).

Changes in 2.3.4 (20151122)

  * Now a negative tray width/height can be specified to subtract from the
    screen width/height (issue #250).
  * Added the list configuration option to TrayStyle to allow displaying
    windows from all desktops (all) or only the current desktop (the default,
    desktop) in task lists.
  * Improved scaling of JPEG and SVG images (issue #253).
  * Fixed the rendering of fixed-aspect background images.
  * Added the drag group option (issue #235).
  * Fixed rendering of window borders without a title bar.
This commit is contained in:
tsutsui 2015-12-13 15:02:36 +00:00
parent ac6432a95e
commit e7b2179e5c
5 changed files with 40 additions and 31 deletions

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile,v 1.26 2014/06/01 14:28:16 tsutsui Exp $
# $NetBSD: Makefile,v 1.27 2015/12/13 15:02:36 tsutsui Exp $
#
DISTNAME= jwm-2.2.2
DISTNAME= jwm-2.3.4
CATEGORIES= wm x11
MASTER_SITES= http://www.joewing.net/programs/jwm/releases/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
MAINTAINER= tsutsui@NetBSD.org
HOMEPAGE= http://www.joewing.net/programs/jwm/
COMMENT= Lightweight window manager with virtual desktops
LICENSE= gnu-gpl-v2
@ -29,6 +29,11 @@ SUBST_STAGE.egdir= pre-configure
SUBST_FILES.egdir= Makefile.in
SUBST_SED.egdir= -e 's,@@EGDIR@@,${EGDIR},g'
SUBST_CLASSES+= icondir
SUBST_STAGE.icondir= post-patch
SUBST_FILES.icondir= example.jwmrc
SUBST_SED.icondir= -e 's|/usr/share/icons|${PREFIX}/share/icons|g'
PKG_SYSCONFSUBDIR= jwm
EGDIR= ${PREFIX}/share/examples/jwm
CONF_FILES= ${EGDIR}/system.jwmrc ${PKG_SYSCONFDIR}/system.jwmrc

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.9 2015/11/02 23:42:52 agc Exp $
$NetBSD: distinfo,v 1.10 2015/12/13 15:02:36 tsutsui Exp $
SHA1 (jwm-2.2.2.tar.xz) = a3c41acef393c9cba9a2ab9bf227ec0673586335
RMD160 (jwm-2.2.2.tar.xz) = bb073fae04e5d9273aefab49e1777de6f0dcc5ab
SHA512 (jwm-2.2.2.tar.xz) = 327a4d282fddfa032b1b8c82da76cbf60c019f8b8aa80c22402f8bf9f27af81720a5e4c4e506b980bbe8f546e104c73a504bd999d52106513e7bd0de0756dc34
Size (jwm-2.2.2.tar.xz) = 283884 bytes
SHA1 (patch-aa) = 49509dcc4c24c30ce8e01088d3ab1fedb50b31f9
SHA1 (patch-ab) = 2f71f1c641b244e8689c71e938d8372f47260911
SHA1 (jwm-2.3.4.tar.xz) = c37458ba5f5b676c2c374c45da5abe3e3c78246c
RMD160 (jwm-2.3.4.tar.xz) = a1b244c1a2cd4266b000939460a841c73f103cb7
SHA512 (jwm-2.3.4.tar.xz) = db9f46ced4b1f8128673b551cd865b6c9b6c8d43f839cfe898168251e8326d402a510ce77144273488c1e65a96d66e16124e4b4749a5a96a9057c1eb20c2bee1
Size (jwm-2.3.4.tar.xz) = 332140 bytes
SHA1 (patch-Makefile.in) = a458542a4c5330b4d2d3272b625943471830c968
SHA1 (patch-src_Makefile.in) = db9b310a04e0542fbbacaba7633bfd0a286d778c

View file

@ -1,6 +1,9 @@
$NetBSD: patch-aa,v 1.4 2014/01/19 15:27:16 tsutsui Exp $
$NetBSD: patch-Makefile.in,v 1.1 2015/12/13 15:02:36 tsutsui Exp $
--- Makefile.in.orig 2014-01-05 15:06:33.000000000 +0000
- put config files into the example dir
- use pkgsrc INSTALL_MACROS
--- Makefile.in.orig 2015-11-22 20:29:54.000000000 +0000
+++ Makefile.in
@@ -1,5 +1,5 @@
PACKAGE = jwm
@ -11,8 +14,8 @@ $NetBSD: patch-aa,v 1.4 2014/01/19 15:27:16 tsutsui Exp $
USE_NLS = @USE_NLS@
@@ -11,10 +11,10 @@ all:
install: all
cd src ; $(MAKE) install ; cd ..
cd po ; $(MAKE) install ; cd ..
$(MAKE) -C src install
$(MAKE) -C po install
- install -d -m 0755 $(SYSCONF)
- install -m 644 example.jwmrc $(SYSCONF)/system.jwmrc
- install -d -m 0755 $(MANDIR)/man1
@ -22,5 +25,5 @@ $NetBSD: patch-aa,v 1.4 2014/01/19 15:27:16 tsutsui Exp $
+ ${BSD_INSTALL_MAN_DIR} $(MANDIR)/man1
+ ${BSD_INSTALL_MAN} jwm.1 $(MANDIR)/man1/jwm.1
depend:
cd src ; $(MAKE) depend
install-strip: all install-conf
$(MAKE) -C src install-strip

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.4 2014/01/19 15:27:16 tsutsui Exp $
--- src/Makefile.in.orig 2014-01-05 15:06:33.000000000 +0000
+++ src/Makefile.in
@@ -22,9 +22,7 @@ EXE = jwm
all: $(EXE)
install: all
- install -d $(BINDIR)
- install $(EXE) $(BINDIR)/$(EXE)
- strip $(BINDIR)/$(EXE)
+ ${BSD_INSTALL_PROGRAM} $(EXE) $(BINDIR)/$(EXE)
depend:
makedepend -m -DMAKE_DEPEND -- $(CFLAGS) -- *.c

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_Makefile.in,v 1.1 2015/12/13 15:02:36 tsutsui Exp $
- use pkgsrc INSTALL_MACROS
--- src/Makefile.in.orig 2015-11-22 20:29:54.000000000 +0000
+++ src/Makefile.in
@@ -21,8 +21,7 @@ EXE = jwm
all: $(EXE)
install: all
- install -d $(BINDIR)
- install $(EXE) $(BINDIR)/$(EXE)
+ ${BSD_INSTALL_PROGRAM} $(EXE) $(BINDIR)/$(EXE)
install-strip: install
strip $(BINDIR)/$(EXE)