isect-1.0 -- open source middleware daemon

This commit is contained in:
jlam 1999-09-15 18:56:20 +00:00
parent 40e480e741
commit e7b35efba4
12 changed files with 291 additions and 0 deletions

39
devel/isect/Makefile Normal file
View file

@ -0,0 +1,39 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/09/15 18:56:20 jlam Exp $
#
DISTNAME= isect-1.0
CATEGORIES= devel
MASTER_SITES= ftp://home.netcom.com/pub/users/tgagne/
MAINTAINER= jlam@netbsd.org
HOMEPAGE= http://home.netcom.com/~tgagne/
DEPENDS+= libwww-5.1m1:../../www/libwww
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
CPPFLAGS+= -I${LOCALBASE}/include # for w3c-libwww/WWWlib.h
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
DOCDIR= ${PREFIX}/share/doc/isect
EGDIR= ${PREFIX}/share/examples/isect
post-install:
${INSTALL_DATA_DIR} ${DOCDIR}
for file in ${WRKSRC}/doc/*.html; do \
${INSTALL_DATA} $${file} ${DOCDIR}; \
done
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/COPYING ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/workers/isdecho.c ${EGDIR}
${SED} -e "s#@PREFIX@#${PREFIX}#g" \
-e "s#@ECHO@#${ECHO}#g" \
${FILESDIR}/isect.sh > ${WRKDIR}/isect.sh
${INSTALL_SCRIPT} ${WRKDIR}/isect.sh ${PREFIX}/etc/rc.d/
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,14 @@
#!/bin/sh
#
# $NetBSD: isect.sh,v 1.1.1.1 1999/09/15 18:56:21 jlam Exp $
#
isdexecd=@PREFIX@/sbin/isdexecd
isectd=@PREFIX@/sbin/isectd
if [ -x ${isdexecd} -a -x ${isectd} ]; then
@ECHO@ -n ' isect'
${isdexecd} &
${isectd} &
fi
exit 0

3
devel/isect/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/09/15 18:56:21 jlam Exp $
MD5 (isect-1.0.tar.gz) = 49c74196047aff03b756df89956d5f75

View file

@ -0,0 +1,5 @@
$NetBSD: patch-sum,v 1.1.1.1 1999/09/15 18:56:21 jlam Exp $
MD5 (patch-aa) = 752746d2b5fa41a6c5089dfdec4b94d2
MD5 (patch-ab) = c0af8cb5a050aaf651b00e2415439d39
MD5 (patch-ac) = 492db11be79977994f2d4c2dbe8df060

View file

@ -0,0 +1,39 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/09/15 18:56:22 jlam Exp $
--- configure.orig Fri Aug 20 06:16:18 1999
+++ configure Tue Sep 14 23:56:02 1999
@@ -1623,6 +1623,8 @@
fi
+# Use NetBSD's pkglibtool.
+if false; then
# Check for any special flags to pass to ltconfig.
libtool_flags="--cache-file=$cache_file"
test "$enable_shared" = no && libtool_flags="$libtool_flags --disable-shared"
@@ -1780,6 +1782,7 @@
# Redirect the config.log output again, so that the ltconfig log is not
# clobbered by the next message.
exec 5>>./config.log
+fi
echo $ac_n "checking for AIX""... $ac_c" 1>&6
echo "configure:1786: checking for AIX" >&5
@@ -2379,7 +2382,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lwww -static $LIBS"
+LIBS="-lwww -lz -static $LIBS"
cat > conftest.$ac_ext <<EOF
#line 2385 "configure"
#include "confdefs.h"
@@ -2407,7 +2410,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- LIBWWW="-lwww"
+ LIBWWW="-lwww -lz"
else
echo "$ac_t""no" 1>&6
LIBWWW=

View file

@ -0,0 +1,36 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/09/15 18:56:22 jlam Exp $
--- execd/Makefile.in.orig Mon Sep 13 21:59:48 1999
+++ execd/Makefile.in Wed Sep 15 00:09:07 1999
@@ -133,18 +133,18 @@
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(bindir)
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
@list='$(bin_PROGRAMS)'; for p in $$list; do \
if test -f $$p; then \
- echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
else :; fi; \
done
uninstall-binPROGRAMS:
@$(NORMAL_UNINSTALL)
list='$(bin_PROGRAMS)'; for p in $$list; do \
- rm -f $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ rm -f $(DESTDIR)$(sbindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
done
.c.o:
@@ -294,7 +294,7 @@
install-strip:
$(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
installdirs:
- $(mkinstalldirs) $(DESTDIR)$(bindir)
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
mostlyclean-generic:

View file

@ -0,0 +1,36 @@
$NetBSD: patch-ac,v 1.1.1.1 1999/09/15 18:56:22 jlam Exp $
--- isectd/Makefile.in.orig Mon Sep 13 21:59:53 1999
+++ isectd/Makefile.in Wed Sep 15 00:09:41 1999
@@ -142,18 +142,18 @@
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(bindir)
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
@list='$(bin_PROGRAMS)'; for p in $$list; do \
if test -f $$p; then \
- echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ echo " $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $$p $(DESTDIR)$(sbindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
else :; fi; \
done
uninstall-binPROGRAMS:
@$(NORMAL_UNINSTALL)
list='$(bin_PROGRAMS)'; for p in $$list; do \
- rm -f $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ rm -f $(DESTDIR)$(sbindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
done
.c.o:
@@ -466,7 +466,7 @@
install-strip:
$(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
installdirs:
- $(mkinstalldirs) $(DESTDIR)$(bindir)
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
mostlyclean-generic:

1
devel/isect/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
open source middleware daemon

25
devel/isect/pkg/DEINSTALL Normal file
View file

@ -0,0 +1,25 @@
#!/bin/sh
#
# $NetBSD: DEINSTALL,v 1.1.1.1 1999/09/15 18:56:21 jlam Exp $
#
PKGNAME=$1
case $2 in
DEINSTALL)
;;
POST-DEINSTALL)
/bin/cat << EOF
===========================================================================
If you won't be using ${PKGNAME} any longer, you may want to remove the
hostname alias to "isectd" and remove the isect services listed in
/etc/services.
===========================================================================
EOF
;;
*)
echo "Unexpected argument: $2"
exit 1
;;
esac
exit 0

13
devel/isect/pkg/DESCR Normal file
View file

@ -0,0 +1,13 @@
isectd is an open-source middleware daemon that simplifies the
implementation of distributed processing and client-server systems.
Using a familiar file IO-like programmer's interface it makes
multi-tier programming as easy as reading and writing.
Isect is short for intersect, a kind of table required in relational
databases to express many-to-many relationships. Distributed processing
implements process-oriented many-to-many relationships: many clients
communicating with many services. If it's mathmatically required for
data relationships then it's mathmatically required for process
relationships! This is the proof--and the reason you need isectd.
Questions and comments should be mailed to tgagne@ix.netcom.com.

35
devel/isect/pkg/INSTALL Normal file
View file

@ -0,0 +1,35 @@
#!/bin/sh
#
# $NetBSD: INSTALL,v 1.1.1.1 1999/09/15 18:56:21 jlam Exp $
#
case $2 in
PRE-INSTALL)
;;
POST-INSTALL)
/bin/cat << EOF
===========================================================================
You need to alias the hostname of the machine which will run isectd to
"isectd" on all the client machines, and add the following to
/etc/services:
#
# isect services
#
isectd 5501/tcp # isectd
isdexec 5502/tcp # isdexecd
The port number you specify should not conflict with any others that are
reserved.
You can start the isect daemon by editing /etc/rc.local to run
${PKG_PREFIX}/etc/rc.d/isect.sh.
===========================================================================
EOF
;;
*)
echo "Unexpected argument: $2"
exit 1
;;
esac
exit 0

45
devel/isect/pkg/PLIST Normal file
View file

@ -0,0 +1,45 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/09/15 18:56:21 jlam Exp $
bin/isdcfgck
bin/isdclient
bin/isdeat
bin/isdecho
etc/rc.d/isect.sh
include/isdio.h
include/libisect.h
include/queues.h
include/tabfuncs.h
@unexec install-info --delete %D/info/isect.info %D/info/dir
info/isect.info
@exec install-info %D/info/isect.info %D/info/dir
lib/libisdio.a
lib/libisdio.so.0.0
lib/libisect.a
lib/libisect.so.0.0
sbin/isdexecd
sbin/isectd
share/doc/isect/bugs.html
share/doc/isect/changes.html
share/doc/isect/index.html
share/doc/isect/isect_1.html
share/doc/isect/isect_10.html
share/doc/isect/isect_11.html
share/doc/isect/isect_12.html
share/doc/isect/isect_13.html
share/doc/isect/isect_14.html
share/doc/isect/isect_15.html
share/doc/isect/isect_16.html
share/doc/isect/isect_2.html
share/doc/isect/isect_3.html
share/doc/isect/isect_4.html
share/doc/isect/isect_5.html
share/doc/isect/isect_6.html
share/doc/isect/isect_7.html
share/doc/isect/isect_8.html
share/doc/isect/isect_9.html
share/doc/isect/isect_stoc.html
share/doc/isect/isect_toc.html
share/doc/isect/whatsnew.html
share/examples/isect/COPYING
share/examples/isect/isdecho.c
@dirrm share/examples/isect
@dirrm share/doc/isect