less: Update to 643

pkgsrc changes:
 - Remove patch-line.c: was a backport from upstream, no longer needed
 - Add patch-edit.c because several <signal.h> definitions are actually
   accessed on non-OS2 codepaths as well (noticed on NetBSD but should be
   relevant for all non-OS2 platforms)

Changes:
Major changes between "less" versions 633 and 643

* Fix problem when a program piping into less reads from the tty,
  like sudo asking for password (github #368).
* Fix search modifier ^E after ^W.
* Fix bug using negated (^N) search (github #374).
* Fix erroneous EOF when terminal window size changes (github #372).
* Fix compile error with some definitions of ECHONL (github #395).
* Fix regression in exit code when stdin is /dev/null and
  output is a file (github #373).
* Add lesstest test suite to production release (github #344).
* Change lesstest output to conform with
  automake Simple Test Format (github #399).

Major changes between "less" versions 632 and 633

* Fix build on systems which have ncurses/termcap.h or
  ncursesw/termcap.h but not termcap.h.

Major changes between "less" versions 608 and 632

* Add LESSUTFCHARDEF environment variable (github #275).
* Add # command (github #330).
* Add ^S search modifier (github #196).
* Add --wordwrap option (github #113).
* Add --no-vbell option (github #304).
* Add --no-search-headers option (github #44).
* Add --modelines option (github #89).
* Add --intr option (github #224).
* Add --proc-backspace, --proc-tab and --proc-return options (github #335).
* Add --show-preproc-errors option (github #258).
* Add LESS_LINES and LESS_COLUMNS environment variables (github #84).
* Add LESS_DATA_DELAY environment variable (github #337).
* Allow empty "lines" field in --header option.
* Update Unicode tables.
* Improve ability of ^X to interrupt F command (github #49).
* Status column (-J) shows off-screen matches.
* Parenthesized sub-patterns in searches are colored with unique colors,
  if supported by the regular expression library (github #196).
* Don't allow opening a tty as file input unless -f is set (github #309).
* Don't require newline input after +&... option (github #339).
* Fix incorrect handling of some Private Use Unicode characters.
* Fix ANSI color bug when overstriking with colored chars (github #276).
* Fix compiler const warning (github #279).
* Fix signal race in iread (github #280).
* Fix reading procfs files on Linux (github #282).
* Fix --ignore-case with ctrl-R (no regex) search (github #300).
* Fix bug doing repeat search after setting & filter (github #299).
* Fix bug doing repeat search before non-repeat search.
* Fix crash with -R and certain line lengths (github #338).
* Don't retain search options from a cancelled search (github #302).
* Don't call realpath on fake filenames like "-" (github #289).
* Implement lesstest test suite.
* Convert function parameter definitions from K&R to C89 (github #316).
This commit is contained in:
leot 2023-08-13 19:41:47 +00:00
parent b897cf03be
commit e7b7a68aad
5 changed files with 40 additions and 30 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.31 2023/02/07 20:32:34 wiz Exp $
# $NetBSD: Makefile,v 1.32 2023/08/13 19:41:47 leot Exp $
DISTNAME= less-608
PKGREVISION= 1
DISTNAME= less-643
CATEGORIES= misc
MASTER_SITES= http://www.greenwoodsoftware.com/less/

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.24 2023/02/07 20:32:34 wiz Exp $
$NetBSD: distinfo,v 1.25 2023/08/13 19:41:47 leot Exp $
BLAKE2s (less-608.tar.gz) = b96aedc410ad1072253e0e22da1d059a1396fda6f454f778df9b13388f88b007
SHA512 (less-608.tar.gz) = 7945b7f88921832ebb1b45fba8cbb449ee0133342796b654a52c146dfff3d84db18724ee84e53349eeea6017a0ebe2d8eb5366210275981dde7bb7190118fa66
Size (less-608.tar.gz) = 362346 bytes
SHA1 (patch-Makefile.in) = 4b47caa52dfb236da1b51a74902b98d7aa3237f4
SHA1 (patch-line.c) = 43116af39c37c14f6fa68999aee6ac4ee44d929c
BLAKE2s (less-643.tar.gz) = 6c9f9055090bf712d15fb8c8ab452d83d87ae2944d005687ca5ce974f7983c5d
SHA512 (less-643.tar.gz) = 6a324ac54e22429ac652dc303bc1fe48933555d1cbf8ad7ecf345940910c014fef9551a3219743cfb7115e356b5841ae97d6ce62e7a1ba1e3300d243efca34d9
Size (less-643.tar.gz) = 592291 bytes
SHA1 (patch-Makefile.in) = 30fede46998d4a256a46f8ca88d3ececcd751e92
SHA1 (patch-edit.c) = dccc8872c0a0e868d3c3b76a61f9fcd03f6d855e

View File

@ -1,10 +1,22 @@
$NetBSD: patch-Makefile.in,v 1.1 2022/09/15 11:02:14 leot Exp $
$NetBSD: patch-Makefile.in,v 1.2 2023/08/13 19:41:47 leot Exp $
Adjust GNU-isms to BSD-isms (ifneq is supported only by GNU make).
--- Makefile.in.orig 2022-07-22 19:26:24.000000000 +0000
--- Makefile.in.orig 2023-07-20 22:43:20.000000000 +0000
+++ Makefile.in
@@ -52,9 +52,9 @@ OBJ = \
@@ -16,9 +16,9 @@ LDFLAGS = @LDFLAGS@
CPPFLAGS = @CPPFLAGS@
EXEEXT = @EXEEXT@
O=o
-ifneq ($(strip $(LESSTEST)),)
+.ifdef LESSTEST
CPPFLAGS += -DLESSTEST
-endif
+.endif
LIBS = @LIBS@
@@ -55,9 +55,9 @@ OBJ = \
output.${O} pattern.${O} position.${O} prompt.${O} search.${O} signal.${O} \
tags.${O} ttyin.${O} version.${O} xbuf.${O} @REGEX_O@

View File

@ -0,0 +1,17 @@
$NetBSD: patch-edit.c,v 1.1 2023/08/13 19:41:47 leot Exp $
Unconditionally include <signal.h> due several SIG* references also
outside OS2 ifdef-s.
--- edit.c.orig 2023-07-20 22:43:14.000000000 +0000
+++ edit.c
@@ -16,9 +16,7 @@
#if HAVE_SYS_WAIT_H
#include <sys/wait.h>
#endif
-#if OS2
#include <signal.h>
-#endif
public int fd0 = 0;

View File

@ -1,18 +0,0 @@
$NetBSD: patch-line.c,v 1.1 2023/02/07 20:32:34 wiz Exp $
End OSC8 hyperlink on invalid embedded escape sequence.
https://github.com/gwsw/less/commit/a78e1351113cef564d790a730d657a321624d79c
--- line.c.orig 2022-07-22 19:26:24.000000000 +0000
+++ line.c
@@ -633,8 +633,8 @@ ansi_step(pansi, ch)
/* Hyperlink ends with \7 or ESC-backslash. */
if (ch == '\7')
return ANSI_END;
- if (pansi->prev_esc && ch == '\\')
- return ANSI_END;
+ if (pansi->prev_esc)
+ return (ch == '\\') ? ANSI_END : ANSI_ERR;
pansi->prev_esc = (ch == ESC);
return ANSI_MID;
}