Fix build on SunOS.

This commit is contained in:
hans 2011-04-14 19:01:26 +00:00
parent bb9eee5324
commit e7b91f3dda
3 changed files with 16 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2010/01/17 12:02:16 wiz Exp $
# $NetBSD: Makefile,v 1.7 2011/04/14 19:01:26 hans Exp $
#
DISTNAME= curlftpfs-0.9.1
@ -18,6 +18,7 @@ USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
CFLAGS.NetBSD+= -D_NETBSD_SOURCE
CFLAGS.SunOS+= --std=c99 -D__EXTENSIONS__
.include "../../devel/glib2/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2008/03/27 14:19:34 bjs Exp $
$NetBSD: distinfo,v 1.5 2011/04/14 19:01:26 hans Exp $
SHA1 (curlftpfs-0.9.1.tar.gz) = 768385f68f7e128ec9e852bbf7860a632e8e3c46
RMD160 (curlftpfs-0.9.1.tar.gz) = bb1a156160ff4bd517410f872f68ba77c8085b11
Size (curlftpfs-0.9.1.tar.gz) = 362542 bytes
SHA1 (patch-aa) = bfa05b8930560ffe25c3a2b12ff9497c0c5d37c4
SHA1 (patch-ab) = 011005bd7d8e230f825d44b31e7cde6fe45dc419

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.3 2011/04/14 19:01:27 hans Exp $
--- ftpfs.h.orig 2007-03-02 00:47:07.000000000 +0100
+++ ftpfs.h 2010-01-08 22:36:58.256798187 +0100
@@ -14,6 +14,7 @@
#include <pthread.h>
#include <glib.h>
#include <pthread.h>
+#include <limits.h>
struct ftpfs {
char* host;