Update scamper to 20110421.

patch provided by Matthew Luckie via PR#44919.

A lot of changed in scamper since 2008.
For some idea about what is in scamper today, please check the website,
in particular the scamper man page.
This commit is contained in:
obache 2011-04-30 11:35:26 +00:00
parent 24892ada30
commit e7e93c79ea
4 changed files with 44 additions and 30 deletions

View file

@ -1,24 +1,21 @@
# $NetBSD: Makefile,v 1.9 2011/04/15 08:34:00 obache Exp $
# $NetBSD: Makefile,v 1.10 2011/04/30 11:35:26 obache Exp $
#
DISTNAME= scamper-cvs-20100517
DISTNAME= scamper-cvs-20110421
PKGNAME= ${DISTNAME:S/-cvs//}
CATEGORIES= net
MASTER_SITES= http://www.wand.net.nz/scamper/
MAINTAINER= pkgsrc-users@NetBSD.org
MAINTAINER= mjl@luckie.org.nz
HOMEPAGE= http://www.wand.net.nz/scamper/
COMMENT= Dual-stack traceroute software
COMMENT= Tool for parallelised IPv4 and IPv6 measurement
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_FEATURES+= inet6
INSTALLATION_DIRS=bin
MAKE_FLAGS+= WITH_DEBUG=yes # recommended by the the software developer
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/scamper ${DESTDIR}${PREFIX}/bin
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +1,33 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/09/29 18:02:20 rpaulo Exp $
@comment $NetBSD: PLIST,v 1.2 2011/04/30 11:35:26 obache Exp $
bin/sc_ally
bin/sc_analysis_dump
bin/sc_attach
bin/sc_tracediff
bin/sc_warts2pcap
bin/sc_warts2text
bin/sc_wartscat
bin/sc_wartsdump
bin/sc_wartsfix
bin/scamper
include/scamper_addr.h
include/scamper_dealias.h
include/scamper_file.h
include/scamper_icmpext.h
include/scamper_list.h
include/scamper_neighbourdisc.h
include/scamper_ping.h
include/scamper_sniff.h
include/scamper_sting.h
include/scamper_tbit.h
include/scamper_trace.h
include/scamper_tracelb.h
lib/libscamperfile.la
man/man1/sc_ally.1
man/man1/sc_analysis_dump.1
man/man1/sc_attach.1
man/man1/sc_tracediff.1
man/man1/sc_warts2pcap.1
man/man1/sc_warts2text.1
man/man1/sc_wartscat.1
man/man1/sc_wartsdump.1
man/man1/scamper.1

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.5 2010/08/22 21:10:17 markd Exp $
$NetBSD: distinfo,v 1.6 2011/04/30 11:35:26 obache Exp $
SHA1 (scamper-cvs-20100517.tar.gz) = e6ca52ef702a5514e35e70992618567e4db1ffdd
RMD160 (scamper-cvs-20100517.tar.gz) = 4f46a3ed768232194e06ad9e6a623f6becae1df7
Size (scamper-cvs-20100517.tar.gz) = 373959 bytes
SHA1 (patch-aa) = e39ea36bc6a1d17ef4586011f88d2db0c9720ff3
SHA1 (scamper-cvs-20110421.tar.gz) = 283c995d5f293887174ad7cc7ce691e7e83a5568
RMD160 (scamper-cvs-20110421.tar.gz) = 890fa217d99fbb3c47cde677664db972f6382c9b
Size (scamper-cvs-20110421.tar.gz) = 1086507 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.3 2010/08/22 21:11:10 markd Exp $
--- scamper_firewall.c.orig 2010-05-06 22:54:22.000000000 +0000
+++ scamper_firewall.c
@@ -830,7 +830,7 @@ static void ipfw_cleanup(void)
#endif /* HAVE_IPFW */
-#if defined(HAVE_IPTABLES) || defined(__sun__) || defined(_WIN32)
+#if defined(HAVE_IPTABLES) || defined(__sun__) || defined(_WIN32) || defined(__NetBSD__)
static scamper_firewall_entry_t *firewall_entry_get(void)
{
return malloc_zero(sizeof(scamper_firewall_entry_t));